[PATCH 0/1] gnu: Add emacs-cpreproc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 9 Apr 2022 22:39
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220409203934.132657-1-plattfot@posteo.net
It's a simple helper tool for mostly C++ development, that I developed a few
years ago but finally got around to move out of my config. More info here
[0]. Thought I should share in case someone else might find it useful.


Fredrik Salomonsson (1):
gnu: Add emacs-cpreproc.

gnu/packages/emacs-xyz.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)


base-commit: 975966ba09e24d813cf94a794c4bd6375777372a
--
2.34.0
F
F
Fredrik Salomonsson wrote on 9 Apr 2022 22:42
[PATCH 1/1] gnu: Add emacs-cpreproc.
(address . 54827@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20220409204210.133564-1-plattfot@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-cpreproc): New variable.
---
gnu/packages/emacs-xyz.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 005f34e569..761dc64144 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -74,7 +74,7 @@
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
-;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
+;;; Copyright © 2020, 2022 Fredrik Salomonsson <plattfot@posteo.net>
;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
@@ -22095,6 +22095,30 @@ (define-public emacs-ccls
and @code{C++} files through the @code{ccls} language server.")
(license license:expat))))
+(define-public emacs-cpreproc
+ (package
+ (name "emacs-cpreproc")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~plattfot/cpreproc")
+ (commit version)))
+ (sha256
+ (base32
+ "0n4lhj9bbnkbzvifrj9q6z3j7z6jqzkaa36y239cfxdcc7i86c1c"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://sr.ht/~plattfot/cpreproc")
+ (synopsis "Wrap @code{C}/@code{C++} code in preprocessor macros.")
+ (description
+ "Aim for this project is to make it easier to generate preprocessor
+macros from Emacs for @code{C}/@code{C++} code that needs to be build
+against multiple incompatible versions of third party libraries or
+@code{C++} standards.")
+ (license license:gpl3+)))
+
(define-public emacs-org-brain
(package
(name "emacs-org-brain")
--
2.34.0
F
F
Fredrik Salomonsson wrote on 26 Apr 2022 20:34
Closing issue
(address . 54827-done@debbugs.gnu.org)
87fslzwv5s.fsf@d2.com
I see this got merged in commit:
cd5c31d192453c071d5384ea1eabbf02c9708758

Closing this issue.

And thanks!

--
s/Fred[re]+i[ck]+/Fredrik/g
Closed
L
L
Ludovic Courtès wrote on 26 Apr 2022 22:36
Re: bug#54827: [PATCH 0/1] gnu: Add emacs-cpreproc.
87k0bbk2fb.fsf_-_@gnu.org
help-debbugs@gnu.org (GNU bug Tracking System) skribis:

Toggle quote (3 lines)
> I see this got merged in commit:
> cd5c31d192453c071d5384ea1eabbf02c9708758

Oops, I forgot to close the issue; apologies!

Ludo’.
?