[PATCH 2/5] gnu: Add gtksourceview-5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
Merged with

Debbugs page

Alexandros Theodotou wrote 3 years ago
(address . guix-patches@gnu.org)(name . Alexandros Theodotou)(address . alex@zrythm.org)
20220409005346.69279-2-alex@zrythm.org
* gnu/packages/gtk.scm (gtksourceview-5): New variable.
---
gnu/packages/gtk.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 96297535ce..e8131bb955 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,6 +91,7 @@ (define-module (gnu packages gtk)
#:use-module (gnu packages linux)
#:use-module (gnu packages m4)
#:use-module (gnu packages man)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
@@ -618,6 +620,44 @@ (define-public gtksourceview
highlighting and other features typical of a source code editor.")
(license license:lgpl2.1+)))
+(define-public gtksourceview-5
+ (package (inherit gtksourceview)
+ (name "gtksourceview")
+ (version "5.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0dz6hifma60plbfqm4vlh1mps2z7f15rkkmflf5fra3hwqbw4fq0"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
+ (add-before
+ 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xorg-server (assoc-ref inputs "xorg-server")))
+ ;; Tests require a running X server.
+ (system (format #f "~a/bin/Xvfb :1 &" xorg-server))
+ (setenv "DISPLAY" ":1")
+ ;; For the missing /etc/machine-id.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ #t))))
+ #:configure-flags
+ ;; Needs newer gobject-introspection
+ '("-Dintrospection=disabled")))
+ (propagated-inputs
+ ;; gtksourceview-3.0.pc refers to all these.
+ (list glib gtk libxml2 pcre2))))
+
(define-public gtksourceview-3
(package (inherit gtksourceview)
(name "gtksourceview")
--
2.35.1
Liliana Marie Prikler wrote 3 years ago
(address . control@debbugs.gnu.org)
48479468a8115ac746ddfbee5a0d277c32f8f965.camel@gmail.com
merge 54805 54806 54807 54808 54809
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54806@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54806
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help