* guix/build/absolute-inclusions.scm: New file.
* Makefile.am (MODULES): Add it here.
---
Makefile.am | 1 +
guix/build/absolute-inclusions.scm | 59 ++++++++++++++++++++++++++++++
2 files changed, 60 insertions(+)
create mode 100644 guix/build/absolute-inclusions.scm
Toggle diff (79 lines)
diff --git a/Makefile.am b/Makefile.am
index fecce7c6f7..394df67016 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,6 +181,7 @@ MODULES = \
guix/diagnostics.scm \
guix/ui.scm \
guix/status.scm \
+ guix/build/absolute-inclusions.scm \
guix/build/android-ndk-build-system.scm \
guix/build/ant-build-system.scm \
guix/build/download.scm \
diff --git a/guix/build/absolute-inclusions.scm b/guix/build/absolute-inclusions.scm
new file mode 100644
index 0000000000..34aecf198a
--- /dev/null
+++ b/guix/build/absolute-inclusions.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Olivier Dion <olivier.dion@polymtl.ca>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build absolute-inclusions)
+ #:use-module (guix build utils)
+ #:use-module (ice-9 match)
+ #:use-module (rnrs exceptions)
+ #:export (absolute-inclusions patch-header-inclusions))
+
+(define (absolute-inclusions files header-locations)
+ (substitute* files
+ (("^[ \t]*#[ \t]*include[ \t]*<(.*)>[ \t]*" original header-name)
+ (guard (c ((search-error? c) original))
+ (format #f "#include <~a>"
+ (search-input-file header-locations
+ (string-append "include/" header-name)))))))
+
+(define header-file?
+ ;; See gcc(1) for the list of suffixes.
+ (let ((suffixes (list "h" "hh" "H" "hp" "hxx" "hpp" "HPP" "h++" "tcc")))
+ (file-name-predicate
+ (format #f "\\.(~a)$" (string-join suffixes "|" 'infix)))))
+
+(define (excluded-input? input)
+ ;; Exclude glibc to avoid increasing the closure size when a
+ ;; static library + binary is build. Likewise, exclude
+ ;; linux-libre-headers.
+ (match input
+ ((_ . store-item)
+ (or (file-exists? (string-append store-item "/include/stdlib.h"))
+ (directory-exists? (string-append store-item "/include/linux"))))))
+
+(define* (patch-header-inclusions #:key inputs outputs #:allow-other-keys)
+ "Patch inclusions in C headers in OUTPUTS to use absolute file names."
+ (define header-locations
+ (filter (negate excluded-input?) (append outputs inputs)))
+ (for-each (match-lambda
+ ((_ . output)
+ (absolute-inclusions
+ (find-files (string-append output "/include")
+ header-file?)
+ header-locations)))
+ outputs))
--
2.35.1