(name . bug-guix)(address . bug-guix@gnu.org)
Hi,
guix home reconfigure config.scm [1], throw error and freezes even
ctrl-c doesn't help
Uncaught exception in task:
In fibers.scm
150:0 9 (_)
In ice-9/boot-9.scm
1747:15 8 (with-exception-handler #<procedure 7c9c7efe1c60> at ic..>
...)
In shepherd.scm
439:9 7 (_)
In ice-9/boot-9.scm
1747:15 8 (with-exception-handler #<procedure 7f9c7efe1ba0> at ic..>
...)
In ice-9/exceptions.scm:
406:15 5 (_)
In ice-9/boot-9.scm:
1752:10 4 (with-exception-handler _ _ #:unwind? _ # _)
In shepherd.scm
502:23 3 (_)
In srfi/srfi-1.scm:
586:17 2 (map1 (#<<service> 7f9c80e0df30>))
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1683:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1683:16 In procedure raise-exception:
Zero values returned to single-valued continuation
[1]
(define-module (config)
#:use-module (gnu home)
#:use-module (gnu home services)
#:use-module (gnu home services fontutils)
#:use-module (gnu home services xdg)
#:use-module (gnu home services shells)
#:use-module (gnu home services shepherd)
#:use-module (gnu home services symlink-manager)
#:use-module (gnu services)
#:use-module (gnu packages)
#:use-module (gnu packages glib)
#:use-module (gnu packages admin)
#:use-module (gnu packages linux)
#:use-module (guix gexp)
#:use-module (guix packages))
(define (home-dbus-environment-variables-service _)
'(("DBUS_SESSION_BUS_ADDRESS" . "unix:path=$XDG_RUNTIME_DIR/dbus.sock")))
(define (home-dbus-shepherd-service _)
(list
(shepherd-service
(provision '(dbus-home))
(stop #~(make-kill-destructor))
(start #~(make-forkexec-constructor
(list #$(file-append dbus "/bin/dbus-daemon")
"--nofork"
"--session"
(string-append
"--address=" "unix:path="
(getenv "XDG_RUNTIME_DIR") "/dbus.sock"))
#:environment-variables
(append '("DISPLAY=wayland-0"
"WAYLAND_DISPLAY=wayland-0")
(environ)))))))
(define-public home-dbus-service-type
(service-type
(name 'home-dbus)
(extensions
(list (service-extension
home-environment-variables-service-type
home-dbus-environment-variables-service)
(service-extension
home-profile-service-type
(const (list dbus)))
(service-extension
home-shepherd-service-type
home-dbus-shepherd-service)))
(default-value #f)
(description "run dbus")))
(define home-env
(home-environment
(services
(list
(service home-dbus-service-type)
(service home-zsh-service-type
(home-zsh-configuration
(xdg-flavor? #t)
(zshrc (list (plain-file "zshrc" "stty -ixon")))))
(simple-service
'set-guix-env-vars
home-environment-variables-service-type
`(("GUIX_PROFILE" . "/home/akagi/.guix-profile")))))))
home-env
--
Best regards,
Aleksandr Vityazev