[PATCH] gnu: Add emacs-hledger-mode

  • Done
  • quality assurance status badge
Details
2 participants
  • Collin J. Doering
  • zimoun
Owner
unassigned
Submitted by
Collin J. Doering
Severity
normal

Debbugs page

Collin J. Doering wrote 3 years ago
(address . guix-patches@gnu.org)(name . Collin J. Doering)(address . collin@rekahsoft.ca)
20220407165442.23653-1-collin@rekahsoft.ca
* gnu/packages/finance.scm (emacs-hledger-mode): New variable
---
gnu/packages/finance.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9f2d055048..d6cd2981a6 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -73,6 +73,7 @@ (define-module (gnu packages finance)
#:use-module (gnu packages documentation)
#:use-module (gnu packages dns)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages emacs-xyz)
#:use-module (gnu packages dbm)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
@@ -455,6 +456,37 @@ (define-public emacs-ledger-mode
This package provides the Emacs mode.")
(license license:gpl2+)))
+(define-public emacs-hledger-mode
+ (let ((commit "9ac07ff0adbce6a402c17e789b1750f9da0d22f4")
+ (revision "1"))
+ (package
+ (name "emacs-hledger-mode")
+ (version (git-version "20210706.1225" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/narendraj9/hledger-mode")
+ (commit commit)))
+ (sha256
+ (base32
+ "0x3dgws8nh7q8x7zzjwbm5k9n7gi7qqd3ww7y51fbx6p6ii3jpp4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-popup" ,emacs-popup)
+ ("emacs-async" ,emacs-async)
+ ("emacs-htmlize" ,emacs-htmlize)))
+ (arguments
+ '(#:include '("^[^/]+.el$")
+ #:exclude '()))
+ (home-page "https://github.com/narendraj9/hledger-mode")
+ (synopsis "Mode for writing journal entries for hledger")
+ (description
+ "A major mode for writing hledger journal files. It generates some
+useful reports along with some financial ratios that can help you
+keep a check on your financial health. This is an attempt to
+organize personal finances for Emacs users. If you don not like this,
+try @code{emacs-ledger-mode}.")
+ (license license:gpl3))))
+
(define-public geierlein
(package
(name "geierlein")
--
2.34.0
Collin J. Doering wrote 3 years ago
Follow up: this issue didn't appear on mumi
(address . 54771@debbugs.gnu.org)
87ilrkuzpv.fsf@rekahsoft.ca
For some reason I haven't seen this issue appear on Guix's Mumi instance (https://issues.guix.gnu.org), however it appears that it was successfully received.

Sending this email as I suspect it will make this bug ticket show up in mumi.

--
Collin J. Doering

zimoun wrote 3 years ago
(name . Collin J. Doering)(address . collin@rekahsoft.ca)(address . 54771@debbugs.gnu.org)
CAJ3okZ2reV7biqzEEvp52fJ9+9eD1SiP6pzhu4o6kK_vpcouZA@mail.gmail.com
Hi,

On Fri, 8 Apr 2022 at 03:33, Collin J. Doering via Guix-patches via
<guix-patches@gnu.org> wrote:

Toggle quote (2 lines)
> For some reason I haven't seen this issue appear on Guix's Mumi instance (https://issues.guix.gnu.org), however it appears that it was successfully received.

The synchronisation of the instance Mumi can vary. It is probably
what you observed.

Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54771@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54771
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help