[PATCH 0/3] Add ledger-autosync and required dependencies

  • Open
  • quality assurance status badge
Details
One participant
  • Collin J. Doering
Owner
unassigned
Submitted by
Collin J. Doering
Severity
normal
C
C
Collin J. Doering wrote on 7 Apr 2022 18:18
(address . guix-patches@gnu.org)
87bkxcooby.fsf@rekahsoft.ca
Hi Guix community,

Below is an incoming patch series which adds the 'ledger-autosync' tool as well as missing dependencies.

Collin J. Doering (3):
gnu: Add python-ofxhome
gnu: Add python-ofxclient
gnu: Add ledger-autosync

gnu/packages/finance.scm | 17 +++++++++++++
gnu/packages/python-xyz.scm | 49 +++++++++++++++++++++++++++++++++++++
2 files changed, 66 insertions(+)


base-commit: 7409f246e2b0be9a2b3b6ae246385f3f197e5fbb

--
Collin J. Doering

C
C
Collin J. Doering wrote on 7 Apr 2022 18:29
[PATCH 1/3] gnu: Add python-ofxhome
(address . 54768@debbugs.gnu.org)(name . Collin J. Doering)(address . collin@rekahsoft.ca)
20220407162941.29133-1-collin@rekahsoft.ca
* gnu/packages/python-xyz.scm (python-ofxhome): New variable
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55705ab2ea..dba7a88188 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28504,6 +28504,26 @@ (define-public python-ofxparse
statements in OFX files.")
(license license:expat)))
+(define-public python-ofxhome
+ (package
+ (name "python-ofxhome")
+ (version "0.3.3")
+ ;; Source from git instead of pypi as test data is not included in pypi tarball
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/captin411/ofxhome")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n1vvdjwzxfprqapcxj7c44m0gp5w23qsdna550ghsdfv09rnplb"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/captin411/ofxhome")
+ (synopsis "REST client for ofxhome.com financial institution lookups")
+ (description "REST client for ofxhome.com financial institution lookups.")
+ (license license:expat)))
+
(define-public python-stripe
(package
(name "python-stripe")
--
2.34.0
C
C
Collin J. Doering wrote on 7 Apr 2022 18:29
[PATCH 2/3] gnu: Add python-ofxclient
(address . 54768@debbugs.gnu.org)(name . Collin J. Doering)(address . collin@rekahsoft.ca)
20220407162941.29133-2-collin@rekahsoft.ca
* gnu/packages/python-xyz.scm (python-ofxclient): New variable
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dba7a88188..043933a3f3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28524,6 +28524,35 @@ (define-public python-ofxhome
(description "REST client for ofxhome.com financial institution lookups.")
(license license:expat)))
+(define-public python-ofxclient
+ (package
+ (name "python-ofxclient")
+ (version "2.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ofxclient" version))
+ (sha256
+ (base32
+ "0jdhqsbl34yn3n0x6mwsnl58c25v5lp6vr910c2hk7l74l5y7538"))))
+ (build-system python-build-system)
+ (propagated-inputs `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-keyring" ,python-keyring)
+ ("python-lxml" ,python-lxml)
+ ("python-ofxhome" ,python-ofxhome)
+ ("python-ofxparse" ,python-ofxparse)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ;; tests fail unless argparse is explicitly removed from setup.py
+ ;; this has no impact as argparse is included in python 2.7+
+ ((".*['\"]argparse['\"],.*") "")) #t)))))
+ (home-page "https://github.com/captin411/ofxclient")
+ (synopsis "OFX client for dowloading transactions from banks")
+ (description "OFX client for dowloading transactions from banks.")
+ (license license:expat)))
+
(define-public python-stripe
(package
(name "python-stripe")
--
2.34.0
C
C
Collin J. Doering wrote on 7 Apr 2022 18:29
[PATCH 3/3] gnu: Add ledger-autosync
(address . 54768@debbugs.gnu.org)(name . Collin J. Doering)(address . collin@rekahsoft.ca)
20220407162941.29133-3-collin@rekahsoft.ca
* gnu/packages/finance.scm (ledger-autosync): New variable
---
gnu/packages/finance.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9f2d055048..1b23379a30 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -394,6 +394,23 @@ (define-public ledger
"file://src/wcwidth.cc"
"See src/wcwidth.cc in the distribution.")))))
+(define-public ledger-autosync
+ (package
+ (name "ledger-autosync")
+ (version "1.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ledger-autosync" version))
+ (sha256
+ (base32
+ "0i4942qbsphq72zx7kd3rgw25rpq4fg4vl43akkl189wzcrgwv6j"))))
+ (build-system python-build-system)
+ (inputs (list python-ofxclient python-ofxparse))
+ (home-page "https://gitlab.com/egh/ledger-autosync")
+ (synopsis "Automatically sync your bank's data with ledger")
+ (description "Automatically sync your bank's data with ledger")
+ (license license:gpl3)))
+
(define-public emacs-ledger-mode
(package
(name "emacs-ledger-mode")
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54768@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54768
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch