[PATCH] gnu: strawberry: Update to 1.0.3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Brendan Tildesley
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 3 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20220403202131.9742-1-mike@rohleder.de
* gnu/packages/music.scm (strawberry): Update to 1.0.3.
---
gnu/packages/music.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3e3829cefe..89d64957c8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -470,7 +470,7 @@ (define-public clementine
(define-public strawberry
(package
(name "strawberry")
- (version "1.0.1")
+ (version "1.0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -479,7 +479,7 @@ (define-public strawberry
(file-name (git-file-name name version))
(sha256
(base32
- "077dlj0kjcrj4g1h4w8finzykizaar67ik6yng6c8zjp2i5bam1j"))
+ "14fr2bm51k4n5byc9pwh3ba6v15s9jmqxigl1y9h00l7cvmfpbn1"))
(modules '((guix build utils)
(ice-9 regex)))
(snippet
--
2.34.0
Brendan Tildesley wrote 3 years ago
69b1a6d3-4cab-a98e-2e70-a8a5cfcd91d8@brendan.scot
It does not compile for me.


In file included from
/tmp/guix-build-strawberry-1.0.3.drv-0/source/src/core/mergedproxymodel.cpp:40:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:
In member function
‘boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred,
SuperMeta, TagList, Category>::iterator
boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred,
SuperMeta, TagList, Category>::find(const CompatibleKey&, const
CompatibleHash&, const CompatiblePred&) const’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:17:
error: ‘promotes_1st_arg’ was not declared in this scope
  542 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
      |                 ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:48:
error: expected primary-expression before ‘,’ token
  542 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
      |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:62:
error: expected primary-expression before ‘,’ token
  542 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:71:
error: expected primary-expression before ‘>’ token
  542 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:542:73:
error: expected primary-expression before ‘)’ token
  542 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:
In member function
‘boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred,
SuperMeta, TagList, Category>::size_type
boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred,
SuperMeta, TagList, Category>::count(const CompatibleKey&, const
CompatibleHash&, const CompatiblePred&) const’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:17:
error: ‘promotes_1st_arg’ was not declared in this scope
  559 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
      |                 ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:48:
error: expected primary-expression before ‘,’ token
  559 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
      |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:62:
error: expected primary-expression before ‘,’ token
  559 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:71:
error: expected primary-expression before ‘>’ token
  559 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:559:73:
error: expected primary-expression before ‘)’ token
  559 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:
In member function
‘std::pair<boost::multi_index::detail::hashed_index_iterator<boost::multi_index::detail::hashed_index_node<typename
SuperMeta::type::index_node_type>,
boost::multi_index::detail::bucket_array<typename
SuperMeta::type::final_allocator_type>, Category,
boost::multi_index::detail::hashed_index_global_iterator_tag>,
boost::multi_index::detail::hashed_index_iterator<boost::multi_index::detail::hashed_index_node<typename
SuperMeta::type::index_node_type>,
boost::multi_index::detail::bucket_array<typename
SuperMeta::type::final_allocator_type>, Category,
boost::multi_index::detail::hashed_index_global_iterator_tag> >
boost::multi_index::detail::hashed_index<KeyFromValue, Hash, Pred,
SuperMeta, TagList, Category>::equal_range(const CompatibleKey&, const
CompatibleHash&, const CompatiblePred&) const’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:17:
error: ‘promotes_1st_arg’ was not declared in this scope
  576 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
      |                 ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:48:
error: expected primary-expression before ‘,’ token
  576 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
      |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:62:
error: expected primary-expression before ‘,’ token
  576 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:71:
error: expected primary-expression before ‘>’ token
  576 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/hashed_index.hpp:576:73:
error: expected primary-expression before ‘)’ token
  576 |
k,hash,eq,promotes_1st_arg<CompatiblePred,CompatibleKey,key_type>());
| ^
In file included from
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_impl.hpp:65,
                 from
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/ordered_index.hpp:17,
                 from
/tmp/guix-build-strawberry-1.0.3.drv-0/source/src/core/mergedproxymodel.cpp:44:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:
In function ‘Node* boost::multi_index::detail::ordered_index_find(Node*,
Node*, const KeyFromValue&, const CompatibleKey&, const
CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:74:7:
error: ‘promotes_1st_arg’ was not declared in this scope
   74 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
      |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:74:64:
error: template argument 1 is invalid
   74 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:7:
error: ‘promotes_2nd_arg’ was not declared in this scope
   75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
      |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:41:
error: expected primary-expression before ‘,’ token
   75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
      |                                         ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:50:
error: expected primary-expression before ‘,’ token
   75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
      |                                                  ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:64:
error: expected primary-expression before ‘>’ token
   75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:66:
error: expected primary-expression before ‘>’ token
   75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:75:68:
error: expected primary-expression before ‘)’ token
   75 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:
In function ‘Node*
boost::multi_index::detail::ordered_index_lower_bound(Node*, Node*,
const KeyFromValue&, const CompatibleKey&, const CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:5:
error: ‘promotes_2nd_arg’ was not declared in this scope
  123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
      |     ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:39:
error: expected primary-expression before ‘,’ token
  123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
      |                                       ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:48:
error: expected primary-expression before ‘,’ token
  123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
      |                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:62:
error: expected primary-expression before ‘>’ token
  123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:123:64:
error: expected primary-expression before ‘)’ token
  123 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey>());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:
In function ‘Node*
boost::multi_index::detail::ordered_index_upper_bound(Node*, Node*,
const KeyFromValue&, const CompatibleKey&, const CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:5:
error: ‘promotes_1st_arg’ was not declared in this scope
  169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
      |     ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:39:
error: expected primary-expression before ‘,’ token
  169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
      |                                       ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:53:
error: expected primary-expression before ‘,’ token
  169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
      |                                                     ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:62:
error: expected primary-expression before ‘>’ token
  169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
|                                                              ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:169:64:
error: expected primary-expression before ‘)’ token
  169 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:
In function ‘std::pair<Node*, Node*>
boost::multi_index::detail::ordered_index_equal_range(Node*, Node*,
const KeyFromValue&, const CompatibleKey&, const CompatibleCompare&)’:
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:216:7:
error: ‘promotes_1st_arg’ was not declared in this scope
  216 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
      |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:216:64:
error: template argument 1 is invalid
  216 | promotes_1st_arg<CompatibleCompare,CompatibleKey,key_type>,
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:7:
error: ‘promotes_2nd_arg’ was not declared in this scope
  217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
      |       ^~~~~~~~~~~~~~~~
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:41:
error: expected primary-expression before ‘,’ token
  217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
      |                                         ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:50:
error: expected primary-expression before ‘,’ token
  217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
      |                                                  ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:64:
error: expected primary-expression before ‘>’ token
  217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
|                                                                ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:66:
error: expected primary-expression before ‘>’ token
  217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
| ^
/gnu/store/f5l9m0dspdjxspdrnvfs4p0rncdhyigf-boost-1.77.0/include/boost/multi_index/detail/ord_index_ops.hpp:217:68:
error: expected primary-expression before ‘)’ token
  217 | promotes_2nd_arg<CompatibleCompare,key_type,CompatibleKey> >());
Michael Rohleder wrote 3 years ago
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 54700@debbugs.gnu.org)
877d83mp3b.fsf@rohleder.de
Brendan Tildesley <mail@brendan.scot> writes:
Toggle quote (2 lines)
> It does not compile for me.

Weird. I just build (and run) it successfully (again):
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmJMeHgRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyUAmwf/ZIV+t2D6xXg7NA8JNDKd3RerPcMizxYG
Ku9uY0Z5oc/TS9p6SB6rEKtQVoa6IWNR3woGva5bkIK5hMv8JF0XsvR70Qij51+N
RNvhWptRbCPO2F4p3AVZMsPtG5i1H1Z+Jczik1rlJQQLLcyD1bcCiNUdMX6TfITs
l5hcN1WSLlGa9hD1DOXGhpQZlONdYxa4Acn6BV+npRiv9+iG30aAhdk9N0DJKU5m
BkK/er7ca7XuxgbCZW/0r4msiqRGErMUIUTR/7TJ+pFOygCP54wdfyLDB8NNGpBg
wnXEZUsMgXkKe6V/1ZZOWxsxkC2M8fsoO1CafM18yaGIQDgGeXsZpg==
=aa7W
-----END PGP SIGNATURE-----

Brendan Tildesley wrote 3 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 54700@debbugs.gnu.org)
b3d273b0-15e8-0c97-ad6f-57b8157c374a@brendan.scot
On 6/4/22 03:12, Michael Rohleder wrote:
Toggle quote (4 lines)
> Brendan Tildesley <mail@brendan.scot> writes:
>> It does not compile for me.
> Weird. I just build (and run) it successfully (again):
>
It builds on my desktop but not laptop. not sure what is going on.
Ludovic Courtès wrote 3 years ago
Re: bug#54700: [PATCH] gnu: strawberry: Update to 1.0.3.
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 54700-done@debbugs.gnu.org)
874k317vh1.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/music.scm (strawberry): Update to 1.0.3.

Applied. It builds fine for me on top of
0996d48d0e79a360e0d5583b812cd565f62ca32e.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54700@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54700
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help