(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
Hi guix,
the following patch adds the emacs-opencl-mode package. It provides
syntax highlighting when editing OpenCL kernels.
Regards,
Thomas
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 42fc13f4c2..6c82a9d784 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -108,6 +108,7 @@
;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30833,3 +30834,23 @@ (define-public emacs-osm
zoomable and moveable map display, display of tracks and POIs from GPX files,
parallel fetching of tiles with cURL, and more.")
(license license:gpl3+)))
+
+(define-public emacs-opencl-mode
+ (let ((commit "15091eff92c33ee0d1ece40eb99299ef79fee92d")
+ (revision "1"))
+ (package
+ (name "emacs-opencl-mode")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (uri (git-reference
+ (url "https://github.com/salmanebah/opencl-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zn6rr48w0ai0sn51zzyp546va6flfgf9lm12vfrdb6kkiiiq403"))
+ (method git-fetch)))
+ (build-system emacs-build-system)
+ (synopsis "OpenCL syntax coloring for Emacs")
+ (description "This Emacs package provides syntax coloring for OpenCL kernels.")
+ (home-page "https://github.com/salmanebah/opencl-mode")
+ (license license:gpl3))))
--
2.34.0