[PATCH] gnu: nss-certs: Use G-Expression.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Kubisiak
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brian Kubisiak
Severity
normal
B
B
Brian Kubisiak wrote on 3 Apr 2022 02:49
(address . guix-patches@gnu.org)
20220403004915.rzqmwkqkags4adf6@peregrine
This fixes cross-compilation for aarch64-linux-gnu.

* gnu/packages/certs.scm (nss-certs)[arguments]: Use a gexp to remove
references to %output.
---
gnu/packages/certs.scm | 31 ++++++++++++++++---------------
1 file changed, 16 insertions(+), 15 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 28c2f84f98..8f762f2966 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -28,6 +28,7 @@ (define-module (gnu packages certs)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
@@ -164,21 +165,21 @@ (define-public nss-certs
(rnrs io ports)
(srfi srfi-26))
#:phases
- (modify-phases
- (map (cut assq <> %standard-phases)
- '(set-paths install-locale unpack))
- (add-after 'unpack 'install
- (lambda _
- (let ((certsdir (string-append %output "/etc/ssl/certs/")))
- (with-directory-excursion "nss/lib/ckfw/builtins/"
- (unless (file-exists? "blacklist.txt")
- (call-with-output-file "blacklist.txt" (const #t)))
- ;; Extract selected single certificates from blob.
- (invoke "certdata2pem")
- ;; Copy .pem files into the output.
- (for-each (cut install-file <> certsdir)
- (find-files "." ".*\\.pem$")))
- (invoke "openssl" "rehash" certsdir)))))))
+ ,#~(modify-phases
+ (map (cut assq <> %standard-phases)
+ '(set-paths install-locale unpack))
+ (add-after 'unpack 'install
+ (lambda _
+ (let ((certsdir (string-append #$output "/etc/ssl/certs/")))
+ (with-directory-excursion "nss/lib/ckfw/builtins/"
+ (unless (file-exists? "blacklist.txt")
+ (call-with-output-file "blacklist.txt" (const #t)))
+ ;; Extract selected single certificates from blob.
+ (invoke "certdata2pem")
+ ;; Copy .pem files into the output.
+ (for-each (cut install-file <> certsdir)
+ (find-files "." ".*\\.pem$")))
+ (invoke "openssl" "rehash" certsdir)))))))
(synopsis "CA certificates from Mozilla")
(description
"This package provides certificates for Certification Authorities (CA)
--
2.34.0
L
L
Ludovic Courtès wrote on 2 May 2022 22:24
(name . Brian Kubisiak)(address . brian@kubisiak.com)(address . 54686-done@debbugs.gnu.org)
8735hrsmx9.fsf@gnu.org
Hi,

Brian Kubisiak <brian@kubisiak.com> skribis:

Toggle quote (5 lines)
> This fixes cross-compilation for aarch64-linux-gnu.
>
> * gnu/packages/certs.scm (nss-certs)[arguments]: Use a gexp to remove
> references to %output.

I resolved the merge conflict and applied to ‘staging’ (the
cross-compilation issue was fixed in
5389c5ea57dd17e19412f38dc448b0a5114a3579.)

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54686@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54686
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch