(address . bug-guix@gnu.org)
I noticed "./pre-inst-env guix build guix" fails on my computer due to
"pypi->guix-package, no wheel" failing. Here is an excerpt from the log:
Toggle quote (76 lines)
> test-name: pypi->guix-package, no wheel
> location: /tmp/guix-build-guix-1.3.0-24.2fb4304.drv-
> 0/source/tests/pypi.scm:221
> source:
> + (test-assert
> + "pypi->guix-package, no wheel"
> + (mock ((guix import utils)
> + url-fetch
> + (lambda (url file-name)
> + (match url
> + ("https://example.com/foo-1.0.0.tar.gz"
> + (begin
> + (mkdir-p "foo-1.0.0/src/bizarre.egg-info")
> + (with-output-to-file
> + "foo-1.0.0/src/bizarre.egg-
> info/requires.txt"
> + (lambda () (display test-requires.txt)))
> + (parameterize
> + ((current-output-port (%make-void-port
> "rw+")))
> + (system* "tar" "czvf" file-name "foo-
> 1.0.0/"))
> + (delete-file-recursively "foo-1.0.0")
> + (set! test-source-hash
> + (call-with-input-file file-name port-
> sha256))))
> + ("
> https://example.com/foo-1.0.0-py2.py3-none-any.whl"
> + #f)
> + (_ (error "Unexpected URL: " url)))))
> + (mock ((guix http-client)
> + http-fetch
> + (lambda (url . rest)
> + (match url
> + ("https://pypi.org/pypi/foo/json"
> + (values
> + (open-input-string test-json-1)
> + (string-length test-json-1)))
> + ("
> https://example.com/foo-1.0.0-py2.py3-none-any.whl"
> + #f)
> + (_ (error "Unexpected URL: " url)))))
> + (match (pypi->guix-package "foo")
> + (('package
> + ('name "python-foo")
> + ('version "1.0.0")
> + ('source
> + ('origin
> + ('method 'url-fetch)
> + ('uri ('pypi-uri "foo" 'version))
> + ('sha256 ('base32 (? string? hash)))))
> + ('build-system 'python-build-system)
> + ('propagated-inputs
> + ('list 'python-bar 'python-foo))
> + ('native-inputs ('list 'python-pytest))
> + ('home-page "http://example.com")
> + ('synopsis "summary")
> + ('description "summary")
> + ('license 'license:lgpl2.0))
> + (and (string=?
> + (bytevector->nix-base32-string test-
> source-hash)
> + hash)
> + (equal?
> + (pypi->guix-package "foo" #:version
> "1.0.0")
> + (pypi->guix-package "foo"))
> + (guard (c ((error? c) #t))
> + (pypi->guix-package
> + "foo"
> + #:version
> + "42"))))
> + (x (pk 'fail x #f))))))
> actual-value: #f
> result: FAIL
Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----
iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYkYOXhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gCEAPwKNk6K/TzH6KzWXlDW0x9Mr+RU
hBPKCxf9bNlTPeuaNAD/Z74IrbDXU0J1IAIsmmWfa649bBZInFwb21gqk9WUbwg=
=/A5W
-----END PGP SIGNATURE-----