Render document title using <h1> in HTML engine

  • Open
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Ludovic Courtès
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal

Debbugs page

Arun Isaac wrote 3 years ago
(address . skribilo-bugs@nongnu.org)
87h77jrdpb.fsf@systemreboot.net
The skribilo HTML engine renders the document title using a table as
follows:

Toggle snippet (10 lines)
<table class="skribilo-title" width="100%" cellspacing="0"
cellpadding="0">
<tbody>
<tr>
<td align="center"><div class="skribilo-title">TITLE GOES HERE</div>
</td></tr>
</tbody>
</table>

Not only is this very convoluted, it means that the document title is
much smaller than the section titles which are in h2. This
representation using a table goes back to a bygone era before CSS. We
should simply use a <h1> and allow the user to customize the CSS as they
please. Something like:

Toggle snippet (3 lines)
<h1 class="skribilo-title">TITLE GOES HERE</h1>

This change has the downside is that it’ll “break someone’s workflow” as
xkcd puts it, but unfortunately, we need to move forward.
Ludovic Courtès wrote 3 years ago
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 54592@debbugs.gnu.org)
87o818676r.fsf@gnu.org
Hi,

Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (5 lines)
> <h1 class="skribilo-title">TITLE GOES HERE</h1>
>
> This change has the downside is that it’ll “break someone’s workflow” as
> xkcd puts it, but unfortunately, we need to move forward.

I every much agree with such a change, ideally together with a default CSS.

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54592@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54592
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help