Render document title using <h1> in HTML engine

  • Open
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Ludovic Courtès
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 27 Mar 2022 10:40
(address . skribilo-bugs@nongnu.org)
87h77jrdpb.fsf@systemreboot.net
The skribilo HTML engine renders the document title using a table as
follows:

Toggle snippet (10 lines)
<table class="skribilo-title" width="100%" cellspacing="0"
cellpadding="0">
<tbody>
<tr>
<td align="center"><div class="skribilo-title">TITLE GOES HERE</div>
</td></tr>
</tbody>
</table>

Not only is this very convoluted, it means that the document title is
much smaller than the section titles which are in h2. This
representation using a table goes back to a bygone era before CSS. We
should simply use a <h1> and allow the user to customize the CSS as they
please. Something like:

Toggle snippet (3 lines)
<h1 class="skribilo-title">TITLE GOES HERE</h1>

This change has the downside is that it’ll “break someone’s workflow” as
xkcd puts it, but unfortunately, we need to move forward.
L
L
Ludovic Courtès wrote on 10 Apr 2022 21:59
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 54592@debbugs.gnu.org)
87o818676r.fsf@gnu.org
Hi,

Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (5 lines)
> <h1 class="skribilo-title">TITLE GOES HERE</h1>
>
> This change has the downside is that it’ll “break someone’s workflow” as
> xkcd puts it, but unfortunately, we need to move forward.

I every much agree with such a change, ideally together with a default CSS.

Ludo’.
?