Arun Isaac wrote 3 years ago
(address . skribilo-bugs@nongnu.org)
The skribilo HTML engine renders the document title using a table as
follows:
Toggle snippet (10 lines)
<table class="skribilo-title" width="100%" cellspacing="0"
cellpadding="0">
<tbody>
<tr>
<td align="center"><div class="skribilo-title">TITLE GOES HERE</div>
</td></tr>
</tbody>
</table>
Not only is this very convoluted, it means that the document title is
much smaller than the section titles which are in h2. This
representation using a table goes back to a bygone era before CSS. We
should simply use a <h1> and allow the user to customize the CSS as they
please. Something like:
Toggle snippet (3 lines)
<h1 class="skribilo-title">TITLE GOES HERE</h1>
This change has the downside is that it’ll “break someone’s workflow” as
xkcd puts it, but unfortunately, we need to move forward.