[PATCH 0/4] Update git-annex to 10.20220322

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Leo Famulari
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 3 years ago
(address . guix-patches@gnu.org)
20220327031210.474782-1-kyle@kyleam.com
This series updates git-annex to the latest version. That requires a new
package because git-annex no longer bundles the http-client-restricted library
(patch 3). And http-client-restricted requires a newer version of
http-client-tls (patch 2), which in turn requires a newer version of
http-client (patch 1).

[1/4] gnu: ghc-http-client: Update to 0.7.11.
[2/4] gnu: ghc-http-client-tls: Update to 0.3.6.1.
[3/4] gnu: Add ghc-http-client-restricted.
[4/4] gnu: git-annex: Update to 10.20220322.

gnu/packages/haskell-apps.scm | 5 +++--
gnu/packages/haskell-web.scm | 39 ++++++++++++++++++++++++++++++-----
2 files changed, 37 insertions(+), 7 deletions(-)


base-commit: 943d4b775b9b1cc645e86206b0cf07da8d0030b3
--
2.34.0
Kyle Meyer wrote 3 years ago
[PATCH 1/4] gnu: ghc-http-client: Update to 0.7.11.
(address . 54590@debbugs.gnu.org)
20220327032604.475598-1-kyle@kyleam.com
* gnu/packages/haskell-web.scm (ghc-http-client): Update to 0.7.11.
[inputs]: Add ghc-iproute.
---
gnu/packages/haskell-web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 70a4eccce6..470a0a02be 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -221,7 +221,7 @@ (define-public ghc-http
(define-public ghc-http-client
(package
(name "ghc-http-client")
- (version "0.6.4.1")
+ (version "0.7.11")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -229,7 +229,7 @@ (define-public ghc-http-client
version ".tar.gz"))
(sha256
(base32
- "1y12xfh6xvsfvyapbssmgrpjz025rmyccprbnmzhs0y1cmlz6hjp"))))
+ "12j7vkpkm2djws6ny7vm2324c7916d0iaf1mbvf4mfjxzy2w7imv"))))
(build-system haskell-build-system)
;; Tests require access to the web.
(arguments `(#:tests? #f))
@@ -242,6 +242,7 @@ (define-public ghc-http-client
ghc-data-default-class
ghc-exceptions
ghc-http-types
+ ghc-iproute
ghc-memory
ghc-mime-types
ghc-monad-control
--
2.34.0
Kyle Meyer wrote 3 years ago
[PATCH 2/4] gnu: ghc-http-client-tls: Update to 0.3.6.1.
(address . 54590@debbugs.gnu.org)
20220327032604.475598-2-kyle@kyleam.com
* gnu/packages/haskell-web.scm (ghc-http-client-tls): Update to 0.3.6.1.
---
gnu/packages/haskell-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 470a0a02be..cafdf5099e 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -263,7 +263,7 @@ (define-public ghc-http-client
(define-public ghc-http-client-tls
(package
(name "ghc-http-client-tls")
- (version "0.3.5.3")
+ (version "0.3.6.1")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -271,7 +271,7 @@ (define-public ghc-http-client-tls
version ".tar.gz"))
(sha256
(base32
- "0qj3pcpgbsfsc4m52dz35khhl4hf1i0nmcpa445z82d9567vy6j7"))))
+ "03f8p9gxdzl6slyw1r6vpv2dqhsyjvbaawbjv75kaq0vlj3gz7xi"))))
(build-system haskell-build-system)
;; Tests require Internet access
(arguments `(#:tests? #f))
--
2.34.0
Kyle Meyer wrote 3 years ago
[PATCH 3/4] gnu: Add ghc-http-client-restricted.
(address . 54590@debbugs.gnu.org)
20220327032604.475598-3-kyle@kyleam.com
* gnu/packages/haskell-web.scm (ghc-http-client-restricted): New variable.
---
gnu/packages/haskell-web.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index cafdf5099e..1c2538b45e 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2020 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2020, 2022 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
@@ -292,6 +292,34 @@ (define-public ghc-http-client-tls
libraries, such as http-conduit.")
(license license:expat)))
+(define-public ghc-http-client-restricted
+ (package
+ (name "ghc-http-client-restricted")
+ (version "0.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "http-client-restricted" version))
+ (sha256
+ (base32 "1vfm9qc3zr0rmq2ddgyg13i67020cdk8xqhyzfc2zcn1km2p6r85"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-http-client
+ ghc-http-client-tls
+ ghc-connection
+ ghc-data-default
+ ghc-network
+ ghc-network-bsd
+ ghc-utf8-string))
+ (home-page "http://hackage.haskell.org/package/http-client-restricted")
+ (synopsis "Restrict the servers used by http-client")
+ (description
+ "This library makes it possible to restrict the HTTP servers that can be
+used by the @code{http-client} and @code{http-client-tls} libraries. This is
+useful when a security policy needs to, e.g., prevent connections to HTTP
+servers on localhost or only allow connections to a specific server.")
+ (license license:expat)))
+
(define-public ghc-http-date
(package
(name "ghc-http-date")
--
2.34.0
Kyle Meyer wrote 3 years ago
[PATCH 4/4] gnu: git-annex: Update to 10.20220322.
(address . 54590@debbugs.gnu.org)
20220327032604.475598-4-kyle@kyleam.com
* gnu/packages/haskell-apps.scm (git-annex): Update to 10.20220322.
[inputs]: Add ghc-http-client-restricted.
---
gnu/packages/haskell-apps.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ecd1a93317..5c351fa981 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -304,14 +304,14 @@ (define-public ghcid
(define-public git-annex
(package
(name "git-annex")
- (version "10.20220222")
+ (version "10.20220322")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"git-annex/git-annex-" version ".tar.gz"))
(sha256
- (base32 "119c7l2vqv19ja3pg3adaivsmrmbyg03a88j2msnzcgyhddggf8z"))))
+ (base32 "107v1c2lw53k25p6snbmxyia3ghd63kj3izvd81d8km9qncv96bv"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags
@@ -425,6 +425,7 @@ (define-public git-annex
ghc-hinotify
ghc-hslogger
ghc-http-client
+ ghc-http-client-restricted
ghc-http-conduit
ghc-http-types
ghc-ifelse
--
2.34.0
Leo Famulari wrote 3 years ago
Re: [bug#54590] [PATCH 0/4] Update git-annex to 10.20220322
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 54590-done@debbugs.gnu.org)
YkM9mhfSU2hkVCVT@jasmine.lan
On Sat, Mar 26, 2022 at 11:12:10PM -0400, Kyle Meyer wrote:
Toggle quote (11 lines)
> This series updates git-annex to the latest version. That requires a new
> package because git-annex no longer bundles the http-client-restricted library
> (patch 3). And http-client-restricted requires a newer version of
> http-client-tls (patch 2), which in turn requires a newer version of
> http-client (patch 1).
>
> [1/4] gnu: ghc-http-client: Update to 0.7.11.
> [2/4] gnu: ghc-http-client-tls: Update to 0.3.6.1.
> [3/4] gnu: Add ghc-http-client-restricted.
> [4/4] gnu: git-annex: Update to 10.20220322.

Thanks for taking care of it!

Pushed as 6c317e02ee3b41dd7aa3a220be50191b6ed6fe9e
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54590@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54590
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help