[PATCH] gnu: Add wsdd.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Maxime Devos
  • Simon Streit
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Simon Streit
Severity
normal
S
S
Simon Streit wrote on 25 Mar 2022 12:46
(address . guix-patches@gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
61b9d1603851cc9d4304d59b8a43899dc804ba67.1648208525.git.simon@netpanic.org
* gnu/packages/samba.scm (wsdd): New variable.
---
gnu/packages/samba.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..21a5fe8617 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -500,3 +500,29 @@ (define-public ppp
;; chat is public domain.
(license (list bsd-3 bsd-4 gpl2+ public-domain))))
+(define-public wsdd
+ (package
+ (name "wsdd")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/christgau/wsdd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04an2w6hamnai668ag4vq8x0i09fsg2jrayb4a7ar0x6bn837k7m"))))
+ (build-system copy-build-system)
+ (inputs
+ `(("python" ,python)))
+ (arguments
+ '(#:install-plan
+ '(("src/wsdd.py" "bin/wsdd")
+ ("man/wsdd.1" "share/man/man1/"))))
+ (home-page "https://github.com/christgau/wsdd")
+ (synopsis "A Web Service Discovery host daemon")
+ (description "This daemon allows (Samba) hosts to be found by Web
+Service Dicovery Clients. It also implements the client side of the
+discovery protocol which allows to search for devices implementing
+WSD.")
+ (license expat)))
--
2.34.0
M
M
Maxime Devos wrote on 26 Mar 2022 11:17
73ef084b46e0e8e7394b75f81bfee7706f3f6200.camel@telenet.be
Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
Toggle quote (5 lines)
> +    (arguments
> +     '(#:install-plan
> +       '(("src/wsdd.py" "bin/wsdd")
> +         ("man/wsdd.1" "share/man/man1/"))))

There are a few tests in 'tests'. Can they be run?
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYj7oUBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7uOaAPwNCGqeycA7b4gFLpQup9fHwoRg
POV1Yr+bUAKED43pFQEAwSbcQ8Oo1AREXnQ6q4xOrfzZZfzp3cUkU+/x2ul5XQ4=
=KVIp
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 26 Mar 2022 11:19
42a8c8cc6e8ce7872b0ff2814727a37de770d6d6.camel@telenet.be
Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
Toggle quote (3 lines)
> +       (uri (git-reference (url "https://github.com/christgau/wsdd")
> +                           (commit (string-append "v" version))))

This uses NetlinkAddressMonitor, which is Linux-specific. Could
'supported-systems' be set to only Linux targets (and not, say,
GNU/Hurd)?
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYj7oxxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7pPLAQCDslUOPwwUcOK4emNjn4ODTAnM
XcktNYt4NwY350W2bAD9EnnpTNWtIIg/JTDp40igjT77C93vMDWGVicaLtAPdA4=
=A8cz
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 29 Mar 2022 11:40
control message for bug #54563
(address . control@debbugs.gnu.org)
87wngd2j15.fsf@gnu.org
tags 54563 + moreinfo
quit
S
S
Simon Streit wrote on 4 Apr 2022 20:48
Re: [bug#54563] [PATCH] gnu: Add wsdd.
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 54563@debbugs.gnu.org)
ygu7d84elc7.fsf@netpanic.org
Hello Maxime,

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (8 lines)
> Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
>> +       (uri (git-reference (url "https://github.com/christgau/wsdd")
>> +                           (commit (string-append "v" version))))
>
> This uses NetlinkAddressMonitor, which is Linux-specific. Could
> 'supported-systems' be set to only Linux targets (and not, say,
> GNU/Hurd)?

I just figured you are meaning that WSDD only supports Linux specific
systems? It appears so after reading the source code. I can't tell if
it will work in GNU/Hurd though. Should the package declaration be
modified to reflect this limitation?
S
S
Simon Streit wrote on 4 Apr 2022 20:52
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 54563@debbugs.gnu.org)
ygu1qycel5b.fsf@netpanic.org
Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (8 lines)
> Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
>> +    (arguments
>> +     '(#:install-plan
>> +       '(("src/wsdd.py" "bin/wsdd")
>> +         ("man/wsdd.1" "share/man/man1/"))))
>
> There are a few tests in 'tests'. Can they be run?

They don't appear to be proper test files running unit tests or anything
close. One monitors the address on all network interfaces. The other
crashes. The top comment in these files state though that they are “not
really a test case, but a PoC for getting notified about changes in
network addresses.”

I don't think it will be necessary to have then run while packaging.
M
M
Maxime Devos wrote on 4 Apr 2022 23:58
(name . Simon Streit)(address . simon@netpanic.org)(address . 54563@debbugs.gnu.org)
70303b8350929cb5a4ef5b70981b755318942a71.camel@telenet.be
Simon Streit schreef op ma 04-04-2022 om 20:48 [+0200]:
Toggle quote (17 lines)
> Hello Maxime,
>
> Maxime Devos <maximedevos@telenet.be> writes:
>
> > Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
> > > +       (uri (git-reference (url "https://github.com/christgau/wsdd")
> > > +                           (commit (string-append "v" version))))
> >
> > This uses NetlinkAddressMonitor, which is Linux-specific.  Could
> > 'supported-systems' be set to only Linux targets (and not, say,
> > GNU/Hurd)?
>
> I just figured you are meaning that WSDD only supports Linux specific
> systems?  It appears so after reading the source code.  I can't tell if
> it will work in GNU/Hurd though.  Should the package declaration be
> modified to reflect this limitation?

netlink is IIUC (currently) a Linux-specific interface. Though
it's ok after all. As such, I would optimistically assume it works on
the Hurd as well.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYktqChccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7mJCAQCPJQeBYVTEw5WpRDD+RWXGFj1H
c90OjtR6o7+hubzbOgD/TPuLzKKi+mJKWGW1iCO1VvizQ/YVcPg76q4CbJpnQw8=
=ceJj
-----END PGP SIGNATURE-----


V
V
Vagrant Cascadian wrote on 2 Sep 2023 01:37
87il8tqxc3.fsf@wireframe
On 2022-03-25, Simon Streit wrote:
Toggle quote (2 lines)
> * gnu/packages/samba.scm (wsdd): New variable.

This was merged as:

14359befa92d2d54af0e584724610d8a31f5ac63 gnu: Add wsdd.

And updated to a newer version in:

79c2af7394a8a541fa2ed0126272025b09aa05cd gnu: wsdd: Update to 0.7.1.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJ1vAAKCRDcUY/If5cW
qnZLAP45jD3j4J6xi1oQ6937N/eXdidfP0tdRKtrhMbebjFxXwD8CbJqVCN714RU
BiTZfwLhqe16qqvKat1maLY7xVnOCA0=
=ltjg
-----END PGP SIGNATURE-----

Closed
?