[PATCH] gnu: Add curlie.

  • Done
  • quality assurance status badge
Details
2 participants
  • Imran Iqbal
  • Ludovic Courtès
Owner
unassigned
Submitted by
Imran Iqbal
Severity
normal
I
I
Imran Iqbal wrote on 24 Mar 2022 06:05
(address . guix-patches@gnu.org)(name . Imran Iqbal)(address . imran@imraniqbal.org)
20220324050511.85536-1-imran@imraniqbal.org
* gnu/packages/curl.scm (curlie): New variable.
---
gnu/packages/curl.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index d36519260e..ca423ad1b9 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -362,3 +362,31 @@ (define-public coeurl
(description "Coeurl is a simple library to do HTTP requests
asynchronously via cURL in C++.")
(license license:expat)))
+
+(define-public curlie
+ (package
+ (name "curlie")
+ (version "1.6.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rs/curlie")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kmp8kd5sahb7x01pkk80zs7dvsnziavjlk2igis499a3ddcjqmr"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/rs/curlie"))
+ (inputs
+ (list curl go-golang-org-x-crypto go-golang-org-x-sys))
+ (home-page "https://curlie.io")
+ (synopsis "The power of curl, the ease of use of httpie")
+ (description "If you like the interface of HTTPie but miss the features of
+curl, curlie is what you are searching for. Curlie is a frontend to @code{curl}
+that adds the ease of use of @code{httpie}, without compromising on features
+and performance. All @code{curl} options are exposed with syntax sugar and
+output formatting inspired from @code{httpie}.")
+ (license license:expat)))
--
2.35.1
L
L
Ludovic Courtès wrote on 25 Mar 2022 11:50
(name . Imran Iqbal)(address . imran@imraniqbal.org)(address . 54541-done@debbugs.gnu.org)
87czia8fx3.fsf@gnu.org
Hi,

Imran Iqbal <imran@imraniqbal.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/curl.scm (curlie): New variable.

I addressed a ‘guix lint’ warning about the description and committed it.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54541@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54541
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch