[PATCH] gnu: Add r-cytobackbone.

  • Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Maxime Devos
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220321191918.18123-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-cytobackbone): New variable.
---
gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55d397e5cf..6f5a040f65 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10066,6 +10066,44 @@ (define-public r-consensusclusterplus
cluster count and membership by stability evidence in unsupervised analysis.")
(license license:gpl2)))
+;; It doesn't have a system of releases. This package depends on a bioconductor
+;; input.
+(define-public r-cytobackbone
+ (let ((commit "4c1a0a35cc5ae1f8f516127cec92351d96fe26e7") (revision "1"))
+ (package
+ (name "r-cytobackbone")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchitchek-lab/CytoBackBone")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ahiad14zcgdk42xzw5xryic2ibn2l8lkrcdvl2b5sz2js028yb3"))))
+ (properties `((upstream-name #{.}# "CytoBackBone")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-flowcore r-flowutils r-fnn r-ggplot2
+ r-preprocesscore))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/tchitchek-lab/CytoBackBone")
+ (synopsis
+ "Merging of phenotype information from different cytometric profiles")
+ (description
+ "Single-cell technologies are the most suitable techniques for the
+characterization of cells by the differential expression of the molecules that
+define their roles and functions in tissues. Among these techniques, mass
+cytometry represents a leap forward by increasing the number of available
+measurements to approximately 40 cell markers. Thanks to this technology,
+detailed immune responses were described in several diseases. However, the
+study of immune responses, such as that due to viral infections or auto-immune
+diseases, could be further improved by increasing the number of simultaneously
+measurable markers. To increase this number, we designed an algorithm, named
+@code{CytoBackBone}, which combines phenotypic information of different
+cytometric profiles obtained from different cytometry panels.")
+ (license license:gpl2))))
+
(define-public r-cytolib
(package
(name "r-cytolib")
--
2.34.0
Maxime Devos wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 54511@debbugs.gnu.org)
7d7abbd50ac7a7193e4aee55b30dbc3f553f300a.camel@telenet.be
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
Toggle quote (2 lines)
> +      (properties `((upstream-name #{.}# "CytoBackBone")))

This needs to be (upstream-name . "CytoBackBone") -- #{.}# is the
symbol containing a dot, so (upstream-name #{.}# "CytoBackBone") is a
three-element list and not a pair.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYjjdPxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7vEgAP0Sxz82nUBJIO942/BESmUVnfKL
4xgB8E9sZZUgWzQ/eAD+JSKpOiZFpBMmQoKN+qtmGhjBjQBqAKjZIqIvXcOSxw8=
=oSRo
-----END PGP SIGNATURE-----


Maxime Devos wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 54511@debbugs.gnu.org)
9d99b1450756f6b31f54c282e7ee76c1db93adab.camel@telenet.be
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
Toggle quote (2 lines)
> +      (license license:gpl2))))

Could you ask upstream if they meant gpl2 or gpl2-or-later?
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYjjdWBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hDbAQDO9JMHEK5XiKW+UiaR0kePd+yO
S5dNGK0lds9YfmGuWwEAgqeppm9cAJhFGgb3v4aDJbeAFkgvD9IKSO+RxzVQTAU=
=imKD
-----END PGP SIGNATURE-----


Maxime Devos wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 54511@debbugs.gnu.org)
2e476f55c1c5b34f7986f8a0ef7203e5d30227bf.camel@telenet.be
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
Toggle quote (3 lines)
> +      (description
> +       "Single-cell technologies are the most suitable [...]

This doesn't seem a good description to me as it is one big word salad.
Also see ‘(guix)Synopses and Descriptions’ for some tips.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYjjd7BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7pjJAP4szbPaYXmtxHv1NzZP2Ed337lD
+y0D2++FXhPkP0n0awD9EmIDnFqCd1ef65N1UOjXer3kD6Umni9pGLtOA+VJdQQ=
=CdML
-----END PGP SIGNATURE-----


MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(name . 54511@debbugs.gnu.org)(address . 54511@debbugs.gnu.org)
bca2b7ec687641a08c1e31bd5ba304b3@mdc-berlin.de
Dear Maxime,
This is an artifact after I run guix style.
I missed it this time.
Thanks for spotting this!
All the best!
Mădălin Ionel Patrașcu
System Administrator
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
________________________________
From: Maxime Devos <maximedevos@telenet.be>
Sent: Monday, March 21, 2022 21:17
To: Patrascu, Madalin Ionel; 54511@debbugs.gnu.org
Subject: [ext] Re: [bug#54511] [PATCH] gnu: Add r-cytobackbone.
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
Toggle quote (1 lines)
> + (properties `((upstream-name #{.}# "CytoBackBone")))
This needs to be (upstream-name . "CytoBackBone") -- #{.}# is the
symbol containing a dot, so (upstream-name #{.}# "CytoBackBone") is a
three-element list and not a pair.
Greetings,
Maxime.
Attachment: file
MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(name . 54511@debbugs.gnu.org)(address . 54511@debbugs.gnu.org)
51dccc52f2264d998c02b2bd281fc794@mdc-berlin.de
Dear Maxime,
Thanks for the suggestion!
Now, I have asked this.
License · Issue #2 · tchitchek-lab/CytoBackBone · GitHubhttps://github.com/tchitchek-lab/CytoBackBone/issues/2
github.com
Dear Authors, Quick question: This project is licensed under GPL-2.0-only or the license GPL-2.0-or-later can be applied? I ask this because we try to add this to Guix. https://debbugs.gnu.org/cgi/bugreport.cgi?bug=54511Thanks and all t...
All the best!
Mădălin Ionel Patrașcu
System Administrator
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
________________________________
From: Maxime Devos <maximedevos@telenet.be>
Sent: Monday, March 21, 2022 21:17
To: Patrascu, Madalin Ionel; 54511@debbugs.gnu.org
Subject: [ext] Re: [bug#54511] [PATCH] gnu: Add r-cytobackbone.
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
Toggle quote (1 lines)
> + (license license:gpl2))))
Could you ask upstream if they meant gpl2 or gpl2-or-later?
Attachment: file
MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(name . 54511@debbugs.gnu.org)(address . 54511@debbugs.gnu.org)
fd9a156bbf6f4d2c8ce1fb9be2a2405c@mdc-berlin.de
Dear Maxime,
Bioinformatics is not my area of expertise ,and beside this, it was the end of a busy day and I wanted to finish this faster.
Sorry that I didn't treat this with more attention!
I will try to send again a path with a more readable description.
All the best!
Mădălin Ionel Patrașcu
System Administrator
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany
________________________________
From: Maxime Devos <maximedevos@telenet.be>
Sent: Monday, March 21, 2022 21:19
To: Patrascu, Madalin Ionel; 54511@debbugs.gnu.org
Subject: [ext] Re: [bug#54511] [PATCH] gnu: Add r-cytobackbone.
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
Toggle quote (2 lines)
> + (description
> + "Single-cell technologies are the most suitable [...]
This doesn't seem a good description to me as it is one big word salad.
Also see ‘(guix)Synopses and Descriptions’ for some tips.
Greetings,
Maxime.
Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH] gnu: Add r-cytobackbone.
(address . 54511@debbugs.gnu.org)
20220322103431.19798-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-cytobackbone): New variable.
---
gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55d397e5cf..bf123ef7cc 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10066,6 +10066,48 @@ (define-public r-consensusclusterplus
cluster count and membership by stability evidence in unsupervised analysis.")
(license license:gpl2)))
+;; It doesn't have a system of releases. This package depends on a bioconductor
+;; input.
+(define-public r-cytobackbone
+ (let ((commit "4c1a0a35cc5ae1f8f516127cec92351d96fe26e7") (revision "1"))
+ (package
+ (name "r-cytobackbone")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchitchek-lab/CytoBackBone")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ahiad14zcgdk42xzw5xryic2ibn2l8lkrcdvl2b5sz2js028yb3"))))
+ (properties `((upstream-name . "CytoBackBone")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-flowcore
+ r-flowutils
+ r-fnn
+ r-ggplot2
+ r-preprocesscore))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/tchitchek-lab/CytoBackBone")
+ (synopsis
+ "Merging of phenotype information from different cytometric profiles")
+ (description
+ "This package implements an algorithm which increases the number of
+simultaneously measurable markers and in this way helps with study of the
+immune responses. Thus, the present algorithm, named @code{CytoBackBone},
+allows combining phenotypic information of cells from different cytometric
+profiles obtained from different cytometry panels. This computational approach
+is based on the principle that each cell has its own phenotypic and functional
+characteristics that can be used as an identification card.
+@code{CytoBackBone} uses a set of predefined markers, that we call the
+backbone, to define this identification card. The phenotypic information of
+cells with similar identification cards in the different cytometric profiles is
+then merged.")
+ (license license:gpl2))))
+
(define-public r-cytolib
(package
(name "r-cytolib")
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(address . 54511-done@debbugs.gnu.org)
87ee2k9aii.fsf@mdc-berlin.de
I moved this to bioinformatics.scm.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54511@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54511
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help