[PATCH] gnu: Add r-cycombine.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220321180242.16823-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-cycombine): New variable.
---
gnu/packages/bioconductor.scm | 43 +++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55d397e5cf..ffa38fda3a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10066,6 +10066,49 @@ (define-public r-consensusclusterplus
cluster count and membership by stability evidence in unsupervised analysis.")
(license license:gpl2)))
+;; This is the latest commit and it solves a bug from the latest release.
+(define-public r-cycombine
+ (let ((commit "f18504bc83ff5daee2b5eb4b28f09abdaaa66698") (revision "1"))
+ (package
+ (name "r-cycombine")
+ (version (git-version "0.2.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/biosurf/cyCombine")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fiwnik8iahg01732fik85xhz359x32f1xc59h443pdf7jancskm"))))
+ (properties `((upstream-name . "cyCombine")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-cytolib
+ r-dplyr
+ r-flowcore
+ r-ggplot2
+ r-knitr
+ r-kohonen
+ r-magrittr
+ r-purrr
+ r-rcolorbrewer
+ r-readr
+ r-readxl
+ r-stringr
+ r-sva
+ r-tibble
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/biosurf/cyCombine")
+ (synopsis "Integration of single-cell cytometry datasets")
+ (description
+ "This package provides a method for combining single-cell cytometry
+datasets, which increases the analytical flexibility and the statistical power
+of the analyses while minimizing technical noise.")
+ (license license:expat))))
+
(define-public r-cytolib
(package
(name "r-cytolib")
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(address . 54510-done@debbugs.gnu.org)
87v8vy865f.fsf@elephly.net
Thanks for the patch; I just applied it.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54510@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54510
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help