Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
Hello,
this patch adds simavr [1] -- an AVR simulator.
Thanks,
- Artyom
References:
From 05b3a83a9f0f9b0e08d2675cb9b1a80c6b30114d Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 19 Mar 2022 23:39:54 +0300
Subject: [PATCH] gnu: Add simavr
* gnu/packages/avr.scm (simavr): New variable.
---
gnu/packages/avr.scm | 74 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 73 insertions(+), 1 deletion(-)
Toggle diff (105 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 3cc5a6964e..9836cc6305 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
(define-module (gnu packages avr)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -35,7 +37,17 @@
#:use-module (gnu packages cross-base)
#:use-module (gnu packages flashing-tools)
#:use-module (gnu packages gcc)
- #:use-module (gnu packages vim))
+ #:use-module (gnu packages vim)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
+ #:use-module (gnu packages avr)
+ #:use-module (gnu packages elf)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages ruby))
(define-public avr-binutils
(package
@@ -181,3 +193,63 @@ inlining, and features an aggressive tree-shaker, eliminating unused top-level
definitions. Microscheme has a robust @dfn{Foreign Function Interface} (FFI)
meaning that C code may be invoked directly from (ms) programs.")
(license license:expat)))
+
+(define-public simavr
+ (package
+ (name "simavr")
+ (version "1.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/buserror/simavr")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0njz03lkw5374x1lxrq08irz4b86lzj2hibx46ssp7zv712pq55q"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:modules '((guix build gnu-build-system)
+ (guix build utils))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (when tests?
+ (invoke "make"
+ "-C"
+ "tests"
+ (string-append "CC=" #$(cc-for-target))
+ "RELEASE=1"
+ "run_tests")))))
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "RELEASE=1"
+ (string-append "PREFIX=" #$output)
+ (string-append "DESTDIR=" #$output))))
+ (propagated-inputs
+ (list avr-toolchain))
+ (native-inputs
+ (list autoconf
+ which
+ git
+ automake
+ pkg-config
+ ncurses
+ ruby))
+ (inputs
+ (list bash-minimal libelf freeglut))
+ (home-page "https://github.com/buserror/simavr")
+ (synopsis "Lean, mean and hackable AVR simulator for GNU/Linux and OSX")
+ (description
+ "simavr is a new AVR simulator for GNU/Linux, or any platform that uses
+@command{avr-gcc}. It uses avr-gcc's own register definition to simplify
+creating new targets for supported AVR devices. The core was made to be small
+and compact, and hackable so allow quick prototyping of an AVR project. The
+AVR core is now stable for use with parts with <= 128KB flash, and with
+preliminary support for the bigger parts. The simulator loads ELF files
+directly, and there is even a way to specify simulation parameterps directly
+in the emulated code using an @code{.elf} section. You can also load
+multipart HEX files.")
+ (license license:gpl3)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmI3WBcACgkQ6cWi2QiY
oC9IdQf/Rj6GW8KH5P5yilWziCAF+ANSoOk0vu1Z4MSQ2j3fyUnejWcCtiQTxwfw
ORcGjGoHJQhVN+Y8pNHdrlXseDrqXQbC/GBv7UJnHiXutjUhiQc3TFNOx81d7oBt
evubrflVOGyW84sWSoNkLeR9D7/xpkZPBIgrS5kkxg16O1EViZOzs7fhVYTewh+z
Ft2ZfgJ58k6joWFLEgl0msFsC/HwE/PvY7D1NHPn53fqPb1lpo5aFkHqvpP2NpuJ
V516LewsQO2odEbccrVItrin+0s/tQBgEUL1eFKgND4f6LYKiPRSmnGIVyGkYOD4
w9JR7LtHKpHER9tuXRQ+EaKSGw+Frw==
=uFGG
-----END PGP SIGNATURE-----