Roman Riabenko wrote 3 years ago
(address . guix-patches@gnu.org)
This patch adds robotfindskitten.
Roman
From c35c4283a2e66c03693164df1b9e62514478bb1c Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Thu, 17 Mar 2022 14:34:25 +0200
Subject: [PATCH] gnu: games: Add robotfindskitten.
* gnu/packages/games.scm (robotfindskitten): New variable.
---
gnu/packages/games.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
Toggle diff (78 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8cc29b3487..9ed0cad802 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,61 @@ (define-public retux
license:gpl2+
license:gpl3+)))))
+(define-public robotfindskitten
+ (package
+ (name "robotfindskitten")
+ ;; Despite what guix lint says, version 2.8284271.702 is newer then
+ ;; 1600003_201b. See ChangeLog for version history.
+ (version "2.8284271.702")
+ ;; The git version is the same as in the release tarball, but it bundles
+ ;; convenient .desktop files, which were requested for Debian.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/robotfindskitten/robotfindskitten")
+ (commit "1cae36621f9c19d19a40eacf63789913d4ef5d5c")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ps3xrl1yh0h7jhl3bwhx5xw2hvhzync03y08i66rzw098r530qq"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-ifv"))) ;per README.md
+ (add-after 'unpack 'fix-install-path
+ (lambda _
+ ;; It is configured to install executable to /games or
+ ;; /usr/local/games per Filesystem Hierarchy Standard.
+ ;; We change that to get it in $PATH.
+ (substitute* "src/Makefile.am"
+ (("\\$\\(prefix\\)/games") "$(prefix)/bin"))
+ ;; When built with guix, all characters are displayed in
+ ;; the background colour pair. If it is not set manually,
+ ;; this is not happening, so we get back colour into the
+ ;; game. The background is redrawn anyway. See man bkgd.
+ (substitute* "src/robotfindskitten.c"
+ (("\\(void\\) bkgd \\( \\(chtype\\) COLOR_PAIR\\(WHITE\\) \\);")
+ "")))))
+ #:configure-flags
+ '("--enable-silent-rules")))
+ (native-inputs (list autoconf automake libtool texinfo))
+ (inputs (list ncurses))
+ (outputs '("out" "debug"))
+ ;; The following was copied from the bundled XML file and formatted.
+ (synopsis "Zen Simulation of robot finding kitten")
+ (description
+ "In this simulation, you play the part of robot. Your task is to
+complete the simulation by finding kitten, as is your destiny, and indeed your
+wont. You (robot) are represented by the # character, and you move around with
+the arrow keys touching things. If the thing you touch is kitten, you get a
+cute little animation (which was cuter in the DOS version) and the simulation
+ends. Otherwise, you get a brief description of what it is you touched.")
+ (home-page "http://robotfindskitten.org/")
+ (license license:gpl2+)))
+
(define-public roguebox-adventures
(package
(name "roguebox-adventures")
base-commit: 8a0713aef2a8d709551d51fefff45f4611d05c66
--
2.34.0