[PATCH] gnu: games: Add robotfindskitten.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Maxime Devos
  • Roman Riabenko
Owner
unassigned
Submitted by
Roman Riabenko
Severity
normal

Debbugs page

Roman Riabenko wrote 3 years ago
(address . guix-patches@gnu.org)
d7b56d3619d5fea4effb0d428dfec8f48dd78f60.camel@riabenko.com
This patch adds robotfindskitten.

Roman
From c35c4283a2e66c03693164df1b9e62514478bb1c Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Thu, 17 Mar 2022 14:34:25 +0200
Subject: [PATCH] gnu: games: Add robotfindskitten.

* gnu/packages/games.scm (robotfindskitten): New variable.
---
gnu/packages/games.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)

Toggle diff (78 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8cc29b3487..9ed0cad802 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,61 @@ (define-public retux
license:gpl2+
license:gpl3+)))))
+(define-public robotfindskitten
+ (package
+ (name "robotfindskitten")
+ ;; Despite what guix lint says, version 2.8284271.702 is newer then
+ ;; 1600003_201b. See ChangeLog for version history.
+ (version "2.8284271.702")
+ ;; The git version is the same as in the release tarball, but it bundles
+ ;; convenient .desktop files, which were requested for Debian.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/robotfindskitten/robotfindskitten")
+ (commit "1cae36621f9c19d19a40eacf63789913d4ef5d5c")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ps3xrl1yh0h7jhl3bwhx5xw2hvhzync03y08i66rzw098r530qq"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-ifv"))) ;per README.md
+ (add-after 'unpack 'fix-install-path
+ (lambda _
+ ;; It is configured to install executable to /games or
+ ;; /usr/local/games per Filesystem Hierarchy Standard.
+ ;; We change that to get it in $PATH.
+ (substitute* "src/Makefile.am"
+ (("\\$\\(prefix\\)/games") "$(prefix)/bin"))
+ ;; When built with guix, all characters are displayed in
+ ;; the background colour pair. If it is not set manually,
+ ;; this is not happening, so we get back colour into the
+ ;; game. The background is redrawn anyway. See man bkgd.
+ (substitute* "src/robotfindskitten.c"
+ (("\\(void\\) bkgd \\( \\(chtype\\) COLOR_PAIR\\(WHITE\\) \\);")
+ "")))))
+ #:configure-flags
+ '("--enable-silent-rules")))
+ (native-inputs (list autoconf automake libtool texinfo))
+ (inputs (list ncurses))
+ (outputs '("out" "debug"))
+ ;; The following was copied from the bundled XML file and formatted.
+ (synopsis "Zen Simulation of robot finding kitten")
+ (description
+ "In this simulation, you play the part of robot. Your task is to
+complete the simulation by finding kitten, as is your destiny, and indeed your
+wont. You (robot) are represented by the # character, and you move around with
+the arrow keys touching things. If the thing you touch is kitten, you get a
+cute little animation (which was cuter in the DOS version) and the simulation
+ends. Otherwise, you get a brief description of what it is you touched.")
+ (home-page "http://robotfindskitten.org/")
+ (license license:gpl2+)))
+
(define-public roguebox-adventures
(package
(name "roguebox-adventures")

base-commit: 8a0713aef2a8d709551d51fefff45f4611d05c66
--
2.34.0
Liliana Marie Prikler wrote 3 years ago
f3cc0d9be758f49247afb3088720657ebf3eb1c7.camel@gmail.com
Hi Roman,

Am Sonntag, dem 20.03.2022 um 16:28 +0200 schrieb Roman Riabenko:

Toggle quote (20 lines)
> + ;; Despite what guix lint says, version 2.8284271.702 is newer
> then
> + ;; 1600003_201b. See ChangeLog for version history.
> + (version "2.8284271.702")
> + ;; The git version is the same as in the release tarball, but it
> bundles
> + ;; convenient .desktop files, which were requested for Debian.
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url
> +
> "https://github.com/robotfindskitten/robotfindskitten")
> + (commit
> "1cae36621f9c19d19a40eacf63789913d4ef5d5c")))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> +
> "0ps3xrl1yh0h7jhl3bwhx5xw2hvhzync03y08i66rzw098r530qq"))))
Looking at the git repository, those are *not* the same. Use git-
version or use the tag as commit, but don't mix conventions.
Toggle quote (3 lines)
> + (replace 'bootstrap
> + (lambda _
> + (invoke "autoreconf" "-ifv"))) ;per README.md
The existing bootstrap should already correctly invoke autoreconf if no
bootstrap script exists.
Toggle quote (9 lines)
> + (add-after 'unpack 'fix-install-path
> + (lambda _
> + ;; It is configured to install executable to
> /games or
> + ;; /usr/local/games per Filesystem Hierarchy
> Standard.
> + ;; We change that to get it in $PATH.
> + (substitute* "src/Makefile.am"
> + (("\\$\\(prefix\\)/games") "$(prefix)/bin"))
We could change this by using #:make-flags instead, I believe.
Toggle quote (12 lines)
> + ;; When built with guix, all characters are
> displayed in
> + ;; the background colour pair. If it is not
> set manually,
> + ;; this is not happening, so we get back
> colour into the
> + ;; game. The background is redrawn anyway. See
> man bkgd.
> + (substitute* "src/robotfindskitten.c"
> + (("\\(void\\) bkgd \\( \\(chtype\\)
> COLOR_PAIR\\(WHITE\\) \\);")
> + "")))))
This should probably go into a "patch-source" phase.

Toggle quote (14 lines)
> + (synopsis "Zen Simulation of robot finding kitten")
> + (description
> + "In this simulation, you play the part of robot. Your task is
> to
> +complete the simulation by finding kitten, as is your destiny, and
> indeed your
> +wont. You (robot) are represented by the # character, and you move
> around with
> +the arrow keys touching things. If the thing you touch is kitten,
> you get a
> +cute little animation (which was cuter in the DOS version) and the
> simulation
> +ends. Otherwise, you get a brief description of what it is you
> touched.")
Both synopsis and description could use some love. Plain copypasta
with grammatical errors is not good optics.

Cheers
Roman Riabenko wrote 3 years ago
0eac7e2692804e6668a0246f79c0e88c495b336e.camel@riabenko.com
Hi Liliana

(Copying the mailing list.)

Thank you for helping to improve this!

У пн, 2022-03-21 у 07:59 +0100, Liliana Marie Prikler пише:
Toggle quote (28 lines)
> Hi Roman,
> Am Sonntag, dem 20.03.2022 um 16:28 +0200 schrieb Roman Riabenko:
> > +    ;; Despite what guix lint says, version 2.8284271.702 is newer
> > then
> > +    ;; 1600003_201b. See ChangeLog for version history.
> > +    (version "2.8284271.702")
> > +    ;; The git version is the same as in the release tarball, but
> > it
> > bundles
> > +    ;; convenient .desktop files, which were requested for Debian.
> > +    (source (origin
> > +              (method git-fetch)
> > +              (uri (git-reference
> > +                    (url
> > +                    
> > "https://github.com/robotfindskitten/robotfindskitten")
> > +                    (commit
> > "1cae36621f9c19d19a40eacf63789913d4ef5d5c")))
> > +              (file-name (git-file-name name version))
> > +              (sha256
> > +               (base32
> > +               
> > "0ps3xrl1yh0h7jhl3bwhx5xw2hvhzync03y08i66rzw098r530qq"))))
> Looking at the git repository, those are *not* the same.  Use git-
> version or use the tag as commit, but don't mix conventions.

I thought the commit log is misleading. Before submitting the patch, I
checked the code and data files, but now that I checked documentation
too, I see that the release, including packages in Debian and Fedora,
do not have the latest fixes to documentation.

It bugged me as cruel towards users to package the release version with
wrong documentation, but, at a more thorough inspection, the
inconsistency in documentation can be figured out after all. If the
authors and maintainers did not deem it worth a release, I do not feel
confident to. After all, I cannot rule out that, theoretically, someone
may even rely on "man robotfindskitten" output for something.

The checkout of the git tag which corresponds to the release version
number is, strictly speaking, somewhat different from the release
tarball. Among other things, it has "contrib" directory with PalmOS
port code. Debian also has the same tarball for original source.
Considering all that, I'd rather go with the tarball than git.

Toggle quote (8 lines)
> > +                  (replace 'bootstrap
> > +                    (lambda _
> > +                      (invoke "autoreconf" "-ifv"))) ;per
> > README.md
> The existing bootstrap should already correctly invoke autoreconf if
> no
> bootstrap script exists.

I recall having some issue without this modification, but I cannot
reproduce it now. Removing.

Toggle quote (12 lines)
> > +                  (add-after 'unpack 'fix-install-path
> > +                    (lambda _
> > +                      ;; It is configured to install executable to
> > /games or
> > +                      ;; /usr/local/games per Filesystem Hierarchy
> > Standard.
> > +                      ;; We change that to get it in $PATH.
> > +                      (substitute* "src/Makefile.am"
> > +                        (("\\$\\(prefix\\)/games")
> > "$(prefix)/bin"))
> We could change this by using #:make-flags instead, I believe.

Thank you for the hint. I didn't expect it to be that simple.

Toggle quote (15 lines)
> > +                      ;; When built with guix, all characters are
> > displayed in
> > +                      ;; the background colour pair. If it is not
> > set manually,
> > +                      ;; this is not happening, so we get back
> > colour into the
> > +                      ;; game. The background is redrawn anyway.
> > See
> > man bkgd.
> > +                      (substitute* "src/robotfindskitten.c"
> > +                        (("\\(void\\) bkgd \\( \\(chtype\\)
> > COLOR_PAIR\\(WHITE\\) \\);")
> > +                         "")))))
> This should probably go into a "patch-source" phase.

I moved this part to a source origin snippet.

Toggle quote (19 lines)
> > +    (synopsis "Zen Simulation of robot finding kitten")
> > +    (description
> > +     "In this simulation, you play the part of robot.  Your task
> > is
> > to
> > +complete the simulation by finding kitten, as is your destiny, and
> > indeed your
> > +wont.  You (robot) are represented by the # character, and you
> > move
> > around with
> > +the arrow keys touching things.  If the thing you touch is kitten,
> > you get a
> > +cute little animation (which was cuter in the DOS version) and the
> > simulation
> > +ends.  Otherwise, you get a brief description of what it is you
> > touched.")
> Both synopsis and description could use some love.  Plain copypasta
> with grammatical errors is not good optics.

My first impression was that it needs some improvement. But I was
quickly discouraged and here is why.

The problem I have with it is that it apparently attempts to pretend to
be something more, not even a game at all, but the Zen Simulation. The
authors invite the audience to a make-believe and this starts with the
synopsis and description and continues in the game and in its
documentation. The story begins with such synopsis and description in
other distributions and package managers too. I really feel as
intruding into the game against the authors intentions by attempting to
modify those.

As to the grammar and spelling, I am embarrassed of my ignorance and
fond of learning something new, which is one of the reasons that I like
this game. When I saw the word "wont", I couldn't imagine that it is a
valid English word, until I verified it with a dictionary. The words
"robot" and "kitten" are consistently used without an article
(including in-game texts and documentation) treating them specially as
characters of the story. The same goes for both words of "Zen
Simulation" being capitalised.

So I leave it as is for now.

I attach a different patch as my new offer.

Roman
From 7e29f26288bf2a6764f0b90cd7eb36c2b48e5e7e Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Thu, 24 Mar 2022 17:12:30 +0200
Subject: [PATCH] gnu: games: Add robotfindskitten.

* gnu/packages/games.scm (robotfindskitten): New variable.
---
gnu/packages/games.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8cc29b3487..f13523a190 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,58 @@ (define-public retux
license:gpl2+
license:gpl3+)))))
+(define-public robotfindskitten
+ ;; Despite what guix lint says, version 2.8284271.702 is newer than
+ ;; 1600003_201b. See ChangeLog for version history.
+ (package
+ (name "robotfindskitten")
+ (version "2.8284271.702")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/"
+ name
+ "/"
+ name
+ "/releases/download/"
+ version
+ "/"
+ name
+ "-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1bwrkxm83r9ajpkd6x03nqvmdfpf5vz6yfy0c97pq3v3ykj74082"))
+ ;; When built with guix, all characters are displayed in the background
+ ;; colour pair for some reason. If it is not set by the program, this
+ ;; is not happening, so the game is coloured properly.
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "src/robotfindskitten.c"
+ (("\\(void\\) bkgd \\( \\(chtype\\) COLOR_PAIR\\(WHITE\\) \\);")
+ ""))))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-silent-rules")
+ #:make-flags ;install to /bin instead of /game
+ (list (string-append "execgamesdir="
+ (assoc-ref %outputs "out") "/bin"))))
+ (inputs (list ncurses))
+ (outputs '("out" "debug"))
+ ;; The following are the original synopsis and description by the authors.
+ (synopsis "Zen Simulation of robot finding kitten")
+ (description
+ "In this simulation, you play the part of robot. Your task is to
+complete the simulation by finding kitten, as is your destiny, and indeed your
+wont. You (robot) are represented by the # character, and you move around with
+the arrow keys touching things. If the thing you touch is kitten, you get a
+cute little animation (which was cuter in the DOS version) and the simulation
+ends. Otherwise, you get a brief description of what it is you touched.")
+ (home-page "http://robotfindskitten.org/")
+ (license license:gpl2+)))
+
(define-public roguebox-adventures
(package
(name "roguebox-adventures")

base-commit: 18119fe288166ff480ca27a1351b09e9c31c1463
--
2.34.0
Roman Riabenko wrote 3 years ago
(address . 54476@debbugs.gnu.org)(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
8a0d6013e738fe0ea9fb7808aae2d1e7bc014669.camel@riabenko.com
Hello

I thought that I was working around a local implementation of ncurses,
but now I am convinced that there is a local bug, which I filed a
report against. See issue 54607. [1]


Assuming that the bug will be fixed, there is no need for the snippet
which I proposed in previous patches. I attach a new patch to add
robotfindskitten, which is my offer in place of previous patches.

Meanwhile, even with that bug not being fixed, robotfindskitten is
still playable. It is just monochrome, which is a mode natively
supported by the game design.

Roman
From 470ab9d236a780425679f4d24776640e7bb766cc Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Mon, 28 Mar 2022 16:49:03 +0300
Subject: [PATCH] gnu: games: Add robotfindskitten.

* gnu/packages/games.scm (robotfindskitten): New variable.
---
gnu/packages/games.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8cc29b3487..7a23140508 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,48 @@ (define-public retux
license:gpl2+
license:gpl3+)))))
+(define-public robotfindskitten
+ ;; Despite what guix lint says, version 2.8284271.702 is newer than
+ ;; 1600003_201b. See ChangeLog for version history.
+ (package
+ (name "robotfindskitten")
+ (version "2.8284271.702")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/"
+ name
+ "/"
+ name
+ "/releases/download/"
+ version
+ "/"
+ name
+ "-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1bwrkxm83r9ajpkd6x03nqvmdfpf5vz6yfy0c97pq3v3ykj74082"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-silent-rules")
+ #:make-flags ;install to /bin instead of /game
+ (list (string-append "execgamesdir="
+ (assoc-ref %outputs "out") "/bin"))))
+ (inputs (list ncurses))
+ (outputs '("out" "debug"))
+ ;; The following are the original synopsis and description by the authors.
+ (synopsis "Zen Simulation of robot finding kitten")
+ (description
+ "In this simulation, you play the part of robot. Your task is to
+complete the simulation by finding kitten, as is your destiny, and indeed your
+wont. You (robot) are represented by the # character, and you move around with
+the arrow keys touching things. If the thing you touch is kitten, you get a
+cute little animation (which was cuter in the DOS version) and the simulation
+ends. Otherwise, you get a brief description of what it is you touched.")
+ (home-page "http://robotfindskitten.org/")
+ (license license:gpl2+)))
+
(define-public roguebox-adventures
(package
(name "roguebox-adventures")

base-commit: 738da660ff51e03b5ef63af9fa81eb50cb222928
--
2.34.0
Liliana Marie Prikler wrote 3 years ago
38b2054628730328b7bd2544597a7db9c0431acb.camel@gmail.com
Am Montag, dem 28.03.2022 um 16:56 +0300 schrieb Roman Riabenko:
Toggle quote (11 lines)
> Hello
>
> I thought that I was working around a local implementation of
> ncurses, but now I am convinced that there is a local bug, which I
> filed a report against. See issue 54607. [1]
>
> [1]: https://issues.guix.gnu.org/54607
>
> Assuming that the bug will be fixed, there is no need for the snippet
> which I proposed in previous patches. I attach a new patch to add
> robotfindskitten, which is my offer in place of previous patches.
For the record, you are still allowed to patch the source in a snippet
or build phase, but you should add a comment referring to this bug when
doing so.

Toggle quote (3 lines)
> Meanwhile, even with that bug not being fixed, robotfindskitten is
> still playable. It is just monochrome, which is a mode natively
> supported by the game design.
Is that purely an aesthetic choice or are there other things to
consider w.r.t. your previous phase? If "monochrome" means black on
white or vice versa and the game only needs those colors, then sure,
waiting for ncurses to be fixed might be the wiser option.

Toggle quote (11 lines)
> + (uri (string-append "https://github.com/"
> + name
> + "/"
> + name
> + "/releases/download/"
> + version
> + "/"
> + name
> + "-"
> + version
> + ".tar.gz"))
Guix style does not always result in the best possible indentation and
is to be taken with a grain of salt.

Toggle quote (14 lines)
> + (synopsis "Zen Simulation of robot finding kitten")
> + (description
> + "In this simulation, you play the part of robot. Your task is
> to
> +complete the simulation by finding kitten, as is your destiny, and
> indeed your
> +wont. You (robot) are represented by the # character, and you move
> around with
> +the arrow keys touching things. If the thing you touch is kitten,
> you get a
> +cute little animation (which was cuter in the DOS version) and the
> simulation
> +ends. Otherwise, you get a brief description of what it is you
> touched.")
Again, this synopsis and description need some love (grammatically
speaking), but it should also cut down on advertisements for
proprietary systems.

Cheers
Roman Riabenko wrote 3 years ago
ac12056ac61dfa8710730d9ffa2e534fcf02a314.camel@riabenko.com
Hi Liliana

I attach a replacement patch that should address all concerns.

Roman
From a6f67e7f17b8924d928f26caca70d0b7ddfc5a04 Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Mon, 11 Apr 2022 13:27:08 +0300
Subject: [PATCH] gnu: games: Add robotfindskitten.

* gnu/packages/games.scm (robotfindskitten): New variable.
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8cc29b3487..f1ae90d847 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,36 @@ (define-public retux
license:gpl2+
license:gpl3+)))))
+(define-public robotfindskitten
+ (package
+ (name "robotfindskitten")
+ (version "2.8284271.702") ; 1600003_201b is older, see ChangeLog
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/" name "/" name
+ "/releases/download/" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bwrkxm83r9ajpkd6x03nqvmdfpf5vz6yfy0c97pq3v3ykj74082"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; there are no tests
+ #:make-flags
+ #~(list "CFLAGS=-D_XOPEN_SOURCE=600" ; http://bugs.gnu.org/54607
+ (string-append "execgamesdir=" #$output "/bin")))) ; /games
+ (inputs (list ncurses))
+ (outputs (list "out" "debug"))
+ (synopsis "Thematic meditative game for terminals")
+ (description
+ "Play for a robot in a realm appearing as a rectangle filled with ASCII
+characters. Move with determination to find the kitten while examining useless
+items with often amusing descriptions and thus experience this \"Zen
+simulation.\" The theme of the game continues in its documentation. You can
+also replace the descriptions of the items with a custom file.")
+ (home-page "http://robotfindskitten.org/")
+ (license license:gpl2+)))
+
(define-public roguebox-adventures
(package
(name "roguebox-adventures")

base-commit: 7da907f90e74a4edf96d76ee457ff958265ef8d4
--
2.35.1
Maxime Devos wrote 3 years ago
Re: [bug#54476] [PATCH] gnu: games: Add robotfindskitten.
4ae286e98001423fe90480d0cb19b1b66c1c10d6.camel@telenet.be
Roman Riabenko schreef op zo 20-03-2022 om 16:28 [+0200]:
Toggle quote (8 lines)
> +(define-public robotfindskitten
> +  (package
> +    (name "robotfindskitten")
> +    ;; Despite what guix lint says, version 2.8284271.702 is newer
> then
> +    ;; 1600003_201b. See ChangeLog for version history.
> +    (version "2.8284271.702")

You can try teaching "guix lint" (actually, (guix import git)) to
recognise the 2.8284271.702 as newest version. Possibly adding

(properties '((release-tag-version-delimiter . ".")))

like done for the 'upower' package is sufficient.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYlVphRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7kCXAQCwRKpreXY+Eb2wY5Jng7U8iSyR
IRLsmQD85PGK8qTXPAD/ZKNUN3CY395oXOHAkXveQS/zFMvPmBwSWsI6SuF6CQM=
=fgyB
-----END PGP SIGNATURE-----


Liliana Marie Prikler wrote 3 years ago
Re: [PATCH] gnu: games: Add robotfindskitten.
0883d1920d6dc54e2c5b8e563e17767cd6f61bc9.camel@gmail.com
Am Montag, dem 11.04.2022 um 13:34 +0300 schrieb Roman Riabenko:
Toggle quote (3 lines)
> Hi Liliana
>
> I attach a replacement patch that should address all concerns.
Pushed with some slight adjustments, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54476@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54476
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help