(address . guix-patches@gnu.org)(name . Felipe Balbi)(address . felipe@balbi.sh)
From: Felipe Balbi <felipe@balbi.sh>
* gnu/packages/rust.scm (rust-1.58): New variable.
* gnu/packages/rust.scm (rust-1.59): New variable.
---
gnu/packages/rust.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
Toggle diff (35 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 26d6df7a9480..26f123833958 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022 Felipe Balbi <felipe@balbi.sh>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -784,11 +785,19 @@ (define rust-1.57
`("procps" ,procps)
(package-native-inputs base-rust))))))
+(define rust-1.58
+ (rust-bootstrapped-package
+ rust-1.57 "1.58.1" "1iq7kj16qfpkx8gvw50d8rf7glbm6s0pj2y1qkrz7mi56vfsyfd8"))
+
+(define rust-1.59
+ (rust-bootstrapped-package
+ rust-1.58 "1.59.0" "1yc5bwcbmbwyvpfq7zvra78l0r8y3lbv60kbr62fzz2vx2pfxj57"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
;;; required to build the full Rust bootstrap chain.
-(define-public rust rust-1.57)
+(define-public rust rust-1.59)
(define-public rust-src
(hidden-package
--
2.34.0