[PATCH] gnu: Add python-textwrap3.

  • Open
  • quality assurance status badge
Details
One participant
  • Pradana Adrinusa AUMARS
Owner
unassigned
Submitted by
Pradana Adrinusa AUMARS
Severity
normal
P
P
Pradana Adrinusa AUMARS wrote on 19 Mar 2022 15:09
(address . guix-patches@gnu.org)
5637bd887facfccc19a6861f40794c8b5b031687.camel@courrier.dev
From d2e058e8dea50ba5335da1821c0eac2b7a8984e9 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sat, 19 Mar 2022 15:07:44 +0100
Subject: [PATCH] gnu: Add python-textwrap3.

* gnu/packages/python-xyz.scm (python-textwrap3): New variable.
---
gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ed6de5a2b..d0aeefd02d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29181,3 +29181,27 @@ (define-public python-multipart
(description
"This package provides a streaming multipart parser for Python.")
(license license:asl2.0)))
+
+(define-public python-textwrap3
+ (package
+ (name "python-textwrap3")
+ (version "0.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "textwrap3" version ".zip"))
+ (sha256
+ (base32
+ "051l1h7f8xdwfjx55n8iflczcmfkasw1i3ynvh1n6vr3vgmyw22h"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list unzip
+ python-pytest
+ python-tox
+ python-pytest-cov))
+ (home-page "https://github.com/jonathaneunice/textwrap3")
+ (synopsis "Compatibility back-port of Python 3.6’s textwrap module.")
+ (description
+ "This package makes a few new APIs such as shorten and the max_lines
+parameter available in a compatible way to all Python versions typically
+in current use.")
+ (license license:psfl)))
--
2.34.0
?