[PATCH 2/2] gnu: tinmop: Update to 0.9.6.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal

Debbugs page

cage wrote 3 years ago
(address . guix-patches@gnu.org)
YjWqxYQK5OZELYk8@kurosawa.casa.net
---
gnu/packages/web-browsers.scm | 87 ++++++++++++++++++-----------------
1 file changed, 46 insertions(+), 41 deletions(-)

Toggle diff (116 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 3d91b17ed3..c4ca474b78 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -815,7 +815,7 @@ (define-public bombadillo
(define-public tinmop
(package
(name "tinmop")
- (version "0.9.2")
+ (version "0.9.6")
(source
(origin
(method git-fetch)
@@ -824,47 +824,52 @@ (define-public tinmop
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1cgx2g2kryfmcwqzzjzcpbdc6zzj10xc52gz0cj2dx5ylc0yg7k3"))))
+ (base32 "19rr1wcadm4698q5gyq0pxv81220l5g8zfnp61s43a4q7kn4mi1z"))))
(build-system gnu-build-system)
(native-inputs
- `(("automake" ,automake)
- ("autoreconf" ,autoconf)
- ("gettext" ,gnu-gettext)
- ("mandoc" , mandoc)
- ("nano" ,nano)
- ("openssl" ,openssl)
- ("sbcl" ,sbcl)
- ("xdg-utils" ,xdg-utils)))
+ (list autoconf
+ automake
+ gnu-gettext
+ mandoc
+ nano
+ openssl
+ sbcl
+ unzip
+ xdg-utils))
(inputs
- `(("access" ,sbcl-access)
- ("alexandria" ,sbcl-alexandria)
- ("babel" ,sbcl-babel)
- ("bordeaux-threads" ,sbcl-bordeaux-threads)
- ("cl-base64" ,sbcl-cl-base64)
- ("cl-colors2" ,sbcl-cl-colors2)
- ("cl-html5-parser" ,sbcl-cl-html5-parser)
- ("cl-i18n" ,sbcl-cl-i18n)
- ("cl-ppcre" ,sbcl-cl-ppcre)
- ("cl-spark" ,sbcl-cl-spark)
- ("cl-sqlite" ,sbcl-cl-sqlite)
- ("cl+ssl" ,sbcl-cl+ssl)
- ("clunit2" ,sbcl-clunit2)
- ("croatoan" ,sbcl-croatoan)
- ("crypto-shortcuts" ,sbcl-crypto-shortcuts)
- ("drakma" ,sbcl-drakma)
- ("esrap" ,sbcl-esrap)
- ("ieee-floats" ,sbcl-ieee-floats)
- ("local-time" ,sbcl-local-time)
- ("log4cl" ,sbcl-log4cl)
- ("marshal" ,sbcl-marshal)
- ("osicat" ,sbcl-osicat)
- ("parse-number" ,sbcl-parse-number)
- ("percent-encoding" ,sbcl-percent-encoding)
- ("sxql" ,sbcl-sxql)
- ("sxql-composer" ,sbcl-sxql-composer)
- ("tooter" ,sbcl-tooter)
- ("unix-opts" ,sbcl-unix-opts)
- ("usocket" ,sbcl-usocket)))
+ (list ncurses
+ sbcl-access
+ sbcl-alexandria
+ sbcl-babel
+ sbcl-bordeaux-threads
+ sbcl-cl+ssl
+ sbcl-cl-base64
+ sbcl-cl-colors2
+ sbcl-cl-html5-parser
+ sbcl-cl-i18n
+ sbcl-cl-ppcre
+ sbcl-cl-spark
+ sbcl-cl-sqlite
+ sbcl-clunit2
+ sbcl-croatoan
+ sbcl-crypto-shortcuts
+ sbcl-drakma
+ sbcl-esrap
+ sbcl-ieee-floats
+ sbcl-local-time
+ sbcl-log4cl
+ sbcl-marshal
+ sbcl-osicat
+ sbcl-parse-number
+ sbcl-percent-encoding
+ sbcl-purgatory
+ sbcl-sxql
+ sbcl-sxql-composer
+ sbcl-tooter
+ sbcl-trivial-clipboard
+ sbcl-unix-opts
+ sbcl-usocket
+ sqlite))
(arguments
`(#:tests? #f
#:strip-binaries? #f
@@ -893,9 +898,9 @@ (define-public tinmop
'("LISP_COMPILER) --eval \"(require 'asdf)\" "
"--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))))
#t)))))
- (synopsis "Gemini and pleroma client with a terminal interface")
+ (synopsis "Gemini, kami and pleroma client with a terminal interface")
(description
- "This package provides a Gemini and pleroma client with a terminal
+ "This package provides a Gemini, kami and pleroma client with a terminal
interface.")
(home-page "https://www.autistici.org/interzona/tinmop.html")
(license license:gpl3+)))
--
2.34.0
Guillaume Le Vaillant wrote 3 years ago
(name . cage)(address . cage-dev@twistfold.it)(address . 54463-done@debbugs.gnu.org)
875yo78yuf.fsf@kitej
Patch pushed as a6d0378fb2561cacf9f96c4e30a0eee53e923ce5 with
a completed commit message.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYjg+mA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8AxQEAnG82OkPltVr9nL5VmKe3+w0/eethcCICh2zS
95ezlFAA/2EbrNLmYLiQAbd7W5Eh1QYmmksG5MtAjBEgIp81C9wR
=oByy
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54463@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54463
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help