[PATCH] opencv: add flag OPENCV_GENERATE_PKGCONFIG required for openFrameworks

  • Done
  • quality assurance status badge
Details
2 participants
  • Blake Shaw
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Blake Shaw
Severity
normal

Debbugs page

Blake Shaw wrote 3 years ago
(address . guix-patches@gnu.org)(name . Blake Shaw)(address . blake@nonconstructivism.com)
32b63bbb7db9533ac1b86a93272a3fafcb489c49.1647617079.git.blake@nonconstructivism.com
---
gnu/packages/image-processing.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 272f400f67..975a5eb792 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -428,7 +428,7 @@ (define-public opencv
"-DWITH_ITT=OFF"
"-DWITH_CAROTENE=OFF" ; only visible on arm/aarch64
"-DENABLE_PRECOMPILED_HEADERS=OFF"
-
+ "-DOPENCV_GENERATE_PKGCONFIG=ON"
;; CPU-Features:
;; See cmake/OpenCVCompilerOptimizations.cmake
;; (CPU_ALL_OPTIMIZATIONS) for a list of all optimizations
@@ -1303,3 +1303,5 @@ (define-public labelme
"Image and video labeling tool supporting different shapes like
polygons, rectangles, circles, lines, points and VOC/COCO export.")
(license license:gpl3+)))
+
+opencv
--
2.34.0
Mathieu Othacehe wrote 3 years ago
(name . Blake Shaw)(address . blake@nonconstructivism.com)(address . 54449-done@debbugs.gnu.org)
87tubqnuqs.fsf@gnu.org
Hello,

I added a commit message,

Toggle quote (3 lines)
> +
> +opencv

removed that bit, and pushed as
614a7610dab88f5124f2837e70ff878861ef2d8d.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54449@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54449
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help