[PATCH] gnu: Add cl-purgatory.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal
C
(address . guix-patches@gnu.org)
YjR5Mxe/XShE3DSh@kurosawa.casa.net
---
gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0c99518e82..4d0da2993a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20823,3 +20823,37 @@ (define-public cl-websocket-driver

(define-public ecl-websocket-driver
(sbcl-package->ecl-package sbcl-websocket-driver))
+
+(define-public sbcl-purgatory
+ (let ((commit "ade0d60a14a1067b9cc8cf06d1f1a1ca8cecdb03")
+ (revision "1"))
+ (package
+ (name "sbcl-purgatory")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/cage/purgatory")
+ (commit commit)))
+ (file-name (git-file-name "purgatory" version))
+ (sha256
+ (base32 "1mwlalymmfbx1jx5wzqcnpg5h8d0ylllm1p3f4lwaawfv05lk82s"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)
+ ("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("usocket" ,sbcl-usocket)
+ ("babel" ,sbcl-babel)))
+ (synopsis "Common Lisp library to make histograms")
+ (description "This is a Common Lisp library that implement
+the 9p network filesystem protocol.")
+ (home-page "https://notabug.org/cage/purgatory/")
+ (license license:llgpl))))
+
+(define-public ecl-purgatory
+ (sbcl-package->ecl-package sbcl-purgatory))
+
+(define-public cl-purgatory
+ (sbcl-package->cl-source-package sbcl-purgatory))
--
2.34.0
G
G
Guillaume Le Vaillant wrote on 18 Mar 2022 14:22
(name . cage)(address . cage-dev@twistfold.it)(address . 54445-done@debbugs.gnu.org)
875yobwg06.fsf@kitej
Patch pushed as cab5f92836ec52b0c524aa2541f3cdcd6c5ceb6e with a few
modifications (updated copyright line, fixed synopsis, used new style
for inputs).
Thanks.
Closed
?