Updates for genext2fs and genimage

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 3 years ago
(address . guix-patches@gnu.org)
87sfrgt7ou.fsf@contorta
I have updates for genext2fs and genimage!

Newer versions of the genext2fs tool have support for things like
SOURCE_DATE_EPOCH, and Guix seems keen on reproducible builds, so Guix
may as well have the latest and greatest genext2fs!

Updating genext2fs triggered test suite failures in genimage, which I
also noticed was a slightly out of date... so updated that too!

Will submit the patches once I get a bug number... (that's really how
this is supposed to be done still?)


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYjPU0gAKCRDcUY/If5cW
qn9DAQDuiQCFm7OQ4CSeiWPfJhimLb0/grpZj/Dxmr3M2jD7RAD/VeFNLlSNMlZm
dfvSoijSQEi15KlDGdi8xVEme9DjsAs=
=LN/9
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 3 years ago
[PATCH 1/2] gnu: genext2fs: Update to 1.5.0.
(address . 54440@debbugs.gnu.org)
87lex8t67m.fsf@contorta
* gnu/packages/linux.scm (genext2fs): Update to 1.5.0.
[source] Update URL.
[arguments] Remove 'apply-debian-patches phase.
[home-page] Update URL.
---
gnu/packages/linux.scm | 25 +++++--------------------
1 file changed, 5 insertions(+), 20 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bf18724990..db6eb2db6f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8020,34 +8020,19 @@ (define-public xfs_repair/static
(define-public genext2fs
(package
(name "genext2fs")
- (version "1.4.1-4")
+ (version "1.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/jeremie-koenig/genext2fs")
- ;; 1.4.1-3 had a VCS tag but 1.4.1-4 doesn't.
- (commit "9ee43894634998b0b2b309d636f25c64314c9421")))
+ (url "https://github.com/bestouff/genext2fs")
+ (commit "474111097321f03de9e009aa9f7d4a8948e310b2")))
(file-name (git-file-name name version))
(sha256
- (base32 "0ib5icn78ciz00zhc1bgdlrwaxvsdz7wnplwblng0jirwi9ml7sq"))))
+ (base32 "14lgvml5zz99845ja47jpf4iirjzfqv36ffzachh3hw2ggji9c7l"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'apply-debian-patches
- ;; Debian changes (the revision after ‘-’ in VERSION) are
- ;; maintained as separate patches. Apply those relevant to us.
- (lambda _
- (for-each
- (lambda (file-name)
- (invoke "patch" "-p1" "-i"
- (string-append "debian/patches/" file-name)))
- (list "blocksize+creator.diff" ; add -B/-o options
- "byteswap_fix.diff"))
- #t)))))
(native-inputs
(list autoconf automake))
- (home-page "https://github.com/jeremie-koenig/genext2fs")
+ (home-page "https://github.com/bestouff/genext2fs")
(synopsis "Generate ext2 file system as a normal user")
(description "This package provides a program to generate an ext2
file system as a normal (non-root) user. It does not require you to mount
--
2.35.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYjPcTgAKCRDcUY/If5cW
qtunAQCNijEz0P+IzCJlIagq8SWw3lMrp1SljJ9ij34nmfhh2wEAncFkFyFa35CX
X08148+0znsXXp42CQLpMi+FLOcgagA=
=GuiJ
-----END PGP SIGNATURE-----

Vagrant Cascadian wrote 3 years ago
[PATCH 2/2] gnu: genimage: Update to 15.
(address . 54440@debbugs.gnu.org)
87ilsct65s.fsf@contorta
* gnu/packages/genimage.scm (genimage): Update to 15.
[arguments]: Update 'fix-failing-tests phase to reference new files.
---
gnu/packages/genimage.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index eb50141374..4a9d24fe78 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -41,11 +41,11 @@ (define-module (gnu packages genimage)
#:use-module (gnu packages virtualization))
(define-public genimage
- (let ((commit "11bb04455eaf5434f0723c91a2224918ebd0a196")
+ (let ((commit "ec44ae086c705e6f0439e742c5a2e9b8f3d6ca82")
(revision "1"))
(package
(name "genimage")
- (version (git-version "14" revision commit))
+ (version (git-version "15" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -54,7 +54,7 @@ (define-public genimage
(file-name (git-file-name name version))
(sha256
(base32
- "1dq3lk0awk12v2aidry35gvrci5a3nr6rzcq0j9hyyf0w1z1rn0l"))
+ "0amj2vjff58yna6kq959i2gqmbjywqr8j5kr5pjqsvbqam3vgg0r"))
(patches
(search-patches "genimage-mke2fs-test.patch"))))
(build-system gnu-build-system)
@@ -93,9 +93,13 @@ (define-public genimage
;; We don't have /etc/passwd so uid 0 is not known as "root".
;; Thus patch it out.
(substitute* '("test/ext2test.0.dump"
+ "test/ext2test.1.dump"
"test/ext3test.0.dump"
+ "test/ext3test.1.dump"
"test/ext4test.0.dump"
+ "test/ext4test.1.dump"
"test/ext2test-percent.0.dump"
+ "test/ext2test-percent.1.dump"
"test/mke2fs.0.dump")
(("root") "unknown"))))
(add-before 'check 'setenv-check
--
2.35.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYjPckAAKCRDcUY/If5cW
qlY8APsFDwwvyPXXkpcA0K8n1Q79nzYQVE8uzBrWeDthrbwTyQD/a2FNEQUKp8kX
fKs+7tMwp6RSUqGoB5U36/8Oq9oAbQs=
=/W7J
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 3 years ago
Re: bug#54440: Updates for genext2fs and genimage
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 54440@debbugs.gnu.org)
87cziinrn5.fsf@gnu.org
Hello Vagrant,

Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (6 lines)
> I have updates for genext2fs and genimage!
>
> Newer versions of the genext2fs tool have support for things like
> SOURCE_DATE_EPOCH, and Guix seems keen on reproducible builds, so Guix
> may as well have the latest and greatest genext2fs!

Yup, sounds like an interesting option! I’m not sure yet it can be used
as a drop-in replacement in (gnu build images), but we’ll see.

Toggle quote (6 lines)
> Updating genext2fs triggered test suite failures in genimage, which I
> also noticed was a slightly out of date... so updated that too!
>
> Will submit the patches once I get a bug number... (that's really how
> this is supposed to be done still?)

Yes. :-)

The patches LGTM, thank you!

Ludo’.
Vagrant Cascadian wrote 3 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 54440-done@debbugs.gnu.org)
87v8vfp8rb.fsf@contorta
On 2022-03-19, Ludovic Courtès wrote:
Toggle quote (11 lines)
> Vagrant Cascadian <vagrant@debian.org> skribis:
>
>> I have updates for genext2fs and genimage!
>>
>> Newer versions of the genext2fs tool have support for things like
>> SOURCE_DATE_EPOCH, and Guix seems keen on reproducible builds, so Guix
>> may as well have the latest and greatest genext2fs!
>
> Yup, sounds like an interesting option! I’m not sure yet it can be used
> as a drop-in replacement in (gnu build images), but we’ll see.

I have seen instructions for adding features using tune2fs after the
fact to make it ext3 or ext4 ... or other arbitrary features (though not
all can be) and who knows how that will affect the reproducibility of
the image!

Toggle quote (2 lines)
>> Updating genext2fs triggered test suite failures in genimage, which I
>> also noticed was a slightly out of date... so updated that too!
...
Toggle quote (2 lines)
> The patches LGTM, thank you!

Pushed as:

ba1ce250c8d2d0d3c215e06d722f8d561cbe095f gnu: genimage: Update to 15.
8aae96b44c2e84f31574200aa71c6ee4979b1620 gnu: genext2fs: Update to 1.5.0.


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYlSoaAAKCRDcUY/If5cW
qrXiAQCgIvIjRngCIlOgTcSATAxjIU6d09YMaSnf54co8D4mJAD+NMNPYPVjDsxL
dMd8KhIUTaCOxBQD7CApc+i/6tm3OQI=
=JnUO
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54440@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54440
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help