J. Sims wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
This fixes issues with Linux 5.17 and adds optimizations for 5.15:
It also runs `guix style`.
* gnu/packages/linux.scm (rtl8812au-aircrack-ng-linux-module):
Update to commit 37e27f9.
---
gnu/packages/linux.scm | 33 ++++++++++++++-------------------
1 file changed, 14 insertions(+), 19 deletions(-)
Toggle diff (48 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0dc5c8260e..a49443bb3d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1383,29 +1383,24 @@ (define-public rtl8821ce-linux-module
(license license:gpl2))))
(define-public rtl8812au-aircrack-ng-linux-module
- (let ((commit "307d694076b056588c652c2bdaa543a89eb255d9")
- (revision "6"))
+ (let ((commit "37e27f9165300c89607144b646545fac576ec510") (revision "7"))
(package
(inherit rtl8821ce-linux-module)
(name "rtl8812au-aircrack-ng-linux-module")
(version (git-version "5.6.4.2" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aircrack-ng/rtl8812au")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1g2zga7jqzp4azwqpgxxx3lg07ijaaqw3zqnaa3i2brycwlnf8l9"))
- (modules '((guix build utils)))
- (snippet
- #~(begin
- ;; Remove bundled tarballs, APKs, word lists, speadsheets,
- ;; and other unnecessary unlicenced things.
- (for-each delete-file-recursively (list "android"
- "docs"
- "tools"))))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aircrack-ng/rtl8812au")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09n814pa6i0b0xkgssymcmbcdic05y9z5bsr6sxjfs40wawsk6af"))
+ (modules '((guix build utils)))
+ (snippet #~(begin
+ (for-each delete-file-recursively
+ (list "android" "docs" "tools"))))))
(supported-systems '("x86_64-linux" "i686-linux"))
(home-page "https://github.com/aircrack-ng/rtl8812au")
(synopsis "Linux driver for Realtek USB wireless network adapters")
--
2.34.0