Adding network-manager-openvpn requires a full reboot

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 15 Mar 2022 16:24
(name . bug-guix)(address . bug-guix@gnu.org)
87sfrjck7w.fsf@gmail.com
Hello Guix,

I've been bitten by this before, and again this morning, so I'm
reporting this behavior as a bug.

The struggle looks a bit like this:

1. Add the 'network-manager-openvpn' plugin to your
'network-manager-configuration', like so:

Toggle snippet (8 lines)
(modify-services %desktop-services
[...]
(network-manager-service-type config =>
(network-manager-configuration
(inherit config)
(vpn-plugins (list network-manager-openvpn))))

2. 'guix system reconfigure' your system with the change

3. Try configuring/importing an OpenVPN connection; it fails because the
plugin hasn't yet been made available.

4. Restart the networking service and relogin.

5. Now it seems to be functional, but the connection fails to be
established, with a timeout error.

6. Reboot the machine.

7. Try again: it now works.

Thanks,

Maxim
M
M
Maxime Devos wrote on 15 Mar 2022 17:32
146ed7e23e6473d2e00ad7c0cea7f5fc43843051.camel@telenet.be
Maxim Cournoyer schreef op di 15-03-2022 om 11:24 [-0400]:
Toggle quote (12 lines)
> 1. Add the 'network-manager-openvpn' plugin to your
> 'network-manager-configuration', like so:
>
> --8<---------------cut here---------------start------------->8---
> (modify-services %desktop-services
>  [...]
>  (network-manager-service-type config =>
>                  (network-manager-configuration
>         (inherit config)
>         (vpn-plugins (list network-manager-openvpn))))
> --8<---------------cut here---------------end--------------->8---

Looking at 'network-manager-environment'

(define network-manager-environment
(match-lambda
(($ <network-manager-configuration> network-manager dns vpn-
plugins)
;; Define this variable in the global environment such that
;; "nmcli connection import type openvpn file foo.ovpn" works.
`(("NM_VPN_PLUGIN_DIR"
. ,(file-append (vpn-plugin-directory vpn-plugins)
"/lib/NetworkManager/VPN")))))),

I expect a potential issue to be that NM_VPN_PLUGIN_DIR is a
/gnu/store/... file name and hence the plugins in there are
not adjusted by a reconfiguration. Maybe it could instead
refer to somewhere in /run/current-system/...?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYjC/gRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7rAAAQCLl5IW7hMfSAfvtElESDi8j9zN
4UF1Tuau1aEfp7YLtgD/UQFT6s5rs0ETIC7Ju9bSMgA3UZRzn1zuv4kc5xsJFwg=
=IEeE
-----END PGP SIGNATURE-----


?