[PATCH] gnu: cl-find-port: Update to 20190601.

  • Done
  • quality assurance status badge
Details
4 participants
  • Guillaume Le Vaillant
  • jgart
  • Tobias Geerinckx-Rice
  • Raghav Gururajan
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220312231808.29254-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-find-port): Update to 20190601.
[version]: Use git-version function with date of commit.
---
gnu/packages/lisp-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fc18742e3c..53aa9c6ae5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5120,12 +5120,12 @@ (define-public cl-verbose
(sbcl-package->cl-source-package sbcl-verbose))
(define-public sbcl-find-port
- (let ((commit "00c96a25af93a0f8681d34ec548861f2d7485478")
- (revision "1"))
+ (let ((commit "811727f88d7f000623bf92fdb0e64678a7112a28")
+ (revision "2"))
(package
(name "sbcl-find-port")
(build-system asdf-build-system/sbcl)
- (version "0.1")
+ (version (git-version "20190601" revision commit))
(home-page "https://github.com/eudoxia0/find-port")
(source
(origin
@@ -5136,7 +5136,7 @@ (define-public sbcl-find-port
(file-name (git-file-name name version))
(sha256
(base32
- "0d6dzbb45jh0rx90wgs6v020k2xa87mvzas3mvfzvivjvqqlpryq"))))
+ "1fw6q7d2bxxb7fqk548ylq8mx4sz95yc0q5h0rwd0mnqjrbwbari"))))
(native-inputs
(list sbcl-fiveam))
(inputs
--
2.35.1
T
T
Tobias Geerinckx-Rice wrote on 13 Mar 2022 00:27
131FAC34-C16A-4F50-83E2-1A37CABD2BFF@tobias.gr
On 12 March 2022 23:18:08 UTC, jgart via Guix-patches via <guix-patches@gnu.org> wrote:
Toggle quote (6 lines)
> (define-public sbcl-find-port
>- (let ((commit "00c96a25af93a0f8681d34ec548861f2d7485478")
>- (revision "1"))
>+ (let ((commit "811727f88d7f000623bf92fdb0e64678a7112a28")
>+ (revision "2"))

LGTM.

Toggle quote (3 lines)
>- (version "0.1")
>+ (version (git-version "20190601" revision commit))

Err... LNSGTM. Why? I can't find a justification for this upstream.

If there is one, please always add it as comment.

Otherwise, it should remain 0.1 but (indeed) with git-version which should have been there from the start.
Hi jgart,

Thanks!

T G-R

Sent on the go. Excuse or enjoy my brevity.
J
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
20220312203324.GB5243@gac.attlocal.net
On Sat, 12 Mar 2022 23:27:09 +0000 Tobias Geerinckx-Rice <me@tobias.gr> wrote:
Toggle quote (2 lines)
> If there is one, please always add it as comment.

Hi Tobias!

I'll make sure to add a comment in the future for packages that don't
have version numbers.

It seems like a fairly common practice in the common lisp community to
not make version releases though.

Do you need me to send a v2 with the comment?

Toggle quote (3 lines)
> Otherwise, it should remain 0.1 but (indeed) with git-version which should have been there from the start.
> Hi jgart,

There's no mention of 0.1 in the current commit. Is it a Guix convention
to use 0.1 when we don't know the version of the package and only have
a particular commit?

all best,

jgart
G
G
Guillaume Le Vaillant wrote on 13 Mar 2022 09:37
(name . jgart)(address . jgart@dismail.de)
87tuc2mei4.fsf@kitej
jgart via Guix-patches via <guix-patches@gnu.org> skribis:

Toggle quote (4 lines)
> There's no mention of 0.1 in the current commit. Is it a Guix convention
> to use 0.1 when we don't know the version of the package and only have
> a particular commit?

Hi,

In the "find-port.asd" file, the find-port system definition has a field
indicating ":version 0.1".
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYi2uEw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+c8QEAh24wRoD7vHLIyJ1FBD78lP/JQmlbp7hWb402
5rUyuq8A/0mZWBP0x99HM/R4oY8Vnc5O9NCGb0whtmUKUO+8IDtJ
=CXMp
-----END PGP SIGNATURE-----

R
R
Raghav Gururajan wrote on 13 Mar 2022 09:53
Re: [PATCH] gnu: cl-find-port: Update to 20190601.
(address . 54362-done@debbugs.gnu.org)
dd708f44-6b0c-03fc-cf90-7d48c8bda486@raghavgururajan.name
I agree with T G-R. It should have been git-version from the beginning.
Also, for packages with no releases, we usually start version and
revision with "0", and increment revision by one for every update. Not
sure why the version was started with "0.1", but lets keep it that way
for now. :)
Pushed as 1a36fb51a8..f69727278b to master.
Attachment: OpenPGP_signature
Closed
J
[PATCH v2] gnu: cl-find-port: Update to 242cfc6.
(address . 54362@debbugs.gnu.org)
20220313173316.5331-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-find-port): Update to 242cfc6.
[version]: Use git-version function with version stated in asd file.
---
Hi all,

Thanks for the review. It is much appreciated.

Here is a v2 of the requested changes.

Guillaume, thanks for pointing out the version number in the asd file.

That version number is from 7 years ago according to `git blame` but if
you think we should still use it that is fine with me. I think the author
is probably just not making version releases and just releasing commits.

all best,

jgart

gnu/packages/lisp-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fc18742e3c..b95466d93b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5120,12 +5120,12 @@ (define-public cl-verbose
(sbcl-package->cl-source-package sbcl-verbose))
(define-public sbcl-find-port
- (let ((commit "00c96a25af93a0f8681d34ec548861f2d7485478")
- (revision "1"))
+ (let ((commit "811727f88d7f000623bf92fdb0e64678a7112a28")
+ (revision "2"))
(package
(name "sbcl-find-port")
(build-system asdf-build-system/sbcl)
- (version "0.1")
+ (version (git-version "0.1" revision commit))
(home-page "https://github.com/eudoxia0/find-port")
(source
(origin
@@ -5136,7 +5136,7 @@ (define-public sbcl-find-port
(file-name (git-file-name name version))
(sha256
(base32
- "0d6dzbb45jh0rx90wgs6v020k2xa87mvzas3mvfzvivjvqqlpryq"))))
+ "1fw6q7d2bxxb7fqk548ylq8mx4sz95yc0q5h0rwd0mnqjrbwbari"))))
(native-inputs
(list sbcl-fiveam))
(inputs
--
2.35.1
?