[PATCH] services: thermald: Add 'adaptive?' field.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jelle Licht
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal
J
J
Jelle Licht wrote on 12 Mar 2022 23:12
(address . guix-patches@gnu.org)
711c688c39edd755893999a13fa336d58ad15391.1647123159.git.jlicht@fsfe.org
* gnu/services/pm.scm (<thermald-configuration>): Add 'adaptive?' field.
(thermald-shepherd-service): Use it to pass --adaptive to thermald.
* doc/guix.texi (Power Management Services): Document the 'adaptive?' field of
'thermald-configuration'.
---
doc/guix.texi | 4 ++++
gnu/services/pm.scm | 5 +++++
2 files changed, 9 insertions(+)

Toggle diff (42 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 4b71fb7010..82dce87eed 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -30687,6 +30687,10 @@ Power Management Services
Data type representing the configuration of @code{thermald-service-type}.
@table @asis
+@item @code{adaptive?} (default: @code{#f})
+Use @acronym{DPTF, Dynamic Power and Thermal Framework} adaptive tables
+when present.
+
@item @code{ignore-cpuid-check?} (default: @code{#f})
Ignore cpuid check for supported CPU models.
diff --git a/gnu/services/pm.scm b/gnu/services/pm.scm
index 3da3c0b961..e48236dbca 100644
--- a/gnu/services/pm.scm
+++ b/gnu/services/pm.scm
@@ -435,6 +435,8 @@ (define (generate-tlp-documentation)
(define-record-type* <thermald-configuration>
thermald-configuration make-thermald-configuration
thermald-configuration?
+ (adaptive? thermald-adaptive? ;boolean
+ (default #f))
(ignore-cpuid-check? thermald-ignore-cpuid-check? ;boolean
(default #f))
(thermald thermald-thermald ;file-like
@@ -448,6 +450,9 @@ (define (thermald-shepherd-service config)
(start #~(make-forkexec-constructor
'(#$(file-append (thermald-thermald config) "/sbin/thermald")
"--no-daemon"
+ #$@(if (thermald-adaptive? config)
+ '("--adaptive")
+ '())
#$@(if (thermald-ignore-cpuid-check? config)
'("--ignore-cpuid-check")
'()))))

base-commit: 504d15a593faf06ed502057406a20b3601e12759
--
2.34.0
M
M
Mathieu Othacehe wrote on 18 Mar 2022 10:43
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 54360@debbugs.gnu.org)
8735jf8ukb.fsf@gnu.org
Hello Jelle,

Toggle quote (5 lines)
> * gnu/services/pm.scm (<thermald-configuration>): Add 'adaptive?' field.
> (thermald-shepherd-service): Use it to pass --adaptive to thermald.
> * doc/guix.texi (Power Management Services): Document the 'adaptive?' field of
> 'thermald-configuration'.

Looks fine, please go ahead.

Thanks,

Mathieu
J
J
Jelle Licht wrote on 20 Mar 2022 16:45
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 54360-done@debbugs.gnu.org)
86y214y6ea.fsf@fsfe.org
Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (13 lines)
> Hello Jelle,
>
>> * gnu/services/pm.scm (<thermald-configuration>): Add 'adaptive?' field.
>> (thermald-shepherd-service): Use it to pass --adaptive to thermald.
>> * doc/guix.texi (Power Management Services): Document the 'adaptive?' field of
>> 'thermald-configuration'.
>
> Looks fine, please go ahead.
>
> Thanks,
>
> Mathieu

pushed as 10d865aa92 to master,

- Jelle
Closed
J
J
Jelle Licht wrote on 20 Mar 2022 16:52
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 54360-done@debbugs.gnu.org)
86wngoy632.fsf@fsfe.org
Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (13 lines)
> Hello Jelle,
>
>> * gnu/services/pm.scm (<thermald-configuration>): Add 'adaptive?' field.
>> (thermald-shepherd-service): Use it to pass --adaptive to thermald.
>> * doc/guix.texi (Power Management Services): Document the 'adaptive?' field of
>> 'thermald-configuration'.
>
> Looks fine, please go ahead.
>
> Thanks,
>
> Mathieu

pushed as 10d865aa92 to master,

- Jelle
Closed
?