angry rectangle wrote 3 years ago
(address . guix-patches@gnu.org)
Because of a typo, aliases aren't included if guix-defaults? is #f.
This patch also fixes an inaccuracy in the documentation about placement of defaults.
They're actually put at the top, after aliases. Which is good considering it has the "exit if non-interactive" statement.
From 0a278853a0b9b33082a8d3164424e8b7d1abb7dd Mon Sep 17 00:00:00 2001
From: angryrectangle <angryrectangle@cock.li>
Date: Sat, 12 Mar 2022 15:28:15 -0500
Subject: [PATCH] home: services: Fix bash aliases without guix-defaults.
* gnu/home/services/shells.scm: Fix bash aliases not being added if
guix-defaults? was #f. Also fix inaccuracy in documentation about placement
of defaults.
---
gnu/home/services/shells.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index ca7f4ac0ad..9a79db484a 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -324,7 +324,7 @@ (define-configuration home-bash-configuration
(guix-defaults?
(boolean #t)
"Add sane defaults like reading @file{/etc/bashrc} and coloring the output of
-@command{ls} to the end of the @file{.bashrc} file.")
+@command{ls} to the top of the @file{.bashrc} file.")
(environment-variables
(alist '())
"Association list of environment variables to set for the Bash session. The
@@ -448,7 +448,7 @@ (define (add-bash-configuration config)
'bashrc
(if (home-bash-configuration-guix-defaults? config)
(list (serialize-field 'aliases) guix-bashrc)
- (list (serialize-field 'alises))))
+ (list (serialize-field 'aliases))))
(file-if-not-empty 'bash-logout)))))
(define (add-bash-packages config)
--
2.34.0