[PATCH] home: services: Fix bash aliases without guix-defaults.

  • Done
  • quality assurance status badge
Details
2 participants
  • angry rectangle
  • Ludovic Courtès
Owner
unassigned
Submitted by
angry rectangle
Severity
normal

Debbugs page

angry rectangle wrote 3 years ago
(address . guix-patches@gnu.org)
878rteg9vo.fsf@cock.li
Because of a typo, aliases aren't included if guix-defaults? is #f.

This patch also fixes an inaccuracy in the documentation about placement of defaults.
They're actually put at the top, after aliases. Which is good considering it has the "exit if non-interactive" statement.
From 0a278853a0b9b33082a8d3164424e8b7d1abb7dd Mon Sep 17 00:00:00 2001
From: angryrectangle <angryrectangle@cock.li>
Date: Sat, 12 Mar 2022 15:28:15 -0500
Subject: [PATCH] home: services: Fix bash aliases without guix-defaults.

* gnu/home/services/shells.scm: Fix bash aliases not being added if
guix-defaults? was #f. Also fix inaccuracy in documentation about placement
of defaults.
---
gnu/home/services/shells.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index ca7f4ac0ad..9a79db484a 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -324,7 +324,7 @@ (define-configuration home-bash-configuration
(guix-defaults?
(boolean #t)
"Add sane defaults like reading @file{/etc/bashrc} and coloring the output of
-@command{ls} to the end of the @file{.bashrc} file.")
+@command{ls} to the top of the @file{.bashrc} file.")
(environment-variables
(alist '())
"Association list of environment variables to set for the Bash session. The
@@ -448,7 +448,7 @@ (define (add-bash-configuration config)
'bashrc
(if (home-bash-configuration-guix-defaults? config)
(list (serialize-field 'aliases) guix-bashrc)
- (list (serialize-field 'alises))))
+ (list (serialize-field 'aliases))))
(file-if-not-empty 'bash-logout)))))
(define (add-bash-packages config)
--
2.34.0
angry rectangle wrote 3 years ago
(address . 54356@debbugs.gnu.org)
87zgluesct.fsf@cock.li
Oops, the patch was wrapped. I'll try again.
If this doesn't work, the original patch can be fixed by removing the ">" and moving the "of" that's on its own line to the previous one.
From 0a278853a0b9b33082a8d3164424e8b7d1abb7dd Mon Sep 17 00:00:00 2001
From: angryrectangle <angryrectangle@cock.li>
Date: Sat, 12 Mar 2022 15:28:15 -0500
Subject: [PATCH] home: services: Fix bash aliases without guix-defaults.

* gnu/home/services/shells.scm: Fix bash aliases not being added if
guix-defaults? was #f. Also fix inaccuracy in documentation about placement
of defaults.
---
gnu/home/services/shells.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index ca7f4ac0ad..9a79db484a 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -324,7 +324,7 @@ (define-configuration home-bash-configuration
(guix-defaults?
(boolean #t)
"Add sane defaults like reading @file{/etc/bashrc} and coloring the output of
-@command{ls} to the end of the @file{.bashrc} file.")
+@command{ls} to the top of the @file{.bashrc} file.")
(environment-variables
(alist '())
"Association list of environment variables to set for the Bash session. The
@@ -448,7 +448,7 @@ (define (add-bash-configuration config)
'bashrc
(if (home-bash-configuration-guix-defaults? config)
(list (serialize-field 'aliases) guix-bashrc)
- (list (serialize-field 'alises))))
+ (list (serialize-field 'aliases))))
(file-if-not-empty 'bash-logout)))))
(define (add-bash-packages config)
--
2.34.0
Ludovic Courtès wrote 3 years ago
(name . angry rectangle)(address . angryrectangle@cock.li)(address . 54356-done@debbugs.gnu.org)
874k3vqryw.fsf_-_@gnu.org
Hi,

angry rectangle <angryrectangle@cock.li> skribis:

Toggle quote (9 lines)
>>From 0a278853a0b9b33082a8d3164424e8b7d1abb7dd Mon Sep 17 00:00:00 2001
> From: angryrectangle <angryrectangle@cock.li>
> Date: Sat, 12 Mar 2022 15:28:15 -0500
> Subject: [PATCH] home: services: Fix bash aliases without guix-defaults.
>
> * gnu/home/services/shells.scm: Fix bash aliases not being added if
> guix-defaults? was #f. Also fix inaccuracy in documentation about placement
> of defaults.

Good catch! I applied it and fixed the same string in doc/guix.texi.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54356@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54356
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help