guix lint prints backtrace on http-get-error condition

  • Open
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal

Debbugs page

Maxim Cournoyer wrote 3 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
87r177syjf.fsf@gmail.com
Hi,

Running 'guix lint extra-cmake-modules', I get the following backtrace:

Toggle snippet (45 lines)
following redirection to `https://mirrors.mit.edu/kde/ls-lR.bz2'...
Backtrace:
In ice-9/boot-9.scm:
1752:10 18 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In unknown file:
17 (apply-smob/0 #<thunk 7faf174292e0>)
In ice-9/boot-9.scm:
724:2 16 (call-with-prompt _ _ #<procedure default-prompt-handler (k proc)>)
In ice-9/eval.scm:
619:8 15 (_ #(#(#<directory (guile-user) 7faf1742ec80>)))
In guix/ui.scm:
2229:7 14 (run-guix . _)
2192:10 13 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 12 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
1752:10 11 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/store.scm:
658:37 10 (thunk)
In srfi/srfi-1.scm:
634:9 9 (for-each #<procedure 7faf150c4e20 at guix/scripts/lint.scm:222:23 (spec)> _)
In guix/scripts/lint.scm:
65:4 8 (run-checkers _ _ #:store _)
In srfi/srfi-1.scm:
634:9 7 (for-each #<procedure 7faef358a810 at guix/scripts/lint.scm:65:14 (checker)> _)
In guix/scripts/lint.scm:
74:21 6 (_ _)
In guix/lint.scm:
1474:5 5 (check-for-updates #<package extra-cmake-modules@5.70.0 gnu/packages/kde-frameworks.scm:8…>)
813:2 4 (call-with-networking-fail-safe _ _ _)
In ice-9/boot-9.scm:
1752:10 3 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
1685:16 2 (raise-exception _ #:continuable? _)
1683:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
ERROR:
1. &http-get-error:
uri: #<<uri> scheme: https userinfo: #f host: "mirrors.mit.edu" port: #f path: "/kde/ls-lR.bz2" query: #f fragment: #f>
code: 404
reason: "Not Found"
headers: ((date . #<date nanosecond: 0 second: 13 minute: 15 hour: 2 day: 12 month: 3 year: 2022 zone-offset: 0>) (server . "Apache/2.4.41 (Ubuntu)") (content-length . 278) (connection close) (content-type text/html (charset . "iso-8859-1")))
2. &message: "https://mirrors.mit.edu/kde/ls-lR.bz2: HTTP download failed: 404 (\"Not Found\")"

It reproduces every time.

Thanks,

Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54347@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54347
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help