Toggle diff (464 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 65e0109891..24d454820b 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2020, 2021 Simon South <simon@simonsouth.net>
+;;; Copyright © 2020, 2021, 2022 Simon South <simon@simonsouth.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
;;;
@@ -1527,7 +1527,7 @@ (define-public ucsim
(define-public sdcc
(package
(name "sdcc")
- (version "4.1.0")
+ (version "4.2.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1535,7 +1535,7 @@ (define-public sdcc
"/" version "/sdcc-src-" version ".tar.bz2"))
(sha256
(base32
- "0gskzli17ghnn5qllvn4d56qf9bvvclqjh63nnj63p52smvggvc1"))
+ "0ly0m3q9vzjb9kcfjh79s77wpl4w7xhybzy4h9x0bmmw4cfsx6xl"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1573,9 +1573,9 @@ (define-public sdcc
(home-page "http://sdcc.sourceforge.net")
(synopsis "C compiler suite for 8-bit microcontrollers")
(description "SDCC is a retargetable, optimizing Standard C compiler suite
-that targets 8-bit microcontrollers in the Intel MCS-51 (8051); Motorola
-68HC08; Padauk PDK13, PDK14 and PDK15; STMicroelectronics STM8; and Zilog Z80
-families, plus many of their variants.")
+that targets 8-bit microcontrollers in the Intel MCS-51 (8051); MOS Technology
+6502; Motorola 68HC08; Padauk PDK13, PDK14 and PDK15; STMicroelectronics STM8;
+and Zilog Z80 families, plus many of their variants.")
(license (list license:gpl2+
license:gpl3+
license:lgpl2.0+
diff --git a/gnu/packages/patches/sdcc-disable-non-free-code.patch b/gnu/packages/patches/sdcc-disable-non-free-code.patch
index 1c823c3c18..39046ae280 100644
--- a/gnu/packages/patches/sdcc-disable-non-free-code.patch
+++ b/gnu/packages/patches/sdcc-disable-non-free-code.patch
@@ -15,10 +15,10 @@ remove instructions that encourage the use of SDCC with non-free
software.
diff --git a/Makefile.common.in b/Makefile.common.in
-index 926b761..0362fd5 100644
+index 1a11f67..69d5efe 100644
--- a/Makefile.common.in
+++ b/Makefile.common.in
-@@ -71,7 +71,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
+@@ -73,7 +73,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
OPT_DISABLE_SDBINUTILS = @OPT_DISABLE_SDBINUTILS@
OPT_DISABLE_SDCPP = @OPT_DISABLE_SDCPP@
OPT_DISABLE_UCSIM = @OPT_DISABLE_UCSIM@
@@ -27,10 +27,10 @@ index 926b761..0362fd5 100644
SLIB = $(top_builddir)/support/util
diff --git a/Makefile.in b/Makefile.in
-index 5485074..3071472 100644
+index d899b62..554a1c3 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -100,9 +100,6 @@ endif
+@@ -105,9 +105,6 @@ endif
ifeq ($(OPT_DISABLE_DEVICE_LIB), 0)
TARGETS += sdcc-device-lib
PKGS += device/lib
@@ -40,7 +40,7 @@ index 5485074..3071472 100644
endif
ifeq ($(OPT_DISABLE_PACKIHX), 0)
-@@ -123,9 +120,6 @@ endif
+@@ -128,9 +125,6 @@ endif
TARGETS += sdcc-libs sdcc-cc sdcc-device-inc sdcc-as sdcc-ld sdcc-scripts
PKGS += $(SDCC_LIBS) src device/include
@@ -50,7 +50,7 @@ index 5485074..3071472 100644
PKGS += $(SDCC_AS) sdas/linksrc $(SDCC_SCRIPTS)
PORTS = $(shell cat ports.build)
-@@ -171,21 +165,12 @@ sdcc-sdbinutils:
+@@ -176,21 +170,12 @@ sdcc-sdbinutils:
sdcc-device-inc:
$(MAKE) -C device/include
@@ -73,10 +73,10 @@ index 5485074..3071472 100644
# doc depends on latex and latex2html
diff --git a/configure b/configure
-index 4c2226b..b8a9251 100755
+index 232d98e..3eeb17c 100755
--- a/configure
+++ b/configure
-@@ -632,7 +632,6 @@ LATEX
+@@ -659,7 +659,6 @@ LATEX
LATEX2HTML
LYX
OPT_ENABLE_DOC
@@ -84,7 +84,7 @@ index 4c2226b..b8a9251 100755
OPT_DISABLE_SDBINUTILS
OPT_DISABLE_SDCDB
OPT_DISABLE_SDCPP
-@@ -661,10 +660,7 @@ OPT_DISABLE_R2K
+@@ -690,10 +689,7 @@ OPT_DISABLE_R2K
OPT_DISABLE_Z180
OPT_DISABLE_Z80
OPT_DISABLE_MCS51
@@ -95,7 +95,7 @@ index 4c2226b..b8a9251 100755
include_dir_suffix
inclib_dir_suffix
LIB_TYPE
-@@ -785,7 +781,6 @@ enable_packihx
+@@ -821,7 +817,6 @@ enable_packihx
enable_sdcpp
enable_sdcdb
enable_sdbinutils
@@ -103,7 +103,7 @@ index 4c2226b..b8a9251 100755
enable_doc
enable_libgc
'
-@@ -806,10 +801,7 @@ sdccconf_h_dir_separator
+@@ -842,10 +837,7 @@ sdccconf_h_dir_separator
LIB_TYPE
inclib_dir_suffix
include_dir_suffix
@@ -114,7 +114,7 @@ index 4c2226b..b8a9251 100755
docdir'
ac_subdirs_all='support/cpp
support/packihx
-@@ -817,9 +809,7 @@ sim/ucsim
+@@ -853,9 +845,7 @@ sim/ucsim
debugger/mcs51
support/sdbinutils
device/lib/pic14
@@ -125,7 +125,7 @@ index 4c2226b..b8a9251 100755
# Initialize some variables set by options.
ac_init_help=
-@@ -1473,7 +1463,6 @@ Optional Features:
+@@ -1509,7 +1499,6 @@ Optional Features:
--disable-sdcpp Disables building sdcpp
--disable-sdcdb Disables building sdcdb
--disable-sdbinutils Disables configuring and building of sdbinutils
@@ -133,7 +133,7 @@ index 4c2226b..b8a9251 100755
--enable-doc Enables building the documentation
--enable-libgc Use the Bohem memory allocator. Lower runtime
footprint.
-@@ -1502,16 +1491,8 @@ Some influential environment variables:
+@@ -1538,16 +1527,8 @@ Some influential environment variables:
appended to datadir to define SDCC's include/lib directory
include_dir_suffix
appended to datadir to define SDCC's include directory
@@ -150,7 +150,7 @@ index 4c2226b..b8a9251 100755
docdir documentation installation directory
Use these variables to override the choices made by `configure' or to help
-@@ -7156,19 +7137,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -7421,19 +7402,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -170,7 +170,7 @@ index 4c2226b..b8a9251 100755
# lib_dir_suffix:
# *nix default: "sdcc/lib"
-@@ -7176,13 +7144,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -7441,13 +7409,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -184,9 +184,9 @@ index 4c2226b..b8a9251 100755
# docdir:
# *nix default: "${datadir}/sdcc/doc"
-@@ -7349,24 +7310,6 @@ cat >>confdefs.h <<_ACEOF
- #define INCLUDE_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_inc_dir_suffix}"
- _ACEOF
+@@ -7600,22 +7561,6 @@ esac
+
+ printf "%s\n" "#define INCLUDE_DIR_SUFFIX DIR_SEPARATOR_STRING \"${norm_inc_dir_suffix}\"" >>confdefs.h
-norm_non_free_inc_dir_suffix=${non_free_include_dir_suffix}
-case ":$norm_non_free_inc_dir_suffix:" in
@@ -202,16 +202,14 @@ index 4c2226b..b8a9251 100755
- *) norm_non_free_inc_dir_suffix=`echo "$norm_non_free_inc_dir_suffix" | sed 's,\(.\)[\\/][\\/]*,\1/,g'` ;;
-esac
-
--cat >>confdefs.h <<_ACEOF
--#define NON_FREE_INCLUDE_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_non_free_inc_dir_suffix}"
--_ACEOF
+-printf "%s\n" "#define NON_FREE_INCLUDE_DIR_SUFFIX DIR_SEPARATOR_STRING \"${norm_non_free_inc_dir_suffix}\"" >>confdefs.h
-
norm_lib_dir_suffix=${lib_dir_suffix}
case ":$norm_lib_dir_suffix:" in
-@@ -7386,24 +7329,6 @@ cat >>confdefs.h <<_ACEOF
- #define LIB_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_lib_dir_suffix}"
- _ACEOF
+@@ -7633,22 +7578,6 @@ esac
+
+ printf "%s\n" "#define LIB_DIR_SUFFIX DIR_SEPARATOR_STRING \"${norm_lib_dir_suffix}\"" >>confdefs.h
-norm_non_free_lib_dir_suffix=${non_free_lib_dir_suffix}
-case ":$norm_non_free_lib_dir_suffix:" in
@@ -227,19 +225,18 @@ index 4c2226b..b8a9251 100755
- *) norm_non_free_lib_dir_suffix=`echo "$norm_non_free_lib_dir_suffix" | sed 's,\(.\)[\\/][\\/]*,\1/,g'` ;;
-esac
-
--cat >>confdefs.h <<_ACEOF
--#define NON_FREE_LIB_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_non_free_lib_dir_suffix}"
--_ACEOF
+-printf "%s\n" "#define NON_FREE_LIB_DIR_SUFFIX DIR_SEPARATOR_STRING \"${norm_non_free_lib_dir_suffix}\"" >>confdefs.h
-
# relative paths
for _lcl_i in expanded_bindir:expanded_datadir:bin2data_dir; do
-@@ -8513,28 +8438,6 @@ _ACEOF
+@@ -8751,27 +8680,6 @@ printf "%s\n" "#define OPT_DISABLE_SDBINUTILS $OPT_DISABLE_SDBINUTILS" >>confdef
- # Check whether --enable-non-free was given.
--if test "${enable_non_free+set}" = set; then :
+-if test ${enable_non_free+y}
+-then :
- enableval=$enable_non_free;
-fi
-
@@ -253,17 +250,15 @@ index 4c2226b..b8a9251 100755
- fi
-
-
--cat >>confdefs.h <<_ACEOF
--#define OPT_DISABLE_NON_FREE $OPT_DISABLE_NON_FREE
--_ACEOF
+-printf "%s\n" "#define OPT_DISABLE_NON_FREE $OPT_DISABLE_NON_FREE" >>confdefs.h
-
-
-
-
# Check whether --enable-doc was given.
- if test "${enable_doc+set}" = set; then :
-@@ -8929,20 +8832,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
+ if test ${enable_doc+y}
+@@ -9199,20 +9107,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
test $OPT_DISABLE_DEVICE_LIB = 0 && subdirs="$subdirs device/lib/pic14"
@@ -283,8 +278,8 @@ index 4c2226b..b8a9251 100755
-
fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
-@@ -9019,15 +8914,9 @@ fi
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_SM83 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
+@@ -9289,15 +9189,9 @@ fi
test $OPT_DISABLE_DEVICE_LIB = 0 && ac_config_files="$ac_config_files device/lib/Makefile"
@@ -300,7 +295,7 @@ index 4c2226b..b8a9251 100755
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
-@@ -9768,7 +9657,6 @@ do
+@@ -10037,7 +9931,6 @@ do
"device/lib/pdk15-stack-auto/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/pdk15-stack-auto/Makefile" ;;
"sdas/aspdk16/Makefile") CONFIG_FILES="$CONFIG_FILES sdas/aspdk16/Makefile" ;;
"device/lib/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/Makefile" ;;
@@ -308,7 +303,7 @@ index 4c2226b..b8a9251 100755
"main.mk") CONFIG_FILES="$CONFIG_FILES main.mk:main_in.mk" ;;
"src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
"device/include/Makefile") CONFIG_FILES="$CONFIG_FILES device/include/Makefile" ;;
-@@ -9780,7 +9668,6 @@ do
+@@ -10049,7 +9942,6 @@ do
"support/regression/ports/host/spec.mk") CONFIG_FILES="$CONFIG_FILES support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"Makefile.common") CONFIG_FILES="$CONFIG_FILES Makefile.common:Makefile.common.in" ;;
@@ -316,7 +311,7 @@ index 4c2226b..b8a9251 100755
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac
-@@ -10589,54 +10476,6 @@ esac
+@@ -10856,54 +10748,6 @@ esac
incPath3=`echo "$incPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -371,7 +366,7 @@ index 4c2226b..b8a9251 100755
libPath1=`echo "/${prefix2data_dir}/${norm_lib_dir_suffix}" | sed 's,/\./,/,g'`
case ":$libPath1:" in
-@@ -10686,54 +10525,6 @@ esac
+@@ -10953,54 +10797,6 @@ esac
libPath3=`echo "$libPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -423,18 +418,18 @@ index 4c2226b..b8a9251 100755
-nonFreeLibPath3=`echo "$nonFreeLibPath3" | sed 's,\\\\\\\\,\\\\,g'`
-
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: result:
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result:
sdcc ${VERSION} is now configured for
-@@ -10772,7 +10563,6 @@ sdcc ${VERSION} is now configured for
- pdk15 ${enable_pdk15_port}
- pdk16 ${enable_pdk16_port}
+@@ -11041,7 +10837,6 @@ sdcc ${VERSION} is now configured for
+ mos6502 ${enable_mos6502_port}
+ mos65c02 ${enable_mos65c02_port}
- Disable non-free lib: ${OPT_DISABLE_NON_FREE}
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -10787,9 +10577,6 @@ sdcc ${VERSION} is now configured for
+@@ -11056,9 +10851,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -444,7 +439,7 @@ index 4c2226b..b8a9251 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -10801,15 +10588,9 @@ sdcc ${VERSION} is now configured for
+@@ -11070,15 +10862,9 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -458,17 +453,17 @@ index 4c2226b..b8a9251 100755
- path(argv[0])${nonFreeLibPath2}${dirch}<model>
- ${nonFreeLibPath3}${dirch}<model>
" >&5
- $as_echo "
+ printf "%s\n" "
sdcc ${VERSION} is now configured for
-@@ -10849,7 +10630,6 @@ sdcc ${VERSION} is now configured for
- pdk15 ${enable_pdk15_port}
- pdk16 ${enable_pdk16_port}
+@@ -11120,7 +10906,6 @@ sdcc ${VERSION} is now configured for
+ mos6502 ${enable_mos6502_port}
+ mos65c02 ${enable_mos65c02_port}
- Disable non-free lib: ${OPT_DISABLE_NON_FREE}
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -10864,9 +10644,6 @@ sdcc ${VERSION} is now configured for
+@@ -11135,9 +10920,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -478,7 +473,7 @@ index 4c2226b..b8a9251 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -10878,14 +10655,8 @@ sdcc ${VERSION} is now configured for
+@@ -11149,15 +10931,9 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -493,11 +488,12 @@ index 4c2226b..b8a9251 100755
- ${nonFreeLibPath3}${dirch}<model>
" >&6; }
# End of configure/configure.in
+
diff --git a/configure.ac b/configure.ac
-index 455fee1..48e0a20 100644
+index cc5309e..5eb4326 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -548,19 +548,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -562,19 +562,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -517,7 +513,7 @@ index 455fee1..48e0a20 100644
# lib_dir_suffix:
# *nix default: "sdcc/lib"
AC_ARG_VAR([lib_dir_suffix], [appended to datadir to define SDCC's library root directory])
-@@ -568,13 +555,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -582,13 +569,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -531,7 +527,7 @@ index 455fee1..48e0a20 100644
# docdir:
# *nix default: "${datadir}/sdcc/doc"
AC_ARG_VAR([docdir], [documentation installation directory])
-@@ -615,19 +595,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
+@@ -629,19 +609,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
adl_NORMALIZE_PATH([norm_inc_dir_suffix], [$sdccconf_h_dir_separator])
AC_DEFINE_UNQUOTED(INCLUDE_DIR_SUFFIX,
DIR_SEPARATOR_STRING "${norm_inc_dir_suffix}", [XXX])
@@ -551,7 +547,7 @@ index 455fee1..48e0a20 100644
# relative paths
adl_COMPUTE_RELATIVE_PATHS([expanded_bindir:expanded_datadir:bin2data_dir])
-@@ -803,7 +775,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
+@@ -819,7 +791,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
AC_DO_DISABLER(sdcpp, SDCPP, [Disables building sdcpp])
AC_DO_DISABLER(sdcdb, SDCDB, [Disables building sdcdb])
AC_DO_DISABLER(sdbinutils, SDBINUTILS, [Disables configuring and building of sdbinutils])
@@ -559,7 +555,7 @@ index 455fee1..48e0a20 100644
AC_DO_ENABLER(doc, DOC, [Enables building the documentation])
AC_CHECK_PROG([LYX], [lyx], [lyx], [:])
-@@ -874,16 +845,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
+@@ -897,16 +868,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
AC_CONFIG_FILES(src/pic14/Makefile)
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/lib/pic14)
fi
@@ -574,9 +570,9 @@ index 455fee1..48e0a20 100644
- test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/non-free/lib/pic16)
-fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_SM83 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
AC_CONFIG_FILES([src/z80/Makefile])
-@@ -947,7 +912,6 @@ fi
+@@ -970,7 +935,6 @@ fi
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_FILES([device/lib/Makefile])
@@ -584,7 +580,7 @@ index 455fee1..48e0a20 100644
AC_CONFIG_FILES([main.mk:main_in.mk
src/Makefile
-@@ -961,9 +925,6 @@ support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in
+@@ -984,9 +948,6 @@ support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in
Makefile
Makefile.common:Makefile.common.in
])
@@ -594,7 +590,7 @@ index 455fee1..48e0a20 100644
AC_OUTPUT
# I found no better place
-@@ -981,16 +942,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
+@@ -1004,16 +965,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
adl_NORMALIZE_PATH_MSG(/${prefix2data_dir}/${norm_inc_dir_suffix}, [incPath1], [$dirch])
adl_NORMALIZE_PATH_MSG(/${bin2data_dir}/${norm_inc_dir_suffix}, [incPath2], [$dirch])
adl_NORMALIZE_PATH_MSG(${expanded_datadir}/${norm_inc_dir_suffix}, [incPath3], [$dirch])
@@ -611,15 +607,15 @@ index 455fee1..48e0a20 100644
AC_MSG_RESULT([
sdcc ${VERSION} is now configured for
-@@ -1030,7 +985,6 @@ sdcc ${VERSION} is now configured for
- pdk15 ${enable_pdk15_port}
- pdk16 ${enable_pdk16_port}
+@@ -1055,7 +1010,6 @@ sdcc ${VERSION} is now configured for
+ mos6502 ${enable_mos6502_port}
+ mos65c02 ${enable_mos65c02_port}
- Disable non-free lib: ${OPT_DISABLE_NON_FREE}
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device l