[PATCH] Add font-google-roboto-mono

  • Open
  • quality assurance status badge
Details
3 participants
  • Denis 'GNUtoo' Carikli
  • Nicolas Goaziou
  • remimimimi
Owner
unassigned
Submitted by
remimimimi
Severity
normal

Debbugs page

remimimimi wrote 3 years ago
(address . guix-patches@gnu.org)
CAP+X-ca=SFUnTDuE+-3tMsJG9v+-Kny0kqvAJt+EME5Pkwuwig@mail.gmail.com

Attachment: file
From dcc51bcbb8d0e831603cf1416570f8b418795c67 Mon Sep 17 00:00:00 2001
From: remimimimimi <valent.xarin@gmail.com>
Date: Wed, 9 Mar 2022 23:38:58 +0300
Subject: [PATCH] gnu: Add font-google-roboto-mono

---
gnu/packages/fonts.scm | 40 +++++++++++++++++++++++++++++++++++++---
1 file changed, 37 insertions(+), 3 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index db19e6d156..1436c70c83 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -837,6 +837,40 @@ (define-public font-google-roboto
visual language \"Material Design\".")
(license license:asl2.0)))
+(define-public font-google-roboto-mono
+ (package
+ (name "font-google-roboto-mono")
+ (version "2.136")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/googlefonts/RobotoMono")
+ (commit "8f651634e746da6df6c2c0be73255721d24f2372")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00ddmr7yvb9isakfvgv6g74m80fmg81dmh1hrrdyswapaa7858a5"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/googlefonts/RobotoMono")
+ (synopsis "Monospaced Roboto font")
+ (description
+ "Roboto Mono is a monospaced addition to the Roboto type family.
+Like the other members of the Roboto family, the fonts are optimized for readability
+on screens across a wide variety of devices and reading environments. While the
+monospaced version is related to its variable width cousin, it doesn’t hesitate to
+change forms to better fit the constraints of a monospaced environment. For example,
+narrow glyphs like ‘I’, ‘l’ and ‘i’ have added serifs for more even texture while
+wider glyphs are adjusted for weight. Curved caps like ‘C’ and ‘O’ take on the
+straighter sides from Roboto Condensed. Special consideration is given to glyphs
+important for reading and writing software source code. Letters with similar shapes
+are easy to tell apart. Digit ‘1’, lowercase ‘l’ and capital ‘I’ are easily
+differentiated as are zero and the letter ‘O’. Punctuation important for code has
+also been considered. For example, the curly braces ‘{ }’ have exaggerated points
+to clearly differentiate them from parenthesis ‘( )’ and braces ‘[ ]’. Periods and
+commas are also exaggerated to identify them more quickly. The scale and weight of
+symbols commonly used as operators have also been optimized.")
+ (license license:asl2.0)))
+
(define-public font-borg-sans-mono
(package
(name "font-borg-sans-mono")
@@ -985,8 +1019,8 @@ (define-public font-adobe-source-code-pro
;; The upstream tag uses "/" between the roman and italic
;; versions, so substitute our "-" separator here.
#f "((R-ro)|(R-it))(-)" version
- 'pre 1 "/" 'post
- ))))
+ 'pre 1 "/" 'post))))
+
(file-name (git-file-name name version))
(sha256
(base32 "1lqchm8z0ah5y675ycmciqvr8y1v1gcj22ysfs443gm291vy0z4v"))))
@@ -1985,7 +2019,7 @@ (define-public font-dseg
#\.)))
(for-each (lambda (f) (install-file f truetype-dir))
(find-files "." "\\.ttf$"))
- #t)))))))
+ #t)))))))
(home-page "https://www.keshikan.net/fonts-e.html")
(synopsis "DSEG: 7-segment and 14-segment fonts")
(description

base-commit: 256703fa6cb0b27bd947315a206d42d500dc20c6
--
2.34.0
Denis 'GNUtoo' Carikli wrote 3 years ago
(address . 54323@debbugs.gnu.org)
20220311155757.424f9fc1@primarylaptop.localdomain
Hi,

Thanks for working on this patch.

Note that I'm not a Guix maintainer (I only managed to send some patches
and get them accepted), but I've seen several things to fix in this
patch and I've also some questions:
- You used 'license:asl2.0' as the license, while looking rapidly at
the source I didn't find any license. Do you know where the license
is stated in the font source code?
- If you really want to fix font-adobe-source-code-pro and font-dseg
code style, it should be done in one or two separate patches. Two
patches are probably easier for maintainers to review.
- I've also noticed that this patch lacks any commit message details.
Something like that should work:
gnu: Add font-google-roboto-mono
* gnu/packages/fonts.scm (font-google-roboto-mono): New variable.

Also there may or may not be additional issues as I've only looked at
it rapidly.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmIrY3YACgkQX138wUF3
4mMoPg/7BdMtJ6tNo8OMO8Cn2mILW1dpYnYx1IJ0dJ5/xIfl8fpO0Nk7S140Q6Uc
m0Nhf1btrQbz2iL7aP+yvJUSxmeMbd6vZ2Kuae+R6iaoVILh7Kd/ljNBPQF3C/S+
IRGaYjgnm4DMvdLw5IjcGYmePwNXeJD4xgPSdxrimUHuw6uFIP7CN7HG4cRbcaFI
GBzqDWJPwa2ByWsuxU2pGd4BTfHAKsrUMpXVgc5pNUT2KbD2wJhAKy5ruSNpo6au
//uFzhMCfubuf/uhntA1M4GU1FucQvO6ouCUyDquSnozNwFTEWFw5t+NkIHcmRsE
63uJrW/vfljIH3BdBCAxj/HhvEW4ojhhQDk9wjP+blCriObi5Mz15gLH4zW1DRFx
A2ny2Z0fQO43eTRPhCL6CKwABUR6lo+LewmiijPiplXdR5QTVGVChN2CRt25PRTc
ptzhWP06u3glG1zUCbo4ApdV+CJmmUlMUY+RgVY8GAaBAU0MfSNrNP8H1xZ2tPk8
tzs9KsVUfvyHmA6f3OwsfzIT2M6JvQvJ0e/bF1vcZoZ/HxurMMz8GRJlh5nlaLHB
0shVbDgzRa+E9gVSQcobdmkgc75QPxqTDpVctT1rZw11xHTafxsDwiZl3ivDQHlF
Z/sWZByHNChYKgQj1hwjNDSt7yb7s+E1zICO6v2BXbDUoxwgyS4=
=Vj99
-----END PGP SIGNATURE-----


remimimimi wrote 3 years ago
(address . 54323@debbugs.gnu.org)(address . GNUtoo@cyberdimension.org)
CAP+X-cb9xaLznHZKV0-y4Z+eiOq51yixZ5rqahFwGtjQh_5QOA@mail.gmail.com
Hello, sorry for the late response.

About the license, I saw it at
https://en.wikipedia.org/wiki/Robotothat license is Apache 2.0. I just
feel more confident about downloading these fonts from github than from
google fonts. Should I download from google fonts because repo has no
license?

I ran auto-format the file and didn't notice any changes, I'll remove it in
the next patch version with all your proposed fixes.
Attachment: file
Nicolas Goaziou wrote 4 days ago
(name . remimimimi)(address . valent.xarin@gmail.com)(address . 54323@debbugs.gnu.org)(address . GNUtoo@cyberdimension.org)
875xki6jgm.fsf@nicolasgoaziou.fr
Hello,

remimimimi <valent.xarin@gmail.com> writes:

Toggle quote (2 lines)
> Hello, sorry for the late response.

And sorry for my very late answer!

Toggle quote (7 lines)
> About the license, I saw it at
> https://fonts.google.com/specimen/Roboto#license and
> https://en.wikipedia.org/wiki/Roboto that license is Apache 2.0. I just
> feel more confident about downloading these fonts from github than from
> google fonts. Should I download from google fonts because repo has no
> license?

The repository https://github.com/googlefonts/RobotoMono now contains
a license (Apache 2.0, unsurprisingly).
Toggle quote (4 lines)
>
> I ran auto-format the file and didn't notice any changes, I'll remove it in
> the next patch version with all your proposed fixes.

The description should be much shorter, such as:

"Roboto Mono is a monospaced addition to the Roboto type family. Like
the other members of the Roboto family, the fonts are optimized for
readability on screens across a wide variety of devices and reading
environments."

I wonder about the version. How do you know it is 2.136? I don’t see any
reference to that number in the repository.

Also, the commit hash should be let bound around the package.

Regards,
--
Nicolas Goaziou
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54323@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54323
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help