[PATCH] added build input to rust-wayland-scanner@0.28

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Till Robin Zickel
Owner
unassigned
Submitted by
Till Robin Zickel
Severity
normal
T
T
Till Robin Zickel wrote on 8 Mar 2022 18:04
(address . guix-patches@gnu.org)
20220308170427.20754-1-trzickel@illegalaliensfrom.space
---
gnu/packages/crates-graphics.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index d1a9c4dd6d..1ec722d6d2 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2691,6 +2691,9 @@ (define-public rust-wayland-scanner-0.28
(sha256
(base32 "0g8ky63qk27in7zajycj3fyydsxlj19hanfcvr8d7z5kcxbvl43h"))))
(build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-xml-rs" ,rust-xml-rs-0.8))))
(inputs
(list rust-proc-macro2-1 rust-quote-1 rust-xml-rs-0.8))
(home-page "https://github.com/smithay/wayland-rs")
--
2.34.0
M
M
Maxime Devos wrote on 8 Mar 2022 18:30
2b2d552e4840507b4ca2e00f8881990c96893b21.camel@telenet.be
Till Robin Zickel schreef op di 08-03-2022 om 18:04 [+0100]:
Toggle quote (6 lines)
> +    (arguments
> +     `(#:cargo-inputs
> +       (("rust-xml-rs" ,rust-xml-rs-0.8))))
>      (inputs
>       (list rust-proc-macro2-1 rust-quote-1 rust-xml-rs-0.8))

It's already in 'inputs'. Why does it need to be added to #:cargo-
inputs as well?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYieSnBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7i95AQDzMBNzus/QC72E+J/C+P0YKnpw
R2ftfcbq8Dx2S4A91wEAyFvAYQTtD0BJoOsC5CkPyTPqYQFS94YeY3ruGRu8iQY=
=Z6J2
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54300@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54300
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch