[PATCH] samba: wrap scripts with GUIX_PYTHONPATH

  • Open
  • quality assurance status badge
Details
3 participants
  • fesoj000
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
fesoj000
Severity
normal
F
F
fesoj000 wrote on 5 Mar 2022 13:06
(address . guix-patches@gnu.org)
50be1b85-e682-d910-970c-14a08275278f@gmail.com
Tools like samba-tool depend on the python libraries installed by samba.

* gnu/packages/samba.scm: new buildstep
(samba)[wrap-scripts]: Add build step.
---
gnu/packages/samba.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..e7afe9330d 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -40,6 +40,7 @@ (define-module (gnu packages samba)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
@@ -231,12 +232,23 @@ (define-public samba
(add-before 'install 'disable-etc,var-samba-directories-setup
(lambda _
(substitute* "dynconfig/wscript"
- (("bld\\.INSTALL_DIR.*") "")))))
+ (("bld\\.INSTALL_DIR.*") ""))))
+ (add-after 'install 'wrap-scripts
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file)
+ (wrap-program (string-append out file)
+ `("GUIX_PYTHONPATH" = (,(getenv
"GUIX_PYTHONPATH")))))
+ '("/bin/samba-tool" "/sbin/samba_dnsupdate"
+ "/sbin/samba_downgrade_db"
"/sbin/samba-gpupdate"
+ "/sbin/samba_kcc" "/sbin/samba_spnupdate"
+ "/sbin/samba_upgradedns"))))))
;; FIXME: The test suite seemingly hangs after failing to
provision the
;; test environment.
#:tests? #f))
(inputs
(list acl
+ bash-minimal
cmocka
cups
gamin
--
2.34.0
M
M
Maxime Devos wrote on 5 Mar 2022 21:12
8515aeed4b6af1c2ec78247ea0fe7809d1a7fa21.camel@telenet.be
fesoj000 schreef op za 05-03-2022 om 13:06 [+0100]:
Toggle quote (4 lines)
> +                           (wrap-program (string-append out file)
> +                             `("GUIX_PYTHONPATH" = (,(getenv
> "GUIX_PYTHONPATH")))))

(getenv "...") includes too much, it also includes the python libraries
from native-inputs that are only required for tests. I recommend:

(string-join
(map (cut (@ (guix build python-build-system) site-packages)
(list (assoc-ref inputs "this-python-input")
(assoc-ref inputs "that-python-input")
[...])
outputs)
#\:)

(untested). Possibly there's a simpler way to do this ...

(Many packages simply do (getenv "GUIX_PYTHONPATH"), but that's a bug
in those packages, see e.g. https://issues.guix.gnu.org/25235.)

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYiPEGRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7oQkAP44CLA4B5puN1MB65JSiLEn/7Gw
83JeMviw/y2s6+iLMQEAg6dbmjdNXGPH0yfa90uvwVp07LoRMq1orXtzcBZzmgc=
=7R5Z
-----END PGP SIGNATURE-----


F
F
fesoj000 wrote on 8 Mar 2022 20:26
[PATCH] samba: wrap scripts with GUIX_PYTHONPATH
(address . 54266@debbugs.gnu.org)
f407fb7d-c411-7696-19a8-ae99eba69eab@gmail.com
Tools like samba-tool need the python libraries installed by samba and some of
sambas inputs.

* gnu/packages/samba.scm: new buildstep
(samba)[wrap-scripts]: Add build step.
---
gnu/packages/samba.scm | 46 ++++++++++++++++++++++++++++++++++--------
1 file changed, 38 insertions(+), 8 deletions(-)

Toggle diff (88 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..2bdf89163e 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -40,6 +40,7 @@ (define-module (gnu packages samba)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
@@ -193,10 +194,13 @@ (define-public samba
(base32 "0zyid2np45kl8hzp9fjqwvn5lxj766a4f0mya58vldqrhcrmw4b9"))))
(build-system gnu-build-system)
(arguments
- (list
- #:make-flags #~(list "TEST_OPTIONS=--quick") ;some tests are very long
- #:phases
- #~(modify-phases %standard-phases
+ `(#:make-flags '("TEST_OPTIONS=--quick") ;some tests are very long
+ #:imported-modules ((guix build python-build-system)
+ ,@%gnu-build-system-modules)
+ #:modules (((guix build python-build-system) #:select (python-version))
+ ,@%gnu-build-system-modules)
+ #:phases
+ (modify-phases %standard-phases
(add-before 'configure 'setup-docbook-stylesheets
(lambda* (#:key inputs #:allow-other-keys)
;; Append Samba's own DTDs to XML_CATALOG_FILES
@@ -212,12 +216,13 @@ (define-public samba
(string-append all " $XML_CATALOG_FILES")))))
(replace 'configure
;; Samba uses a custom configuration script that runs WAF.
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((libdir (string-append #$output "/lib")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (libdir (string-append out "/lib")))
(invoke "./configure"
"--enable-selftest"
"--enable-fhs"
- (string-append "--prefix=" #$output)
+ (string-append "--prefix=" out)
"--sysconfdir=/etc"
"--localstatedir=/var"
;; Install public and private libraries into
@@ -231,12 +236,37 @@ (define-public samba
(add-before 'install 'disable-etc,var-samba-directories-setup
(lambda _
(substitute* "dynconfig/wscript"
- (("bld\\.INSTALL_DIR.*") "")))))
+ (("bld\\.INSTALL_DIR.*") ""))))
+ (add-after 'install 'wrap-scripts
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (define (site-package-path python)
+ (string-append "/lib/python" (python-version python)
+ "/site-packages"))
+ (define (guix-pythonpath site-package-path)
+ (string-join
+ (append (map (lambda (input)
+ (string-append (assoc-ref inputs input)
+ site-package-path))
+ '("tdb" "ldb" "talloc"))
+ (list (string-append out site-package-path)))
+ ":"))
+ (for-each (lambda (file)
+ (wrap-program (string-append out file)
+ `("GUIX_PYTHONPATH" =
+ (,(guix-pythonpath
+ (site-package-path
+ (assoc-ref inputs "python")))))))
+ '("/bin/samba-tool" "/sbin/samba_dnsupdate"
+ "/sbin/samba_downgrade_db" "/sbin/samba-gpupdate"
+ "/sbin/samba_kcc" "/sbin/samba_spnupdate"
+ "/sbin/samba_upgradedns"))))))
;; FIXME: The test suite seemingly hangs after failing to provision the
;; test environment.
#:tests? #f))
(inputs
(list acl
+ bash-minimal
cmocka
cups
gamin
--
2.34.0
M
M
Maxime Devos wrote on 8 Mar 2022 21:39
f11cd5e1b755b976d05821328c09cf5ab9cd4b04.camel@telenet.be
fesoj000 schreef op di 08-03-2022 om 20:26 [+0100]:
Toggle quote (6 lines)
> -     (list
> -      #:make-flags #~(list "TEST_OPTIONS=--quick") ;some tests are very long
> -      #:phases
> -      #~(modify-phases %standard-phases
> +     `(#:make-flags '("TEST_OPTIONS=--quick") ;some tests are very long

What's the reason for turning things from G-exps into S-exps?
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYie+6RccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hIaAQD4UuIPnnfQJBp4ntkonaU9b8/1
lR2ndVkHm9bsTKCrCgEAx3gJOYUl7YrdMHLmEBgj1tHp3RYy7E5EsxoPXiuCZQw=
=sDJD
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 8 Mar 2022 21:44
6117b63516dfa5b4801ed876d33658412aedbfff.camel@telenet.be
fesoj000 schreef op di 08-03-2022 om 20:26 [+0100]:
Toggle quote (6 lines)
> +                            (wrap-program (string-append out file)
> +                              `("GUIX_PYTHONPATH" =
> +                                (,(guix-pythonpath
> +                                   (site-package-path
> +                                    (assoc-ref inputs "python")))))))

I would expect that python always puts its own site-packages in front
of the path, though I could be mistaken, so is this necessary?

Also, it looks like some of the python stuf uses 'ldb', so 'ldb' might
need to be included as well.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYifAPRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7iP2AQD7eXTr4dnAssa2B/FDc35XrNUH
bXnBLiNJT7WOsnJ9OgEA882VCZGEPk2pg9Puh9dmX0wAdeXVrD74RYDGW5JaZA8=
=WB2Q
-----END PGP SIGNATURE-----


F
F
fesoj000 wrote on 8 Mar 2022 23:01
7a858578-21af-828c-20ab-e0683a7b78c2@gmail.com
On 3/8/22 9:39 PM, Maxime Devos wrote:
Toggle quote (9 lines)
> fesoj000 schreef op di 08-03-2022 om 20:26 [+0100]:
>> -     (list
>> -      #:make-flags #~(list "TEST_OPTIONS=--quick") ;some tests are very long
>> -      #:phases
>> -      #~(modify-phases %standard-phases
>> +     `(#:make-flags '("TEST_OPTIONS=--quick") ;some tests are very long
>
> What's the reason for turning things from G-exps into S-exps?

Good question, here is the gexp version.

Toggle diff (63 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..c4457cc11e 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -40,6 +40,7 @@ (define-module (gnu packages samba)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
@@ -195,6 +196,10 @@ (define-public samba
(arguments
(list
#:make-flags #~(list "TEST_OPTIONS=--quick") ;some tests are very long
+ #:imported-modules `((guix build python-build-system)
+ ,@%gnu-build-system-modules)
+ #:modules `(((guix build python-build-system) #:select (python-version))
+ ,@%gnu-build-system-modules)
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'setup-docbook-stylesheets
@@ -231,12 +236,36 @@ (define-public samba
(add-before 'install 'disable-etc,var-samba-directories-setup
(lambda _
(substitute* "dynconfig/wscript"
- (("bld\\.INSTALL_DIR.*") "")))))
+ (("bld\\.INSTALL_DIR.*") ""))))
+ (add-after 'install 'wrap-scripts
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (site-package-path python)
+ (string-append "/lib/python" (python-version python)
+ "/site-packages"))
+ (define (guix-pythonpath site-package-path)
+ (string-join
+ (append (map (lambda (input)
+ (string-append (assoc-ref inputs input)
+ site-package-path))
+ '("tdb" "ldb" "talloc"))
+ (list (string-append #$output site-package-path)))
+ ":"))
+ (for-each (lambda (file)
+ (wrap-program (string-append #$output file)
+ `("GUIX_PYTHONPATH" =
+ (,(guix-pythonpath
+ (site-package-path
+ (assoc-ref inputs "python")))))))
+ '("/bin/samba-tool" "/sbin/samba_dnsupdate"
+ "/sbin/samba_downgrade_db" "/sbin/samba-gpupdate"
+ "/sbin/samba_kcc" "/sbin/samba_spnupdate"
+ "/sbin/samba_upgradedns")))))
;; FIXME: The test suite seemingly hangs after failing to provision the
;; test environment.
#:tests? #f))
(inputs
(list acl
+ bash-minimal
cmocka
cups
gamin
--
2.34.0
F
F
fesoj000 wrote on 8 Mar 2022 23:21
(address . 54266@debbugs.gnu.org)
42365ae6-a63a-5825-8a96-59a54b706b15@gmail.com
On 3/8/22 9:44 PM, Maxime Devos wrote:
Toggle quote (9 lines)
> fesoj000 schreef op di 08-03-2022 om 20:26 [+0100]:
>> +                            (wrap-program (string-append out file)
>> +                              `("GUIX_PYTHONPATH" =
>> +                                (,(guix-pythonpath
>> +                                   (site-package-path
>> +                                    (assoc-ref inputs "python")))))))
>
> I would expect that python always puts its own site-packages in front
> of the path, though I could be mistaken, so is this necessary?hm, "python3 -c 'import sys; print(sys.path)'" always includes its own site
packages. If you talk about the samba package output then we can do this like
the new diff below.

Toggle quote (2 lines)
> Also, it looks like some of the python stuf uses 'ldb', so 'ldb' might
> need to be included as well.
'ldb' is included, you can look at the guix-pythonpath function which builds
the pythonpath. In fact not only 'ldb' is need but further 'tdb' and 'talloc'.


Toggle diff (63 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..fa8ff5b6bb 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -40,6 +40,7 @@ (define-module (gnu packages samba)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
@@ -195,6 +196,10 @@ (define-public samba
(arguments
(list
#:make-flags #~(list "TEST_OPTIONS=--quick") ;some tests are very long
+ #:imported-modules `((guix build python-build-system)
+ ,@%gnu-build-system-modules)
+ #:modules `(((guix build python-build-system) #:select (python-version))
+ ,@%gnu-build-system-modules)
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'setup-docbook-stylesheets
@@ -231,12 +236,36 @@ (define-public samba
(add-before 'install 'disable-etc,var-samba-directories-setup
(lambda _
(substitute* "dynconfig/wscript"
- (("bld\\.INSTALL_DIR.*") "")))))
+ (("bld\\.INSTALL_DIR.*") ""))))
+ (add-after 'install 'wrap-scripts
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (site-package-path python)
+ (string-append "/lib/python" (python-version python)
+ "/site-packages"))
+ (define (guix-pythonpath site-package-path)
+ (string-join
+ (append (list (string-append #$output site-package-path))
+ (map (lambda (input)
+ (string-append (assoc-ref inputs input)
+ site-package-path))
+ '("tdb" "ldb" "talloc")))
+ ":"))
+ (for-each (lambda (file)
+ (wrap-program (string-append #$output file)
+ `("GUIX_PYTHONPATH" =
+ (,(guix-pythonpath
+ (site-package-path
+ (assoc-ref inputs "python")))))))
+ '("/bin/samba-tool" "/sbin/samba_dnsupdate"
+ "/sbin/samba_downgrade_db" "/sbin/samba-gpupdate"
+ "/sbin/samba_kcc" "/sbin/samba_spnupdate"
+ "/sbin/samba_upgradedns")))))
;; FIXME: The test suite seemingly hangs after failing to provision the
;; test environment.
#:tests? #f))
(inputs
(list acl
+ bash-minimal
cmocka
cups
gamin
--
2.34.0
M
M
Maxime Devos wrote on 8 Mar 2022 23:28
(name . fesoj000)(address . fesoj000@gmail.com)(address . 54266@debbugs.gnu.org)
627b297ab383846cd2572bc29337dc5a224f425a.camel@telenet.be
[Please keep 54266@debbugs.gnu.org in CC]

fesoj000 schreef op di 08-03-2022 om 23:14 [+0100]:
Toggle quote (3 lines)
> packages. If you talk about the samba package output then we can do this like
> the new diff below.

Looking at some of the python scripts, it seems that they
add samba's python libraries to the path by theirselves,
so I don't think this is necessary.

Toggle quote (5 lines)
> > Also, it looks like some of the python stuf uses 'ldb', so 'ldb' might
> > need to be included as well.
> 'ldb' is included, you can look at the guix-pythonpath function which builds
> the pythonpath. In fact not only 'ldb' is need but further 'tdb' and 'talloc'.

Looking a little closer, it indeed seems fine (untested)!

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYifYihccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7pyvAP0cONy768a67sQn1jycZxRQJUpe
6oJww7UrWE1l/GWxHQEAt8S5Fio1bJ9AWsMaTCgmcH4yWciOEwHzxWcC4Osd4gs=
=3FNc
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 8 Mar 2022 23:29
475e57fbd9aed4d022121c70d7bb3904c6cae82b.camel@telenet.be
Nevermind the comment about keeping debbugs in CC or To, seems like the
mail was received twice and one of them has 54266@debbugs.gnu.org
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYifY4BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7ggrAP0YjWIS6AmAX89E47wjCNA7wzkS
8RDQtJbgwUvDd+tkxgD/WXXPNp0ZtUlij2Q1fMN8TJbZJVJgEcnt4qFhJmIHqAw=
=Pisl
-----END PGP SIGNATURE-----


F
F
fesoj000 wrote on 9 Mar 2022 00:09
(address . 54266@debbugs.gnu.org)
507835fa-d569-8ee2-2df3-f45f1281d10e@gmail.com
On 3/8/22 11:28 PM, Maxime Devos wrote:
Toggle quote (9 lines)
> [Please keep 54266@debbugs.gnu.org in CC]
>
> fesoj000 schreef op di 08-03-2022 om 23:14 [+0100]:
>> packages. If you talk about the samba package output then we can do this like
>> the new diff below.
>
> Looking at some of the python scripts, it seems that they
> add samba's python libraries to the path by theirselves,
> so I don't think this is necessary.
I just tested it, without the samba site-packages path the scripts still seem
to work just fine.

Toggle quote (10 lines)
>>> Also, it looks like some of the python stuf uses 'ldb', so 'ldb' might
>>> need to be included as well.
>> 'ldb' is included, you can look at the guix-pythonpath function which builds
>> the pythonpath. In fact not only 'ldb' is need but further 'tdb' and 'talloc'.
>
> Looking a little closer, it indeed seems fine (untested)!
>
> Greetings,
> Maxime.

(I again made the mistake to not include debbugs ...)
F
F
fesoj000 wrote on 9 Mar 2022 00:10
[PATCH] samba: wrap scripts with GUIX_PYTHONPATH
(address . 54266@debbugs.gnu.org)
ded52caa-b6c4-cee2-0d33-43ec5e436630@gmail.com
Tools like samba-tool need the python libraries installed by samba and some of
sambas inputs.

* gnu/packages/samba.scm: new buildstep
(samba)[wrap-scripts]: Add build step.
---
gnu/packages/samba.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..cb34fd8c2c 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -40,6 +40,7 @@ (define-module (gnu packages samba)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
@@ -195,6 +196,10 @@ (define-public samba
(arguments
(list
#:make-flags #~(list "TEST_OPTIONS=--quick") ;some tests are very long
+ #:imported-modules `((guix build python-build-system)
+ ,@%gnu-build-system-modules)
+ #:modules `(((guix build python-build-system) #:select (python-version))
+ ,@%gnu-build-system-modules)
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'setup-docbook-stylesheets
@@ -231,12 +236,35 @@ (define-public samba
(add-before 'install 'disable-etc,var-samba-directories-setup
(lambda _
(substitute* "dynconfig/wscript"
- (("bld\\.INSTALL_DIR.*") "")))))
+ (("bld\\.INSTALL_DIR.*") ""))))
+ (add-after 'install 'wrap-scripts
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (site-package-path python)
+ (string-append "/lib/python" (python-version python)
+ "/site-packages"))
+ (define (guix-pythonpath site-package-path)
+ (string-join
+ (map (lambda (input)
+ (string-append (assoc-ref inputs input)
+ site-package-path))
+ '("tdb" "ldb" "talloc"))
+ ":"))
+ (for-each (lambda (file)
+ (wrap-program (string-append #$output file)
+ `("GUIX_PYTHONPATH" =
+ (,(guix-pythonpath
+ (site-package-path
+ (assoc-ref inputs "python")))))))
+ '("/bin/samba-tool" "/sbin/samba_dnsupdate"
+ "/sbin/samba_downgrade_db" "/sbin/samba-gpupdate"
+ "/sbin/samba_kcc" "/sbin/samba_spnupdate"
+ "/sbin/samba_upgradedns")))))
;; FIXME: The test suite seemingly hangs after failing to provision the
;; test environment.
#:tests? #f))
(inputs
(list acl
+ bash-minimal
cmocka
cups
gamin
--
2.34.0
F
F
fesoj000 wrote on 18 Mar 2022 22:58
[PATCH] gnu: samba: wrap scripts
(address . 54266@debbugs.gnu.org)
cf649ded-0e69-a3ee-a277-3cb9653c9fb8@gmail.com
Are there still open issues which are not addressed by the last patch?

BR
M
M
Maxim Cournoyer wrote on 16 Jan 2023 18:53
Re: bug#54266: [PATCH] samba: wrap scripts with GUIX_PYTHONPATH
(name . fesoj000)(address . fesoj000@gmail.com)(address . 54266@debbugs.gnu.org)
87edru5psi.fsf_-_@gmail.com
Hi,

fesoj000 <fesoj000@gmail.com> writes:

Toggle quote (17 lines)
> On 3/8/22 11:28 PM, Maxime Devos wrote:
>> [Please keep 54266@debbugs.gnu.org in CC]
>> fesoj000 schreef op di 08-03-2022 om 23:14 [+0100]:
>>> packages. If you talk about the samba package output then we can do this like
>>> the new diff below.
>> Looking at some of the python scripts, it seems that they
>> add samba's python libraries to the path by theirselves,
>> so I don't think this is necessary.
> I just tested it, without the samba site-packages path the scripts still seem
> to work just fine.
>
>>>> Also, it looks like some of the python stuf uses 'ldb', so 'ldb' might
>>>> need to be included as well.
>>> 'ldb' is included, you can look at the guix-pythonpath function which builds
>>> the pythonpath. In fact not only 'ldb' is need but further 'tdb' and 'talloc'.
>> Looking a little closer, it indeed seems fine (untested)!

I'm a bit lost, is there something left to do here? Else let's close it
(replying to 54266-done@debbugs.gnu.org).

--
Thanks,
Maxim
?