(address . bug-guix@gnu.org)
The only download for the kaleido package on Pypi is a binary. There is
no source code on Pypi. The importer recognizes this but then prints a
confusing backtrace when attempting to print a hint:
Toggle snippet (41 lines)
./pre-inst-env guix import pypi kaleido
guix import: error: no source release for pypi package kaleido 0.2.1.post1
hint: Backtrace:
In ice-9/boot-9.scm:
1752:10 18 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In unknown file:
17 (apply-smob/0 #<thunk 7f6fab4442e0>)
In ice-9/boot-9.scm:
724:2 16 (call-with-prompt _ _ #<procedure default-prompt-handler (k proc)>)
In ice-9/eval.scm:
619:8 15 (_ #(#(#<directory (guile-user) 7f6fab449c80>)))
In guix/ui.scm:
2229:7 14 (run-guix . _)
2192:10 13 (run-guix-command _ . _)
In guix/scripts/import.scm:
124:11 12 (guix-import . _)
In ice-9/boot-9.scm:
1752:10 11 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/scripts/import/pypi.scm:
99:28 10 (_)
In guix/memoization.scm:
98:0 9 (mproc "kaleido" #:version #f)
In unknown file:
8 (_ #<procedure 7f6fa9f85380 at guix/memoization.scm:179:32 ()> #<procedure list _> (this is nothing))
In ice-9/boot-9.scm:
1685:16 7 (raise-exception _ #:continuable? _)
In guix/ui.scm:
806:16 6 (_ _)
316:5 5 (display-hint _ _)
1434:24 4 (texi->plain-text _)
In texinfo.scm:
1132:22 3 (parse _)
980:31 2 (loop #<input: string 7f6fa7652620> (*fragment*) _ _ _)
1064:40 1 (_ _ _ (" " "source. To build it from source, refer to the upstream repository at" " " "package is available on PyPI, but o…" …) …)
92:2 0 (loop _ _ _ _)
texinfo.scm:92:2: In procedure loop:
Throw to key `parser-error' with args `(#f "@-command expected more arguments:" () (url #:opt title replacement) (url #:opt title replacement))'.
--
Ricardo