openvpn-shepherd-service is not writing log files

  • Open
  • quality assurance status badge
Details
One participant
  • Cameron Chaparro
Owner
unassigned
Submitted by
Cameron Chaparro
Severity
normal
C
C
Cameron Chaparro wrote on 24 Feb 2022 23:11
(address . bug-guix@gnu.org)
CAN85xJm0Fv4QOgkertiBu5ZEdoz=VAqBoLrCaGH9nKzQA8D6zw@mail.gmail.com
I noticed that the `openvpn-shepherd-service' is defining, but not
actually using, the log file when starting the client/server. I think
this patch should address that issue.

Cameron Chaparro
Attachment: file
From 372f3b8a2f2900bca5a55208a07940e6b70ddded Mon Sep 17 00:00:00 2001
Message-Id: <372f3b8a2f2900bca5a55208a07940e6b70ddded.1645740586.git.cameron@cameronchaparro.com>
From: Cameron Chaparro <cameron@cameronchaparro.com>
Date: Thu, 24 Feb 2022 15:49:15 -0600
Subject: [PATCH] gnu: Add #:log-file option when starting openvpn shepherd
services

---
gnu/services/vpn.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (26 lines)
diff --git a/gnu/services/vpn.scm b/gnu/services/vpn.scm
index 3e370ba4be..b24e9cffb3 100644
--- a/gnu/services/vpn.scm
+++ b/gnu/services/vpn.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Nathan Dehnel <ncdehnel@gmail.com>
+;;; Copyright © 2022 Cameron V Chaparro <cameron@cameronchaparro.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -494,7 +495,8 @@ (define (openvpn-shepherd-service role)
(list (string-append #$openvpn "/sbin/openvpn")
"--writepid" #$pid-file "--config" #$config-file
"--daemon")
- #:pid-file #$pid-file))
+ #:pid-file #$pid-file
+ #:log-file #$log-file))
(stop #~(make-kill-destructor)))))))
(define %openvpn-accounts

base-commit: 979b6a2c55fab729923d76ac9fee027d5d2d8f2b
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54150@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54150
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch