(name . Guix-patches)(address . guix-patches@gnu.org)
Imgui was being built without two of its files, removing table and widget support from the built library. This simple patch adds them back to the build phase.
Tested it builds and those features work in a package (mangohud) that uses them.
From 11c8aa71d3e226b469e4ed3c65fd85851eb63f76 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 23 Feb 2022 14:51:32 -0500
Subject: [PATCH] gnu: imgui: Add missing build files.
* gnu/packages/toolkits.scm (imgui)[phases]: Add imgui_tables.cpp and
imgui_widgets.cpp to the build phase.
---
gnu/packages/toolkits.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (23 lines)
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index ee0cffa2f9..ba860014a4 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +70,8 @@ (define-public imgui
"-o" "libimgui.so"
"imgui.cpp"
"imgui_draw.cpp"
+ "imgui_tables.cpp"
+ "imgui_widgets.cpp"
;; Include the supported backends.
"backends/imgui_impl_glfw.cpp"
"backends/imgui_impl_sdl.cpp"
--
2.34.0