[PATCH] gnu: imgui: Add missing build files.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Maxim Cournoyer
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 23 Feb 2022 20:55
(name . Guix-patches)(address . guix-patches@gnu.org)
pP6T2o9FJHYshP8_V83tR6Y_4yEfZgtnW5vlNcZ4Nwa7QC1FigKlK_-5nrjzCv-2AA4v3pppLOTEvWhG4OEPYCjprSaVj2P8cd4GMoFajNc=@protonmail.com
Imgui was being built without two of its files, removing table and widget support from the built library. This simple patch adds them back to the build phase.

Tested it builds and those features work in a package (mangohud) that uses them.
From 11c8aa71d3e226b469e4ed3c65fd85851eb63f76 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 23 Feb 2022 14:51:32 -0500
Subject: [PATCH] gnu: imgui: Add missing build files.

* gnu/packages/toolkits.scm (imgui)[phases]: Add imgui_tables.cpp and
imgui_widgets.cpp to the build phase.
---
gnu/packages/toolkits.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index ee0cffa2f9..ba860014a4 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +70,8 @@ (define-public imgui
"-o" "libimgui.so"
"imgui.cpp"
"imgui_draw.cpp"
+ "imgui_tables.cpp"
+ "imgui_widgets.cpp"
;; Include the supported backends.
"backends/imgui_impl_glfw.cpp"
"backends/imgui_impl_sdl.cpp"
--
2.34.0
M
M
Maxim Cournoyer wrote on 24 Feb 2022 04:09
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 54132-done@debbugs.gnu.org)
87y221klje.fsf@gmail.com
Hello!

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (30 lines)
> Imgui was being built without two of its files, removing table and
> widget support from the built library. This simple patch adds them
> back to the build phase.
>
> Tested it builds and those features work in a package (mangohud) that uses them.
>
> From 11c8aa71d3e226b469e4ed3c65fd85851eb63f76 Mon Sep 17 00:00:00 2001
> From: John Kehayias <john.kehayias@protonmail.com>
> Date: Wed, 23 Feb 2022 14:51:32 -0500
> Subject: [PATCH] gnu: imgui: Add missing build files.
>
> * gnu/packages/toolkits.scm (imgui)[phases]: Add imgui_tables.cpp and
> imgui_widgets.cpp to the build phase.
> ---
> gnu/packages/toolkits.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
> index ee0cffa2f9..ba860014a4 100644
> --- a/gnu/packages/toolkits.scm
> +++ b/gnu/packages/toolkits.scm
> @@ -1,6 +1,7 @@
> ;;; GNU Guix --- Functional package management for GNU
> ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
> +;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;

I've heard for contributions of less than about 10 new lines, the
changes are not substantial enough to be protected by copyright.
Something to keep in mind for your future patches :-).

Toggle quote (10 lines)
> @@ -69,6 +70,8 @@ (define-public imgui
> "-o" "libimgui.so"
> "imgui.cpp"
> "imgui_draw.cpp"
> + "imgui_tables.cpp"
> + "imgui_widgets.cpp"
> ;; Include the supported backends.
> "backends/imgui_impl_glfw.cpp"
> "backends/imgui_impl_sdl.cpp"

Applied as 74f9c8e47f08826eff12b793e668d7e8c5898b0e.

Thanks for the investigation and fix!

Maxim
Closed
J
J
John Kehayias wrote on 24 Feb 2022 04:35
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(name . 54132@debbugs.gnu.org)(address . 54132@debbugs.gnu.org)
Nx71kWJX7viqi-RvS2M8VMAO8JTXdxDjSdh5ZZaseXgqr-5E5BVZ4PJCQOwBmwAUo33VbplMsH_BUkFgVjPWGJ2TeElUoQJGD3W1kyvCh4w=@protonmail.com
Hi Maxim!

------- Original Message -------

On Wednesday, February 23rd, 2022 at 10:09 PM, Maxim Cournoyer wrote:

Toggle quote (6 lines)
>
> I've heard for contributions of less than about 10 new lines, the
> changes are not substantial enough to be protected by copyright.
> Something to keep in mind for your future patches :-).
>

Ah, good to know! I was never sure about the short patches and sort of flip a coin sometimes. Feel free to remove the copyright line if needed. Or, you know, I'll just have to make sure to get some more code into toolkits.scm in the next 10 months :)

Thanks for the quick review and push!

John
M
M
Maxim Cournoyer wrote on 24 Feb 2022 15:13
(name . John Kehayias)(address . john.kehayias@protonmail.com)(name . 54132@debbugs.gnu.org)(address . 54132@debbugs.gnu.org)
87v8x4jqss.fsf@gmail.com
Hi John,

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (17 lines)
> Hi Maxim!
>
> ------- Original Message -------
>
> On Wednesday, February 23rd, 2022 at 10:09 PM, Maxim Cournoyer wrote:
>
>>
>> I've heard for contributions of less than about 10 new lines, the
>> changes are not substantial enough to be protected by copyright.
>> Something to keep in mind for your future patches :-).
>>
>
> Ah, good to know! I was never sure about the short patches and sort of
> flip a coin sometimes. Feel free to remove the copyright line if
> needed. Or, you know, I'll just have to make sure to get some more
> code into toolkits.scm in the next 10 months :)

Haha, sounds fair.

Toggle quote (2 lines)
> Thanks for the quick review and push!

No problem,

Have a good Thursday,

Maxim
?