[PATCH] gnu: python-importlib-metadata: Update to 4.11.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • kiasoc5
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
MwPdVVJ--3-2@tutanota.com
Tested update with the following command:

guix refresh -l python-importlib-metadata | tr ' ' '\n' | grep '@' | xargs ./pre-inst-env guix build --keep-going --check

Most dependents build fine, there are some more to be fixed.

```
guix build: error: build of `/gnu/store/23zz3gkbcp7rhngx5kqqkifgllnnn87d-orange-3.31.1.drv', `/gnu/store/8g57fz279rsfbp7ygyfdkkigxz6alsd9-python-dolfin-adjoint-2019.1.0.drv', `/gnu/store/hpp2hysd3rjwy9kzbfrip1mjsp7cw42x-jrnl-1.9.7.drv', `/gnu/store/im8523db69cn0zn8d6357fljvnj9h51v-python-pytest-virtualenv-1.7.0.drv', `/gnu/store/jb7dhh6qyl1ywfl560g2fdincqln0j0m-python-behave-web-api-1.0.6.drv', `/gnu/store/k0yar63qm2h4kv8qbl0dbp04c6lvm8kz-python-pysnptools-0.4.11.drv', `/gnu/store/nr9isakhk3bxkl6p5v65gvqahy4n5fmy-dosage-2.17.drv', `/gnu/store/pf79l2hn6brzwl0b1q0bynlh42501s3v-electrum-4.1.5.drv', `/gnu/store/pvnxfjfr9fg0ap8lwia60vs53rgdclrh-gr-satellites-4.2.0.drv', `/gnu/store/qg7mfxcn2ayyq4v4lc1bkxddayfj54bp-gnss-sdr-0.0.15.drv', `/gnu/store/qgc7prgchmwn9hyy36hsn12cyraixvcf-electron-cash-4.2.6.drv', `/gnu/store/sc72sngxh0fbklbn66hly6k6r7zy6fcl-gqrx-2.15.8.drv', `/gnu/store/ympmpv7ci9xav22jaisq9kwrp1qq8w00-onionshare-2.4.drv' failed
```
From 346546faf492951b2b1226615d5cdd738f8dab83 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Sun, 20 Feb 2022 15:56:18 -0500
Subject: [PATCH] gnu: python-importlib-metadata: Update to 4.11.1.

* gnu/packages/python-xyz.scm (python-importlib-metadata): Update to 4.11.1.
---
gnu/packages/python-xyz.scm | 47 +++++++++++++++++++++++++++----------
1 file changed, 35 insertions(+), 12 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 516fa4057f..f6bbbb408e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8212,19 +8212,42 @@ (define-public python2-importlib-resources-bootstrap
(define-public python-importlib-metadata
(package
(name "python-importlib-metadata")
- (version "1.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "importlib_metadata" version))
- (sha256
- (base32
- "00ikdj4gjhankdljnz7g5ggak4k9lql2926x0x117ir9j2lv7x86"))))
+ (version "4.11.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "importlib_metadata" version))
+ (sha256
+ (base32
+ "0b05r23934nj0yqd4nm6f1hk34wzhvagidw1imp7ycd083j4wpqp"))))
(build-system python-build-system)
- (propagated-inputs
- (list python-zipp))
- (native-inputs
- (list python-setuptools-scm python-pyfakefs python-packaging))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-source-file-times-to-1980 ; make unzip work
+ (lambda _
+ (setenv "SOURCE_DATE_EPOCH" "315532800")))
+ (add-before 'check 'fix-tests ; this file uses a python module no distro has packaged
+ (lambda _
+ (delete-file "exercises.py")))
+ (replace 'build
+ (lambda _
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip" "--no-cache-dir" "--no-input" "install" "--no-deps" "--prefix"
+ out whl))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
+ (propagated-inputs (list python-zipp))
+ (native-inputs (list python-setuptools-scm
+ python-pyfakefs
+ python-packaging
+ python-pytest
+ python-pypa-build))
(home-page "https://importlib-metadata.readthedocs.io/")
(synopsis "Read metadata from Python packages")
(description
--
2.35.1
Ludovic Courtès wrote 3 years ago
(address . kiasoc5@tutanota.com)(address . 54083@debbugs.gnu.org)
87tu9zwwh6.fsf@gnu.org
Hi,

kiasoc5@tutanota.com skribis:

Toggle quote (10 lines)
> Tested update with the following command:
>
> guix refresh -l python-importlib-metadata | tr ' ' '\n' | grep '@' | xargs ./pre-inst-env guix build --keep-going --check
>
> Most dependents build fine, there are some more to be fixed.
>
> ```
> guix build: error: build of `/gnu/store/23zz3gkbcp7rhngx5kqqkifgllnnn87d-orange-3.31.1.drv', `/gnu/store/8g57fz279rsfbp7ygyfdkkigxz6alsd9-python-dolfin-adjoint-2019.1.0.drv', `/gnu/store/hpp2hysd3rjwy9kzbfrip1mjsp7cw42x-jrnl-1.9.7.drv', `/gnu/store/im8523db69cn0zn8d6357fljvnj9h51v-python-pytest-virtualenv-1.7.0.drv', `/gnu/store/jb7dhh6qyl1ywfl560g2fdincqln0j0m-python-behave-web-api-1.0.6.drv', `/gnu/store/k0yar63qm2h4kv8qbl0dbp04c6lvm8kz-python-pysnptools-0.4.11.drv', `/gnu/store/nr9isakhk3bxkl6p5v65gvqahy4n5fmy-dosage-2.17.drv', `/gnu/store/pf79l2hn6brzwl0b1q0bynlh42501s3v-electrum-4.1.5.drv', `/gnu/store/pvnxfjfr9fg0ap8lwia60vs53rgdclrh-gr-satellites-4.2.0.drv', `/gnu/store/qg7mfxcn2ayyq4v4lc1bkxddayfj54bp-gnss-sdr-0.0.15.drv', `/gnu/store/qgc7prgchmwn9hyy36hsn12cyraixvcf-electron-cash-4.2.6.drv', `/gnu/store/sc72sngxh0fbklbn66hly6k6r7zy6fcl-gqrx-2.15.8.drv', `/gnu/store/ympmpv7ci9xav22jaisq9kwrp1qq8w00-onionshare-2.4.drv' failed
> ```

Apologies for the long delay.

Would you be willing to try and adjust some of the failing dependents?
Of those listed above, only 4 are currently broken:

Toggle snippet (33 lines)
$ guix weather orange python-dolfin-adjoint jrnl python-pytest-virtualenv python-behave-web-api python-pysnptools dosage electrum gr-satellites gnss-sdr electron-cash gqrx onionshare --substitute-urls=https://ci.guix.gnu.org --display-missing
computing 13 package derivations for x86_64-linux...
looking for 13 store items on https://ci.guix.gnu.org...
https://ci.guix.gnu.org
69.2% substitutes available (9 out of 13)
at least 51.0 MiB of nars (compressed)
65.1 MiB on disk (uncompressed)

0.0% (0 out of 4) of the missing items are queued
744 queued builds
aarch64-linux: 547 (73.5%)
powerpc64le-linux: 1 (.1%)
i686-linux: 6 (.8%)
x86_64-linux: 190 (25.5%)
build rate: 109.54 builds per hour
powerpc64le-linux: 0.22 builds per hour
i686-linux: 76.92 builds per hour
x86_64-linux: 28.69 builds per hour
aarch64-linux: 5.53 builds per hour

Substitutes are missing for the following items:
/gnu/store/3j20ssshr0zd8624jrbv7ymrhq7hm02b-orange-3.31.1 x86_64-linux
/gnu/store/zymd425djigr7k5653k6sqbgccz6j7cn-python-dolfin-adjoint-2019.1.0 x86_64-linux
/gnu/store/ggcnmsjmljr5fakf1pviyfa1w2nhw8c7-python-pytest-virtualenv-1.7.0 x86_64-linux
/gnu/store/6iwf2dgsaihcmd0z9m0fcfs21b7ksg4y-python-pysnptools-0.4.11 x86_64-linux
$ guix describe
Generation 214 May 02 2022 21:44:14 (current)
guix 6b588da
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 6b588da368c77cde82ea2f22ca315116228777ad

So it seems like there’s a serious regression here.

As a stopgap, we can start by keeping version 1.5.0 in addition to the
new version, and use 1.5.0 in dependents that really need it.

Thoughts?

TIA,
Ludo’.
kiasoc5 wrote 3 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 54083@debbugs.gnu.org)
N1a6W4t--B-2@tutanota.com
Hi Ludo,

May 8, 2022, 21:22 by ludo@gnu.org:

Toggle quote (2 lines)
> Would you be willing to try and adjust some of the failing dependents?
>
I am busy for a few weeks but I can take a look after.

Toggle quote (2 lines)
> Of those listed above, only 4 are currently broken:
>
That's great, less to fix.

Toggle quote (6 lines)
>
> As a stopgap, we can start by keeping version 1.5.0 in addition to the
> new version, and use 1.5.0 in dependents that really need it.
>
> Thoughts?
>
Either way is fine, though I would prefer we keep 1.5.0 for those dependents so it's less to rebuild later.

Thanks!
kiasoc5 wrote 3 years ago
Closing 54083
(address . 54083-done@debbugs.gnu.org)
a130734d9f1abe7a360ffec21ad7c13b4b589753@disroot.org
Maxim updated python-importlib-metadata with commit b25a2c7c4057106efd9c02807fa7b4cdf2c5a574, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54083@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54083
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help