[mumi] Preprocess search query from GraphQL before use

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Felix Lechner
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 16 Feb 2022 09:21
(name . Ricardo Wurmus)(address . rekado@elephly.net)
20220216082121.23755-1-arunisaac@systemreboot.net
Hi Ricardo,

It looks like there is a small bug in the GraphQL patches I sent
earlier. I had failed to preprocess the search query before use.

Regards,
Arun

Arun Isaac (1):
web: Preprocess search query from GraphQL before use.

mumi/web/graphql.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

--
2.34.0
A
A
Arun Isaac wrote on 16 Feb 2022 09:24
[PATCH] web: Preprocess search query from GraphQL before use.
(name . Ricardo Wurmus)(address . rekado@elephly.net)
20220216082446.24153-1-arunisaac@systemreboot.net
* mumi/web/graphql.scm (<query>): Preprocess search query using
process-query before passing on to search-bugs.
---
mumi/web/graphql.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/mumi/web/graphql.scm b/mumi/web/graphql.scm
index 662c5ba..56110a0 100644
--- a/mumi/web/graphql.scm
+++ b/mumi/web/graphql.scm
@@ -102,7 +102,8 @@
(bug-status number)))
(issues (non-nullable-type (list-type <issue>))
(lambda* (parent context info #:key search)
- (search-bugs search)))
+ (search-bugs (string-join
+ (process-query search)))))
(person (non-nullable-type <person>)
(lambda* (parent context info #:key email)
email)))
--
2.34.0
R
R
Ricardo Wurmus wrote on 17 Feb 2022 23:19
Re: [mumi] Preprocess search query from GraphQL before use
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 54024-done@debbugs.gnu.org)
87a6epgmn8.fsf@elephly.net
Hi Arun,

Toggle quote (3 lines)
> It looks like there is a small bug in the GraphQL patches I sent
> earlier. I had failed to preprocess the search query before use.

Applied, thanks!

(Reconfiguring issues.guix.gnu.org would take a little while longer as
we’re in the process of moving the root fs and /gnu/store to new disks.
Almost finished it today but ran into problems after rebooting.)

--
Ricardo
Closed
A
A
Arun Isaac wrote on 19 Feb 2022 07:31
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 54024-done@debbugs.gnu.org)
875ypbfju5.fsf@systemreboot.net
Thanks, Ricardo! I think this new patch still isn't up on
issues.guix.gnu.org, but that's ok. It's not very urgent.

Should we consider more automated ways to redeploy mumi on every commit?
Or maybe, we should run a separate development server just for
that. WDYT?
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmIQjtIbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuz1iQH/0cnNQFYz7Vjv/kO9rd8
CqLuMxPAWjlQRhp/KRCdaX8qmbHcc+2m1dAUIY9zz9K2/DzvQH+Wh/3DvfG/oifB
CFlgB/Duy1YJarSOAT6rzVGAySWUOrkpn468oD9yxo/Kb64XYATnCLd7Ts/xh/6B
RBPs4TQTFakTDBB+QwkBIyKROgi0qLezxYRR9okR050cN1sqI6DQuKvWjj639rrV
24mJRTkxBoDqTr1eRZthJYWC132aYII1vItAbxvveSCvADtT22LPUkRoVcm6TgVN
gFO+D2GzxuwZEvVmIXP7QJEYpNNqd6r0IParRvevcOuIQSwTO311A2BHwjjKWL6X
6i8=
=n9EO
-----END PGP SIGNATURE-----

Closed
R
R
Ricardo Wurmus wrote on 19 Feb 2022 12:07
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 54024-done@debbugs.gnu.org)
87czjjdsfu.fsf@elephly.net
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (3 lines)
> Thanks, Ricardo! I think this new patch still isn't up on
> issues.guix.gnu.org, but that's ok. It's not very urgent.

It’s not up because we’re still having problems with the migration.

Toggle quote (4 lines)
> Should we consider more automated ways to redeploy mumi on every commit?
> Or maybe, we should run a separate development server just for
> that. WDYT?

We could change maintenance.git to not use the default mumi package but
to build the latest mumi at all times. I won’t be able to do this,
though. Toddler has a high fever and I barely sleep these days.

--
Ricardo
Closed
A
A
Arun Isaac wrote on 19 Feb 2022 21:19
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 54024-done@debbugs.gnu.org)
87ee3y7gox.fsf@systemreboot.net
Hi Ricardo,

Toggle quote (2 lines)
> It’s not up because we’re still having problems with the migration.

No problem, this isn't too urgent.

Toggle quote (8 lines)
>> Should we consider more automated ways to redeploy mumi on every commit?
>> Or maybe, we should run a separate development server just for
>> that. WDYT?
>
> We could change maintenance.git to not use the default mumi package but
> to build the latest mumi at all times. I won’t be able to do this,
> though. Toddler has a high fever and I barely sleep these days.

I'll take a look at this. Maybe, I can give this a shot. This may be
similar to a Guix based continuous deployment system I just set up at
work.

You take care, and take care of the little one. Family comes before
Guix.

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmIRUL4bHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzjIkH/3ceCodxAuvubMfdahke
Z8QHeW4ojXgEhqCu3NtioLpQLISzJO94wpjuw6Sx2cn0Wzd6MI6bNE1d+T8PD48p
yjySFxeZVvTltbcwg0Gd+/JywDtTbx59hvsPky6WtU36tlcO0GsDrECGd0sBCwix
9nCTXTCKmlLiDNJTX/NPWNJ5cB5F8TPeWmAJ2MXxKWvU3zLDGc6OBmGB82yr6JQe
yOWhIBYXygdYNXqkd7/FQjQzHBQta0JDf4x4E0XMEGZ3Dia73DmwadBsjtRtEd0f
ANi0TfYrLx2JIFJ0iH0OQZ6ZbHFrfwb2FpW54ZDfXp8fO1zqdH6BrW6SgPQF5i5d
I8E=
=ZYID
-----END PGP SIGNATURE-----

Closed
F
F
Felix Lechner wrote on 23 Feb 14:23 +0100
(no subject)
(address . control@debbugs.gnu.org)
875xyf1fhb.fsf@lease-up.com
unarchive 68680
reassign 68680 mumi
archive 68680

unarchive 63802
reassign 63802 mumi
archive 63802

unarchive 63215
reassign 63215 mumi
archive 63215

unarchive 61645
reassign 61645 mumi
archive 61645

unarchive 60410
reassign 60410 mumi
archive 60410

unarchive 60292
reassign 60292 mumi
archive 60292

unarchive 60292
reassign 60292 mumi
archive 60292

unarchive 58573
reassign 58573 mumi
archive 58573

unarchive 54024
reassign 54024 mumi
archive 54024

unarchive 49115
reassign 49115 mumi
archive 49115

unarchive 48160
reassign 48160 mumi
archive 48160

unarchive 47739
reassign 47739 mumi
archive 47739

unarchive 47520
reassign 47520 mumi
archive 47520

unarchive 47121
reassign 47121 mumi
archive 47121

unarchive 45015
reassign 45015 mumi
archive 45015

unarchive 43661
reassign 43661 mumi
archive 43661

unarchiv 43166
reassign 43166 mumi
archive 43166

unarchive 41906
reassign 41906 mumi
archive 41906

unarchive 41098
reassign 41098 mumi
archive 41098

unarchive 39924
reassign 39924 mumi
archive 39924

unarchive 39924
reassign 39924 mumi
archive 39924

unarchive 39924
reassign 39924 mumi
archive 39924

thanks
?