[PATCH] gnu: Add node-isexe.

  • Open
  • quality assurance status badge
Details
One participant
  • Matthew James Kraai
Owner
unassigned
Submitted by
Matthew James Kraai
Severity
normal
M
M
Matthew James Kraai wrote on 16 Feb 2022 07:20
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20220216062026.14853-1-kraai@ftbfs.org
* gnu/packages/node-xyz.scm (node-isexe): New variable.
---
gnu/packages/node-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 87892410f9..1659d1e56b 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;; Copyright © 2021 Charles <charles.b.jackson@protonmail.com>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,6 +132,34 @@ (define-public node-far
codes.")
(license license:expat)))
+(define-public node-isexe
+ (package
+ (name "node-isexe")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isaacs/isexe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18rh937j0m0jkzdxfdvvjv6nsdbrdqipnq7nvv1ab7b7rjyw5id3"))))
+ (build-system node-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda args
+ (delete-dependencies `("mkdirp"
+ "rimraf"
+ "tap")))))
+ #:tests? #f))
+ (home-page "https://github.com/isaacs/isexe#readme")
+ (synopsis "Node.js package to check if a file is executable and a normal file")
+ (description "Check if a file is executable and a normal file.")
+ (license license:isc)))
+
(define-public node-long-stack-traces
(package
(name "node-long-stack-traces")
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54023@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54023
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch