[PATCH 0/2] Not showing upgraded/added packages in 'guix pull'

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 14 Feb 2022 17:38
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
20220214163838.1174-1-ludo@gnu.org
Hello!

As a followup to https://issues.guix.gnu.org/53909, these patches
remove the list of added/upgraded packages from the output of
‘guix pull’ (upon completion) and ‘guix pull --news’.

It’s not spring yet in this hemisphere, but it looks like a spring cleanup!

Ludo’.

Ludovic Courtès (2):
pull: '--news' no longer shows package lists.
pull: No longer print upgraded/added packages upon completion.

doc/guix.texi | 10 ++---
guix/scripts/pull.scm | 98 +++++++++++++++++++++++--------------------
2 files changed, 57 insertions(+), 51 deletions(-)


base-commit: 41000d16c5c1586482a76d856c3152a6b8fcce8a
--
2.34.0
L
L
Ludovic Courtès wrote on 14 Feb 2022 17:41
[PATCH 2/2] pull: No longer print upgraded/added packages upon completion.
(address . 54000@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
20220214164127.1248-2-ludo@gnu.org
* guix/scripts/pull.scm (build-and-install): Remove call to
'display-profile-news' and adjust accordingly.
---
guix/scripts/pull.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/guix/scripts/pull.scm b/guix/scripts/pull.scm
index af1b27d7dd..f557aaf79a 100644
--- a/guix/scripts/pull.scm
+++ b/guix/scripts/pull.scm
@@ -454,10 +454,9 @@ (define guix-command
#:hooks %channel-profile-hooks)
(return
- (let ((more? (list (display-profile-news profile #:concise? #t)
- (display-channel-news-headlines profile))))
+ (let ((more? (display-channel-news-headlines profile)))
(newline)
- (when (any ->bool more?)
+ (when more?
(display-hint
(G_ "Run @command{guix pull --news} to read all the news.")))))
(if guix-command
--
2.34.0
L
L
Ludovic Courtès wrote on 14 Feb 2022 17:41
[PATCH 1/2] pull: '--news' no longer shows package lists.
(address . 54000@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
20220214164127.1248-1-ludo@gnu.org
* guix/scripts/pull.scm (display-channel-news): Return #t when news were
displayed.
(display-news): Remove call to 'display-profile-news'. Print something
when there were no news.
(process-query): For 'display-news', call 'display-channel-news'
directly.
* doc/guix.texi (Invoking guix pull): Adjust accordingly.
---
doc/guix.texi | 10 ++---
guix/scripts/pull.scm | 93 ++++++++++++++++++++++++-------------------
2 files changed, 55 insertions(+), 48 deletions(-)

Toggle diff (138 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index a05f073c3d..534414ab8a 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -4486,13 +4486,11 @@ information.
@cindex channel news
@item --news
@itemx -N
-Display the list of packages added or upgraded since the previous
-generation, as well as, occasionally, news written by channel authors
-for their users (@pxref{Channels, Writing Channel News}).
+Display news written by channel authors for their users for changes made
+since the previous generation (@pxref{Channels, Writing Channel News}).
-The package information is the same as displayed upon @command{guix
-pull} completion, but without ellipses; it is also similar to the output
-of @command{guix pull -l} for the last generation (see below).
+You can view that information for previous generations with
+@command{guix pull -l}.
@item --list-generations[=@var{pattern}]
@itemx -l [@var{pattern}]
diff --git a/guix/scripts/pull.scm b/guix/scripts/pull.scm
index 205697b3bd..af1b27d7dd 100644
--- a/guix/scripts/pull.scm
+++ b/guix/scripts/pull.scm
@@ -352,45 +352,48 @@ (define* (display-channel-news profile
(previous
(and=> (relative-generation profile -1)
(cut generation-file-name profile <>))))
- "Display news about the channels of PROFILE compared to PREVIOUS."
- (when previous
- (let ((old-channels (profile-channels previous))
- (new-channels (profile-channels profile)))
- (and (pair? old-channels) (pair? new-channels)
- (begin
- (match (lset-difference channel=? new-channels old-channels)
- (()
- #t)
- (new
- (let ((count (length new)))
- (format (current-error-port)
- (N_ " ~a new channel:~%"
- " ~a new channels:~%" count)
- count)
- (for-each display-channel new))))
- (match (lset-difference channel=? old-channels new-channels)
- (()
- #t)
- (removed
- (let ((count (length removed)))
- (format (current-error-port)
- (N_ " ~a channel removed:~%"
- " ~a channels removed:~%" count)
- count)
- (for-each display-channel removed))))
+ "Display news about the channels of PROFILE compared to PREVIOUS. Return
+true if news were displayed, false otherwise."
+ (and previous
+ (let ((old-channels (profile-channels previous))
+ (new-channels (profile-channels profile)))
+ (and (pair? old-channels) (pair? new-channels)
+ (begin
+ (match (lset-difference channel=? new-channels old-channels)
+ (()
+ #t)
+ (new
+ (let ((count (length new)))
+ (format (current-error-port)
+ (N_ " ~a new channel:~%"
+ " ~a new channels:~%" count)
+ count)
+ (for-each display-channel new))))
+ (match (lset-difference channel=? old-channels new-channels)
+ (()
+ #t)
+ (removed
+ (let ((count (length removed)))
+ (format (current-error-port)
+ (N_ " ~a channel removed:~%"
+ " ~a channels removed:~%" count)
+ count)
+ (for-each display-channel removed))))
- ;; Display channel-specific news for those channels that were
- ;; here before and are still around afterwards.
- (for-each (match-lambda
- ((new old)
- (display-channel-specific-news new old)))
- (filter-map (lambda (new)
- (define old
- (find (cut channel=? new <>)
- old-channels))
+ ;; Display channel-specific news for those channels that were
+ ;; here before and are still around afterwards.
+ (fold (match-lambda*
+ (((new old) news?)
+ (or (display-channel-specific-news new old)
+ news?)))
+ #f
+ (filter-map (lambda (new)
+ (define old
+ (find (cut channel=? new <>)
+ old-channels))
- (and old (list new old)))
- new-channels)))))))
+ (and old (list new old)))
+ new-channels)))))))
(define* (display-channel-news-headlines profile)
"Display the titles of news about the channels of PROFILE compared to its
@@ -422,12 +425,18 @@ (define more?
(any ->bool more?))))))
(define (display-news profile)
- ;; Display profile news, with the understanding that this process represents
- ;; the newest generation.
- (display-profile-news profile
- #:current-is-newer? #t)
+ "Display channel news for PROFILE compared to its previous generation."
+ (define previous
+ (relative-generation profile -1))
- (display-channel-news profile))
+ (if previous
+ (unless (display-channel-news profile
+ (generation-file-name profile previous))
+ (info (G_ "no channel news since generation ~a~%") previous)
+ (display-hint (G_ "Run @command{guix pull -l} to view the
+news for earlier generations.")))
+ (leave (G_ "profile ~a does not have a previous generation~%")
+ profile)))
(define* (build-and-install instances profile)
"Build the tool from SOURCE, and install it in PROFILE. When DRY-RUN? is
--
2.34.0
L
L
Liliana Marie Prikler wrote on 15 Feb 2022 14:55
Re: [PATCH 0/2] Not showing upgraded/added packages in 'guix pull'
13cb5b9b650f86917e44db255f2ad92d679d3226.camel@ist.tugraz.at
Am Montag, dem 14.02.2022 um 17:38 +0100 schrieb Ludovic Courtès:
Toggle quote (14 lines)
> Hello!
>
> As a followup to <https://issues.guix.gnu.org/53909>, these patches
> remove the list of added/upgraded packages from the output of
> ‘guix pull’ (upon completion) and ‘guix pull --news’.
>
> It’s not spring yet in this hemisphere, but it looks like a spring
> cleanup!
>
> Ludo’.
>
> Ludovic Courtès (2):
>   pull: '--news' no longer shows package lists.
>   pull: No longer print upgraded/added packages upon completion.
What if I wanted that information however? Does `guix pull --news --
details` still give it to me? I don't really want to do `guix pull -l
1d --details` instead.

Cheers
L
L
Ludovic Courtès wrote on 17 Feb 2022 11:19
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)(address . 54000@debbugs.gnu.org)
87fsohpzhl.fsf@gnu.org
Hi,

Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> skribis:

Toggle quote (7 lines)
> Am Montag, dem 14.02.2022 um 17:38 +0100 schrieb Ludovic Courtès:
>> Hello!
>>
>> As a followup to <https://issues.guix.gnu.org/53909>, these patches
>> remove the list of added/upgraded packages from the output of
>> ‘guix pull’ (upon completion) and ‘guix pull --news’.

[...]

Toggle quote (4 lines)
>>   pull: '--news' no longer shows package lists.
>>   pull: No longer print upgraded/added packages upon completion.
> What if I wanted that information however?

Is it an actual use case or speculation?

Toggle quote (2 lines)
> Does `guix pull --news -- details` still give it to me?

Not with this patch, but we could do that *if* there’s a need.

Toggle quote (2 lines)
> I don't really want to do `guix pull -l 1d --details` instead.

OK. So far, my impression was that this information was hardly used at
all, which is why it seemed reasonable to keep it behind ‘--details
--list-generations’.

I’m open to supporting ‘--news --details’, but only if it corresponds to
a real use case.

Thanks,
Ludo’.
L
L
Liliana Marie Prikler wrote on 17 Feb 2022 11:30
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 54000@debbugs.gnu.org)
31aeb5561e8aad5b5d5b235ff326f145a84863e3.camel@ist.tugraz.at
Hi Ludo,

Am Donnerstag, dem 17.02.2022 um 11:19 +0100 schrieb Ludovic Courtès:
Toggle quote (19 lines)
> Hi,
>
> Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> skribis:
>
> > Am Montag, dem 14.02.2022 um 17:38 +0100 schrieb Ludovic Courtès:
> > > Hello!
> > >
> > > As a followup to <https://issues.guix.gnu.org/53909>, these
> > > patches
> > > remove the list of added/upgraded packages from the output of
> > > ‘guix pull’ (upon completion) and ‘guix pull --news’.
>
> [...]
>
> > >   pull: '--news' no longer shows package lists.
> > >   pull: No longer print upgraded/added packages upon completion.
> > What if I wanted that information however?
>
> Is it an actual use case or speculation?
That's a use case. While --dry-run exists, I don't really want it to
serve double duty here. If I previously guix pulled and only three new
packages were added, none of which I'm interested in, I would not have
to meaninglessly run further build commands like guix package or guix
system. Even if the list is potentially longer, I could visually grep
for a few packages I'm interested in and determine whether it'd make
sense to build now or wait for a little while as I'm processing other
things.

Toggle quote (12 lines)
> > Does `guix pull --news -- details` still give it to me?
>
> Not with this patch, but we could do that *if* there’s a need.
>
> > I don't really want to do `guix pull -l 1d --details` instead.
>
> OK.  So far, my impression was that this information was hardly used
> at all, which is why it seemed reasonable to keep it behind ‘--
> details --list-generations’.
>
> I’m open to supporting ‘--news --details’, but only if it corresponds
> to a real use case.
In general, it doesn't have to be named ‘--news --details’, but a means
of diffing two generations via the CLI -- in particular the current one
to the last -- would be very welcome, because then all information we
previously had would still be available quite easily, albeit no longer
printed by default.

Cheers
Z
Z
zimoun wrote on 17 Feb 2022 13:04
Re: [bug#54000] [PATCH 0/2] Not showing upgraded/added packages in 'guix pull'
(address . 54000@debbugs.gnu.org)
86ley94s3w.fsf@gmail.com
Hi Liliana,

On Thu, 17 Feb 2022 at 11:30, Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> wrote:

Toggle quote (11 lines)
>> Is it an actual use case or speculation?
>
> That's a use case. While --dry-run exists, I don't really want it to
> serve double duty here. If I previously guix pulled and only three new
> packages were added, none of which I'm interested in, I would not have
> to meaninglessly run further build commands like guix package or guix
> system. Even if the list is potentially longer, I could visually grep
> for a few packages I'm interested in and determine whether it'd make
> sense to build now or wait for a little while as I'm processing other
> things.

Stats, ~24 updates and ~13 additions per day on average (over the past
year). If you pull twice a day, then yes you can read this information.
But, I bet people pull once a week, at best, so it looks like more
“noise“ and I guess most people miss the news.

About grepping, it is not straightforward. For instance, I get this:

Toggle snippet (13 lines)
$ guix pull --news | grep python
openshadinglanguage, perl-date-range, pgcli, plfit, poweralertd, pproxy, python-aiosignal, python-android-backup,
python-asdf-astropy, python-astral, python-astropy-healpix, python-astroquery, python-canvasapi, python-cmarkgfm,
python-cucumber-tag-expressions, python-cython-next, python-doit, python-esprima, python-executing,
python-flask-assets, python-flit-core-bootstrap, python-frozenlist, python-fs, python-geojson, python-gwcs,
python-ipython-sql, python-markdownify, python-miio, python-pgspecial, python-photutils, python-phpserialize,
python-piexif, python-psycopg, python-psycopg-pool, python-pydbus, python-pyftpdlib, python-pylru, python-pyowm,
python-pypdf3, python-pyrss2gen, python-pyscss, python-pysendfile, python-pystitcher,
python-pytest-doctest-custom, python-pytest-metadata, python-pytest-pydocstyle, python-pyvo, python-reedsolo,
python-regions, python-retry, python-roundrobin, python-sarge, python-sentry-sdk, python-setuptools-rust,
python-sphinx-click, python-sphinxcontrib-apidoc, python-tomli-w, python-tweepy, python-typeguard,

So I do not think the current display is adequate for grepping.


Somehow, the feature you want should be separated. For instance,

guix pull --updated
guix pull --added
guix pull --new-versions


Toggle quote (6 lines)
> In general, it doesn't have to be named ‘--news --details’, but a means
> of diffing two generations via the CLI -- in particular the current one
> to the last -- would be very welcome, because then all information we
> previously had would still be available quite easily, albeit no longer
> printed by default.

That feature is interesting but it appears to me orthogonal with the
current proposal.


Cheers,
simon
L
L
Liliana Marie Prikler wrote on 17 Feb 2022 13:52
(address . 54000@debbugs.gnu.org)
041a39d537297f3d0b1e829dcde05c0939eb6ccb.camel@ist.tugraz.at
Hi zimoun,

Am Donnerstag, dem 17.02.2022 um 13:04 +0100 schrieb zimoun:
Toggle quote (7 lines)
> Hi Liliana,
>
> Stats, ~24 updates and ~13 additions per day on average (over the
> past year).  If you pull twice a day, then yes you can read this
> information.
> But, I bet people pull once a week, at best, so it looks like more
> “noise“ and I guess most people miss the news.
For the record, that's < 150 updates and < 100 additions per week. Of
course, these numbers tend to get higher as Guix grows, but for now I
personally find this both manageable and helpful. Which doesn't mean I
want it done by default, just that I want a way of doing it.

Furthermore, news are displayed at the bottom, so if you're not
interested in the noise, just don't scroll up :P
Granted, if you're piping the output to a pager, that doesn't help you.

Toggle quote (27 lines)
> About grepping, it is not straightforward.  For instance, I get this:
>
> --8<---------------cut here---------------start------------->8---
> $ guix pull --news | grep python
>     openshadinglanguage, perl-date-range, pgcli, plfit, poweralertd,
> pproxy, python-aiosignal, python-android-backup,
>     python-asdf-astropy, python-astral, python-astropy-healpix,
> python-astroquery, python-canvasapi, python-cmarkgfm,
>     python-cucumber-tag-expressions, python-cython-next, python-doit,
> python-esprima, python-executing,
>     python-flask-assets, python-flit-core-bootstrap, python-
> frozenlist, python-fs, python-geojson, python-gwcs,
>     python-ipython-sql, python-markdownify, python-miio, python-
> pgspecial, python-photutils, python-phpserialize,
>     python-piexif, python-psycopg, python-psycopg-pool, python-
> pydbus, python-pyftpdlib, python-pylru, python-pyowm,
>     python-pypdf3, python-pyrss2gen, python-pyscss, python-
> pysendfile, python-pystitcher,
>     python-pytest-doctest-custom, python-pytest-metadata, python-
> pytest-pydocstyle, python-pyvo, python-reedsolo,
>     python-regions, python-retry, python-roundrobin, python-sarge,
> python-sentry-sdk, python-setuptools-rust,
>     python-sphinx-click, python-sphinxcontrib-apidoc, python-tomli-w,
> python-tweepy, python-typeguard,
> --8<---------------cut here---------------end--------------->8---
>
> So I do not think the current display is adequate for grepping.
I agree that with certain packages that's a little harder to do than
with others, but particularly with python the way to resolve this would
be to grep for 'python@'

Toggle quote (5 lines)
> Somehow, the feature you want should be separated.  For instance,
>
>     guix pull --updated
>     guix pull --added
>     guix pull --new-versions
That would perhaps help if your aim is to optimize for computation
time, but I'd still prefer all changes. It also helps that we already
have that code, so we only have to tell people to e.g. use --changes
instead of --news if that is the thing they wanted.  
W.r.t. only listing some of the changes, one could later implement
options like --changes=added,removed,updated,rewritten,...


Toggle quote (8 lines)
> > In general, it doesn't have to be named ‘--news --details’, but a
> > means of diffing two generations via the CLI -- in particular the
> > current one to the last -- would be very welcome, because then all
> > information we previously had would still be available quite
> > easily, albeit no longer printed by default.
>
> That feature is interesting but it appears to me orthogonal with the
> current proposal.
Orthogonal in which way? In that we could implement such a feature
without changing the way `guix pull' normally works and vice versa?
Sure. In that we'd not be losing any information if we changed `guix
pull' without providing such an option? Eh...
Z
Z
zimoun wrote on 17 Feb 2022 15:41
(address . 54000@debbugs.gnu.org)
864k4x4ktu.fsf@gmail.com
Hi Liliana,

On Thu, 17 Feb 2022 at 13:52, Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> wrote:

Toggle quote (11 lines)
>> Stats, ~24 updates and ~13 additions per day on average (over the
>> past year).  If you pull twice a day, then yes you can read this
>> information.
>> But, I bet people pull once a week, at best, so it looks like more
>> “noise“ and I guess most people miss the news.
>
> For the record, that's < 150 updates and < 100 additions per week. Of
> course, these numbers tend to get higher as Guix grows, but for now I
> personally find this both manageable and helpful. Which doesn't mean I
> want it done by default, just that I want a way of doing it.

On my poor laptop, I barely pull. Last time, more than 2 weeks ago.

Toggle snippet (8 lines)
$ guix describe
Generation 76 Feb 04 2022 11:15:54 (current)
guix ff093f5
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: ff093f5739a61e77b296feccc48d260b9bb574c0

and a typical ‘guix pull --news’ looks like:

Toggle snippet (50 lines)
$ time guix pull --news
New in this revision:
416 new packages: alfis,

[...]

877 packages upgraded: amsynth@1.12.4,

[...]


News for channel 'guix'
New `--execute' option to `guix deploy'
commit 5c13484646069064c834bbd3cd02c3bc80d94cb6

The `guix deploy' command has a new `--execute' or
`-x' option, which allows you to execute a command on
all the machines that your configuration file
specifies, as in this example:
guix deploy deploy.scm -x -- herd restart guix-daemon
This is no substitute for full-featured tools such as
pdsh but it is a useful helper.
`guix style' can format package definitions
commit c4fe13c294cc1e31dd8a49ce3981f603fb169e0a

The recently-introduced `guix style' command can now
be used to automatically format package definitions
according to the Guix project's formatting guidelines.
If you contribute packages to Guix or to a third-party
channel, you may find it useful.
The new `--styling' option can currently be passed one
of the following "styling rules": `format', to format
package definitions, or `inputs', to remove labels
from package inputs. Omitting `--styling' is
equivalent to passing `--styling=format'; previously
it was equivalent to `--styling=inputs'.
Run `info "(guix) Invoking guix style"', for more
info.


real 0m7.796s
user 0m8.131s
sys 0m0.500s


Toggle quote (4 lines)
> Furthermore, news are displayed at the bottom, so if you're not
> interested in the noise, just don't scroll up :P
> Granted, if you're piping the output to a pager, that doesn't help you.

First, because it is too much information, I never do it.
Second, because it is really slow, I never do it.
Therefore, I never read the news.

Well, I read them from Git, browsing after fetching. :-) Not sure it is
adequate.

I barely upgrade my base system – I made it work once and just use it –
and instead I heavily rely on time-machine and shell.

I agree with your request and I understand the need. Even, I think
diffing generations can be useful. But we should keep the default as
simple and fast as possible.


Toggle quote (13 lines)
>> Somehow, the feature you want should be separated.  For instance,
>>
>>     guix pull --updated
>>     guix pull --added
>>     guix pull --new-versions
>
> That would perhaps help if your aim is to optimize for computation
> time, but I'd still prefer all changes. It also helps that we already
> have that code, so we only have to tell people to e.g. use --changes
> instead of --news if that is the thing they wanted.  
> W.r.t. only listing some of the changes, one could later implement
> options like --changes=added,removed,updated,rewritten,...

We agree.

My point was just to say that ‘--news --details’ is not the correct UI
for the feature you would like because, for instance, currently
’--details’ alone is equivalent to ’--details -l’. Therefore, what
happens if the user only provides ’--details’?

The option ’--changes=’ makes also sense and it is probably a good
direction; instead of ’--news --details’.

Well, my point is just to say that the feature you want should be
separated from ‘--news’. :-)


Toggle quote (8 lines)
>> That feature is interesting but it appears to me orthogonal with the
>> current proposal.
>
> Orthogonal in which way? In that we could implement such a feature
> without changing the way `guix pull' normally works and vice versa?
> Sure. In that we'd not be losing any information if we changed `guix
> pull' without providing such an option? Eh...

Well, from my point of view, ‘guix pull -l 1d --details’ fits the job
and I miss why it would be an issue; since such display would be barely
used.

To be precise, the option ’-l’ should accept ’last’. From my point of
view, it is better to have:

guix pull --news # just the last news
guix pull -l last --details

(better meaming encourage people to read news :-)


And we could also imagine some options as ’--details=added’. Note we
could also imagine to make ‘guix git log’ show some information. Lot of
imagination. ;-)

Cheers,
simon
L
L
Ludovic Courtès wrote on 18 Feb 2022 10:08
(name . zimoun)(address . zimon.toutoune@gmail.com)
87k0dslexx.fsf@gnu.org
Hey comrades, hold your horses! :-)

Since there’s a need for this, we can make ‘--details’ print package
lists when combined with ‘--news’; it doesn’t cost us anything, that’s
OK.

There may be a need for more general package version diffing and such
things, but we can address it separately.

Thanks,
Ludo’.
L
L
Liliana Marie Prikler wrote on 18 Feb 2022 10:20
(address . 54000@debbugs.gnu.org)
3456b0651ed89758801b8b68071859f0023b5638.camel@ist.tugraz.at
Am Freitag, dem 18.02.2022 um 10:08 +0100 schrieb Ludovic Courtès:
Toggle quote (5 lines)
> Hey comrades, hold your horses!  :-)
>
> Since there’s a need for this, we can make ‘--details’ print package
> lists when combined with ‘--news’; it doesn’t cost us anything,
> that’s OK.
Regarding the issue simon raised w.r.t. --details implying -l, I think
--details should only imply listing the latest generation if -l is not
specified. That way --news --details would (hopefully) work as I
intended, and specifying one without the other would only print that
part.

On a separate note, would/should guix describe be affected by this?
Its output appear currently the same as `guix pull -l
$CURRENT_GENERATION', but I haven't tested this on a generation
including news. My guess would be "no" as guix describe currently
doesn't accept --news.

Cheers
L
L
Ludovic Courtès wrote on 27 Feb 2022 23:15
Re: bug#54000: [PATCH 0/2] Not showing upgraded/added packages in 'guix pull'
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
87wnhgrm68.fsf_-_@gnu.org
Hi,

Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> skribis:

Toggle quote (12 lines)
> Am Freitag, dem 18.02.2022 um 10:08 +0100 schrieb Ludovic Courtès:
>> Hey comrades, hold your horses!  :-)
>>
>> Since there’s a need for this, we can make ‘--details’ print package
>> lists when combined with ‘--news’; it doesn’t cost us anything,
>> that’s OK.
> Regarding the issue simon raised w.r.t. --details implying -l, I think
> --details should only imply listing the latest generation if -l is not
> specified. That way --news --details would (hopefully) work as I
> intended, and specifying one without the other would only print that
> part.

Right, I went with something like you describe:

2ddfb7b99b pull: No longer print upgraded/added packages upon completion.
bc8bea1739 pull: '--news' no longer shows package lists.

That is, one can run ‘guix pull -N --details’ and get what you asked
for. Running ‘guix pull --details’ alone still implies ‘-l’.

Let me know if anything’s amiss.

Toggle quote (6 lines)
> On a separate note, would/should guix describe be affected by this?
> Its output appear currently the same as `guix pull -l
> $CURRENT_GENERATION', but I haven't tested this on a generation
> including news. My guess would be "no" as guix describe currently
> doesn't accept --news.

No, ‘guix describe’ doesn’t display news, profile changes, and all
that. It’s meant to just show the raw channel info.

Thanks to both of you for your feedback!

Ludo’.
Closed
?