(address . bug-guix@gnu.org)
Hello Guix hackers,
Running 'guix pull' on a fresh basic install of Guix System 1.3.0 for i686
gets stuck at around 80%.
I've tested this several times and it happens most of the time. In the
other rare few cases other errors showed up. Not a single 'pull' succeeded
either way.
I let the pull run for days sometimes but it never finishes.
I run Guix x86_64 on my other systems without issues in the same
environment.
I tested this on a Pentium 4 32bits laptop with 786MB RAM at first, and
then switched to a VM with 8 GBs RAM, 2+ cores, 60GBs SSD to avoid any
resources issues.
Terminal log of one of the runs and config.scm attached.
Let me know if there's anything I can help with.
Regards,
Ahmad
;; This is an operating system configuration generated
;; by the graphical installer.
(use-modules (gnu))
(use-service-modules desktop networking ssh xorg)
(operating-system
(locale "en_US.utf8")
(timezone "Africa/Freetown")
(keyboard-layout (keyboard-layout "us"))
(host-name "Guix8601")
(users (cons* (user-account
(name "user")
(comment "User")
(group "users")
(home-directory "/home/user")
(supplementary-groups
'("wheel" "netdev" "audio" "video")))
%base-user-accounts))
(packages
(append
(list (specification->package "nss-certs"))
%base-packages))
(services
(append
(list (service openssh-service-type)
(service dhcp-client-service-type))
%base-services))
(bootloader
(bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")
(keyboard-layout keyboard-layout)))
(swap-devices
(list (uuid "573b665f-259d-46fa-a26b-ca6c9b65865e")))
(file-systems
(cons* (file-system
(mount-point "/")
(device
(uuid "8eb36ef8-95d9-4dac-a82c-398995638ae6"
'ext4))
(type "ext4"))
%base-file-systems)))