Florian Pelz wrote 3 years ago
(address . guix-patches@gnu.org)
Connman's online check is unreliable for me.
* gnu/installer/connman.scm (connman-online?): Accept if
connman state is ready instead of online.
---
gnu/installer/connman.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/gnu/installer/connman.scm b/gnu/installer/connman.scm
index 2f33b58453..6095d99947 100644
--- a/gnu/installer/connman.scm
+++ b/gnu/installer/connman.scm
@@ -287,7 +287,7 @@ (define (connman-disconnect service)
(define (connman-online?)
(let ((state (connman-state)))
- (eq? state 'online)))
+ (member state '(ready online))))
(define (connman-connect-with-auth service password-proc)
"Connect to the given SERVICE with the password returned by calling
base-commit: 5996aab354831d942b10253bc70217a4f2e6a247
--
2.34.0