[PATCH] installer: Continue even if Connman cannot phone home.

  • Done
  • quality assurance status badge
Details
One participant
  • Florian Pelz
Owner
unassigned
Submitted by
Florian Pelz
Severity
normal

Debbugs page

Florian Pelz wrote 3 years ago
(address . guix-patches@gnu.org)
20220212143832.emgl7r3mdqfljgpe@pelzflorian.localdomain
Connman's online check is unreliable for me.

* gnu/installer/connman.scm (connman-online?): Accept if
connman state is ready instead of online.
---
gnu/installer/connman.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/installer/connman.scm b/gnu/installer/connman.scm
index 2f33b58453..6095d99947 100644
--- a/gnu/installer/connman.scm
+++ b/gnu/installer/connman.scm
@@ -287,7 +287,7 @@ (define (connman-disconnect service)
(define (connman-online?)
(let ((state (connman-state)))
- (eq? state 'online)))
+ (member state '(ready online))))
(define (connman-connect-with-auth service password-proc)
"Connect to the given SERVICE with the password returned by calling

base-commit: 5996aab354831d942b10253bc70217a4f2e6a247
--
2.34.0
pelzflorian (Florian Pelz) wrote 3 years ago
(address . 53959-done@debbugs.gnu.org)
20220226151319.6pnx2ouelahwmwqf@pelzflorian.localdomain
On Sat, Feb 12, 2022 at 03:38:32PM +0100, Florian Pelz wrote:
Toggle quote (6 lines)
> (define (connman-online?)
> (let ((state (connman-state)))
> - (eq? state 'online)))
> + (member state '(ready online))))


Pushed to master as cc11905568065409fe46487174e1cf404291bda1
using memq instead of member.

It will take effect once the guix package is updated.

Regards,
Florian
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53959@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53959
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help