[PATCH] gnu: Add onlykey-udev-rules

  • Open
  • quality assurance status badge
Details
One participant
  • P?ladhammika
Owner
unassigned
Submitted by
P?ladhammika
Severity
normal
P
P
P?ladhammika wrote on 10 Feb 2022 22:31
(name . Guix Patches)(address . guix-patches@gnu.org)
OVacxuM1B_oTe_3i4GH_njUf-TPC8ozYHciHGXQA73in9NIpma2Pvf7F46vvZU_OvW8vz7lOPhKMH2temp7w1k_u_RITMoDhPCzk7M-fy0g=@protonmail.com
All the best,
P?ladhammika
From 3533849ad5d3b1b4ae4c7cf3616b410bf2e6df84 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Thu, 10 Feb 2022 16:21:54 -0500
Subject: [PATCH] gnu: Add onlykey-udev-rules

---
gnu/packages/python-crypto.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e49ccdf1f2..654694b4dc 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1757,3 +1757,25 @@ (define-public python-sop
scaffolding for the command line, which should make it relatively easy to
supply a handful of python functions as methods to a class.")
(license license:expat))) ; MIT license
+
+(define-public onlykey-udev-rules
+ (package
+ (name "onlykey-udev-rules")
+ (version "20210501")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trustcrypto/OnlyKey-App")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18nvrqmlifh4m8nfs0d19sb9d1l3a95xc89qxqdr881jcxdsgflw"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("./resources/linux/49-onlykey.rules" "/etc/udev/rules.d/"))))
+ (home-page "https://onlykey.io/")
+ (synopsis "Onlykey UDEV rules")
+ (description "UDEV rule in order for non-root users to be able to communicate with USB devices")
+ (license license:fsf-free)))
--
2.34.0
?