[PATCH] gnu: Add python-onlykey-solo-python

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Pāladhammika
Owner
unassigned
Submitted by
Pāladhammika
Severity
normal

Debbugs page

Pāladhammika wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
VQmGX4F_4o0kD3dogfq7v8fF8sU0u-5hhHJCIFxRahzXXZv9Xx6V2jR9iGP0DAK13uf25ZuoEZVS15TseBMFmLiUynwckTFZWrPeqtiXr6I=@protonmail.com
All the best,
Pāladhammika
From 372deb2998cf3c67ae59e89c629f7f5ab92d7015 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Thu, 10 Feb 2022 16:23:55 -0500
Subject: [PATCH] gnu: Add python-onlykey-solo-python

---
gnu/packages/python-crypto.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e49ccdf1f2..23b52f1bce 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1757,3 +1757,29 @@ (define-public python-sop
scaffolding for the command line, which should make it relatively easy to
supply a handful of python functions as methods to a class.")
(license license:expat))) ; MIT license
+
+(define-public python-onlykey-solo-python
+ (package
+ (name "python-onlykey-solo-python")
+ (version "0.0.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "onlykey-solo-python" version))
+ (sha256
+ (base32 "1xj1rzz6pqdsy0p2cr1vas3nw0l0ysxq6ww1hgiyb0cfim5bkf1i"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;no tests
+ (propagated-inputs
+ (list python-click
+ python-cryptography
+ python-ecdsa
+ python-fido2
+ python-intelhex
+ python-pyserial
+ python-pyusb
+ python-requests))
+ (home-page "https://github.com/trustcrypto/onlykey-solo-python")
+ (synopsis "Python library for OnlyKey with Solo FIDO2")
+ (description "Python library for OnlyKey with Solo FIDO2")
+ (license license:asl2.0)))
--
2.34.0
Maxime Devos wrote 3 years ago
(name . Pāladhammika)(address . paladhammika@protonmail.com)(address . 53931@debbugs.gnu.org)
f27914c1e054c40fcb166f126c35e166103d9fa6.camel@telenet.be
Pāladhammika via Guix-patches via schreef op do 10-02-2022 om 21:31
[+0000]:
Toggle quote (2 lines)
Why not use the upstream https://github.com/solokeys/solo-python of
the fork? The latest commits are the same.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYgfVhhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7s/rAQDDlNpIy3emigV6WeoduO3SiDeB
65Y2CZqytwZ8RdlT1AD8D24+KNl9wSMx4oWVVdHZAbePeFWkwddM7vbAsdrsjAs=
=AIPg
-----END PGP SIGNATURE-----


Pāladhammika wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 53931@debbugs.gnu.org)
9ktA8eaiUNIC0uf3Cb3B4UXXGAX4BPNS34YXJbZ1_erhzyXmqYDico48XuuiBhbH01gT3XP5VXrsvkmL1kzXjb-vk2U0M8v7KKV5cRdOKlk=@protonmail.com
Are they? The trustcrypto fork claims to be 12 commits ahead. Even still it makes sense to use the fork that by trustcrypto since they also produce the onlykey package, no?

All the best,
Pāladhammika

------- Original Message -------

On Saturday, February 12th, 2022 at 3:43 PM, Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (13 lines)
> Pāladhammika via Guix-patches via schreef op do 10-02-2022 om 21:31
>
> [+0000]:
>
> > +   (home-page "https://github.com/trustcrypto/onlykey-solo-python")
>
> Why not use the upstream https://github.com/solokeys/solo-python of
>
> the fork? The latest commits are the same.
>
> Greetings,
>
> Maxime.
Maxime Devos wrote 3 years ago
(name . Pāladhammika)(address . paladhammika@protonmail.com)(address . 53931@debbugs.gnu.org)
d7e923ffc92902960e6ad110ee1238bf178960d5.camel@telenet.be
Pāladhammika schreef op za 12-02-2022 om 16:21 [+0000]:
Are they? The trustcrypto fork claims to be 12 commits ahead.
Toggle quote (3 lines)
> Even still it makes sense to use the fork that by trustcrypto
> since they also produce the onlykey package, no?

AFAICT the fork is exactly the same as upstream, except with a slightly
different name, without any text in the README and with some
docstrings, warnings and error messages tweaked.

The only non-tweak commit appears to be
which seems a tiny change that should have been discussed upstream
(maybe it's as simple as recognising both pairs of vendor_id/product_id).

Also, no development seems to happen in the fork, development happens
upstream. The fork does not appear to accept pull requests and there
is no option for submitting an issue, whereas upstream does, so it
seems that upstream has a much better community.

Considering all this, this does not appear to be a fork
in the sense that, say, XEmacs is a fork of Emacs. Instead, it appears
to be pure branding -- and branding that will cause collisions in the profile
at that if both upstream and the trustcrypto-branded variant are installed
in the same profile, since the variant didn't change module names.

As such, I do not see a reason to prefer the branded variant over upstream,
and I would recommend not to, to prevent future problems (see profile
collisions), to reduce the number of packages that need to be updated
and to not cater to marketing.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYgfyVBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7nbYAP9tQazTccDVNXj3QEUDve/zLdcy
smO/rAwscvsS5tmiCAD/QZcPsDMOzT0qQyfRpcuCdBddNfFqCvnuqG4CSTGgcwc=
=hUBR
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 53931@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53931
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help