Pāladhammika wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
All the best,
Pāladhammika
From 372deb2998cf3c67ae59e89c629f7f5ab92d7015 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Thu, 10 Feb 2022 16:23:55 -0500
Subject: [PATCH] gnu: Add python-onlykey-solo-python
---
gnu/packages/python-crypto.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e49ccdf1f2..23b52f1bce 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1757,3 +1757,29 @@ (define-public python-sop
scaffolding for the command line, which should make it relatively easy to
supply a handful of python functions as methods to a class.")
(license license:expat))) ; MIT license
+
+(define-public python-onlykey-solo-python
+ (package
+ (name "python-onlykey-solo-python")
+ (version "0.0.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "onlykey-solo-python" version))
+ (sha256
+ (base32 "1xj1rzz6pqdsy0p2cr1vas3nw0l0ysxq6ww1hgiyb0cfim5bkf1i"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;no tests
+ (propagated-inputs
+ (list python-click
+ python-cryptography
+ python-ecdsa
+ python-fido2
+ python-intelhex
+ python-pyserial
+ python-pyusb
+ python-requests))
+ (home-page "https://github.com/trustcrypto/onlykey-solo-python")
+ (synopsis "Python library for OnlyKey with Solo FIDO2")
+ (description "Python library for OnlyKey with Solo FIDO2")
+ (license license:asl2.0)))
--
2.34.0