No way of replacing an input in modify-input syntax structure but keep all the outputs

  • Done
  • quality assurance status badge
Details
3 participants
  • Gordon Quad
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gordon Quad
Severity
important
G
G
Gordon Quad wrote on 10 Feb 2022 11:09
(address . bug-guix@gnu.org)
20220210100941.nwmrbgm7qt34dv3v@citadel.info
poppler package include glib as a native-input with "bin" output.

If I am doing the following:

(package/inherit poppler
(native-inputs
(modify-inputs (package-native-inputs poppler)
(replace "glib" my-glib))))

poppler's build will fail becuase replace syntax will replace "glib"
package erasing its outputs. I can specify output explicitly by doing
(replace "glib" (my-glib "bin")) in this case, but that makes mass input
modification difficult (e.g. if i want to replace all instances of glib
to my-glib).

That said there is a value in having such behaviour for replace syntax
in case for example if I replace package with my own version that has no
extra outputs, so it would be nice to have both options available.
L
L
Liliana Marie Prikler wrote on 10 Feb 2022 21:03
(address . ludo@gnu.org)
0dac06dbcb20fa32baf87df3460ebc102652f31e.camel@gmail.com
Am Donnerstag, dem 10.02.2022 um 10:09 +0000 schrieb Gordon Quad:
Toggle quote (14 lines)
> poppler package include glib as a native-input with "bin" output.
>
> If I am doing the following:
>
> (package/inherit poppler
>     (native-inputs
>         (modify-inputs (package-native-inputs poppler)
>             (replace "glib" my-glib))))
>
> poppler's build will fail becuase replace syntax will replace "glib"
> package erasing its outputs. I can specify output explicitly by doing
> (replace "glib" (my-glib "bin")) in this case, but that makes mass
> input modification difficult (e.g. if i want to replace all instances
> of glib to my-glib).
I think the problem here is that "glib" serves double duty as both
"glib:out" and "glib:bin". IMHO we should probably add the output
argument to the label (with a colon separator, of course) if one is
given.

I'm CC'ing Ludo because he implemented the feature and might know more
than me regarding its design.

Cheers
G
G
Gordon Quad wrote on 11 Feb 2022 11:26
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
20220211102614.rxbfjemppztfhlb2@citadel.info
On Thu, Feb 10, 2022 at 09:03:56PM +0100, Liliana Marie Prikler wrote:
Toggle quote (22 lines)
> Am Donnerstag, dem 10.02.2022 um 10:09 +0000 schrieb Gordon Quad:
> > poppler package include glib as a native-input with "bin" output.
> >
> > If I am doing the following:
> >
> > (package/inherit poppler
> > ��� (native-inputs
> > ������� (modify-inputs (package-native-inputs poppler)
> > ����������� (replace "glib" my-glib))))
> >
> > poppler's build will fail becuase replace syntax will replace "glib"
> > package erasing its outputs. I can specify output explicitly by doing
> > (replace "glib" (my-glib "bin")) in this case, but that makes mass
> > input modification difficult (e.g. if i want to replace all instances
> > of glib to my-glib).
> I think the problem here is that "glib" serves double duty as both
> "glib:out" and "glib:bin". IMHO we should probably add the output
> argument to the label (with a colon separator, of course) if one is
> given.
>
> I'm CC'ing Ludo because he implemented the feature and might know more
> than me regarding its design.
Well, just grepping the code for glib I found plenty of places where it
is specified as ("glib" ,glib "bin"), and glib is the only package that
I checked so far. So what you telling me that official policy is to use
labeling convesion as "package:output" but not all the old code converted
to that yet?
L
L
Ludovic Courtès wrote on 8 Mar 2022 17:01
control message for bug #53915
(address . control@debbugs.gnu.org)
87a6e05t7o.fsf@gnu.org
severity 53915 important
quit
L
L
Ludovic Courtès wrote on 8 Mar 2022 17:11
Re: bug#53915: No way of replacing an input in modify-input syntax structure but keep all the outputs
(name . Gordon Quad)(address . gordon@niflheim.info)
87zgm04e6f.fsf@gnu.org
Hi,

Gordon Quad <gordon@niflheim.info> skribis:

Toggle quote (12 lines)
> poppler package include glib as a native-input with "bin" output.
>
> If I am doing the following:
>
> (package/inherit poppler
> (native-inputs
> (modify-inputs (package-native-inputs poppler)
> (replace "glib" my-glib))))
>
> poppler's build will fail becuase replace syntax will replace "glib"
> package erasing its outputs.

Indeed:

Toggle snippet (11 lines)
scheme@(guile-user)> ,use(gnu packages pdf)
scheme@(guile-user)> ,use(guix)
scheme@(guile-user)> (package-native-inputs poppler)
$4 = (("pkg-config" #<package pkg-config@0.29.2 gnu/packages/pkg-config.scm:36 7f9b13a30580>) ("glib" #<package glib@2.70.2 gnu/packages/glib.scm:180 7f9b12990000> "bin") ("gobject-introspection" #<package gobject-introspection@1.66.1 gnu/packages/glib.scm:428 7f9b12994e70>))
scheme@(guile-user)> (package-propagated-inputs poppler)
$5 = (("glib" #<package glib@2.70.2 gnu/packages/glib.scm:180 7f9b12990000>))
scheme@(guile-user)> (modify-inputs (append $5 $4)
(replace "glib" xpdf))
$6 = (("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395 7f9b1457c9a0>) ("pkg-config" #<package pkg-config@0.29.2 gnu/packages/pkg-config.scm:36 7f9b13a30580>) ("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395 7f9b1457c9a0>) ("gobject-introspection" #<package gobject-introspection@1.66.1 gnu/packages/glib.scm:428 7f9b12994e70>))

We see that both ‘glib’ packages have been replaced, but the “bin” part
has been removed from the second one.

With the patch below, we get more sensible behavior:

Toggle snippet (5 lines)
scheme@(guile-user)> (modify-inputs (append $5 $4)
(replace "glib" xpdf))
$8 = (("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395 7f9b1457c9a0>) ("pkg-config" #<package pkg-config@0.29.2 gnu/packages/pkg-config.scm:36 7f9b13a30580>) ("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395 7f9b1457c9a0> "bin") ("gobject-introspection" #<package gobject-introspection@1.66.1 gnu/packages/glib.scm:428 7f9b12994e70>))

If that makes sense to you, I’ll go ahead with this change and adjust
documentation accordingly.

Thanks for bringing it up!

Ludo’.
Toggle diff (17 lines)
diff --git a/guix/packages.scm b/guix/packages.scm
index 3f0262602d..288ae37523 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -1091,11 +1091,11 @@ (define (replace-input name replacement inputs)
"Replace input NAME by REPLACEMENT within INPUTS."
(map (lambda (input)
(match input
- (((? string? label) . _)
+ (((? string? label) _ . outputs)
(if (string=? label name)
(match replacement ;does REPLACEMENT specify an output?
((_ _) (cons label replacement))
- (_ (list label replacement)))
+ (_ (cons* label replacement outputs)))
input))))
inputs))
L
L
Liliana Marie Prikler wrote on 8 Mar 2022 21:28
(address . 53915@debbugs.gnu.org)
33debb0b55b52a09d268c07ec8f2355f928de62a.camel@gmail.com
Am Dienstag, dem 08.03.2022 um 17:11 +0100 schrieb Ludovic Courtès:
Toggle quote (17 lines)
> [...]
> With the patch below, we get more sensible behavior:
>
> --8<---------------cut here---------------start------------->8---
> scheme@(guile-user)> (modify-inputs (append $5 $4)
>                        (replace "glib" xpdf))
> $8 = (("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395
> 7f9b1457c9a0>) ("pkg-config" #<package
> pkg-config@0.29.2 gnu/packages/pkg-config.scm:36 7f9b13a30580>)
> ("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395 7f9b1457c9a0>
> "bin") ("gobject-introspection" #<package
> gobject-introspection@1.66.1 gnu/packages/glib.scm:428
> 7f9b12994e70>))
> --8<---------------cut here---------------end--------------->8---
>
> If that makes sense to you, I’ll go ahead with this change and adjust
> documentation accordingly.
Sounds better than my own suggestion, since it'll keep working the way
it did even when labels are eventually dropped. If more control is
needed, we can always later extend it to support (replace ("label"
"output") (package output)). WDYT?

Cheers
L
L
Ludovic Courtès wrote on 16 Mar 2022 15:53
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87k0cuc5j6.fsf@gnu.org
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

Toggle quote (21 lines)
> Am Dienstag, dem 08.03.2022 um 17:11 +0100 schrieb Ludovic Courtès:
>> [...]
>> With the patch below, we get more sensible behavior:
>>
>> --8<---------------cut here---------------start------------->8---
>> scheme@(guile-user)> (modify-inputs (append $5 $4)
>>                        (replace "glib" xpdf))
>> $8 = (("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395
>> 7f9b1457c9a0>) ("pkg-config" #<package
>> pkg-config@0.29.2 gnu/packages/pkg-config.scm:36 7f9b13a30580>)
>> ("glib" #<package xpdf@4.03 gnu/packages/pdf.scm:395 7f9b1457c9a0>
>> "bin") ("gobject-introspection" #<package
>> gobject-introspection@1.66.1 gnu/packages/glib.scm:428
>> 7f9b12994e70>))
>> --8<---------------cut here---------------end--------------->8---
>>
>> If that makes sense to you, I’ll go ahead with this change and adjust
>> documentation accordingly.
> Sounds better than my own suggestion, since it'll keep working the way
> it did even when labels are eventually dropped.

Pushed with tests in 00dfff84c66c5c6aa4853684419a92befe55d4b4.

Toggle quote (3 lines)
> If more control is needed, we can always later extend it to support
> (replace ("label" "output") (package output)). WDYT?

I’d rather not: the goal of ‘modify-inputs’ is to provide an interface
that works as if input labels didn’t exist, with an eye on removing them
entirely in the future:


Regardless, we’ll have to keep an eye on all these corner cases and to
adjust the plan accordingly.

Thanks!

Ludo’.
Closed
?