[PATCH] gnu: clojure-data-xml: Fix test suite

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • Ryan Sundberg
Owner
unassigned
Submitted by
Ryan Sundberg
Severity
normal

Debbugs page

Ryan Sundberg wrote 3 years ago
(address . guix-patches@gnu.org)(name . Ryan Sundberg)(address . ryan@arctype.co)
20220208052813.19484-1-ryan@arctype.co
Removes clojurescript related tests that interfere with the JDK clojure
test suite, causing it to fail.

* gnu/packages/clojure.scm (clojure-data-xml)[arguments]: Add
'delete-cljs-tests phase
---
gnu/packages/clojure.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 2a9ad90740..3ee4941ddb 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -441,8 +441,14 @@ (define-public clojure-data-xml
(build-system clojure-build-system)
(arguments
'(#:source-dirs '("src/main/clojure")
- #:test-dirs '("src/test/clojure")
- #:doc-dirs '()))
+ #:test-dirs '("src/test/clojure" "src/test/resources")
+ #:doc-dirs '()
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'delete-cljs-tests
+ (lambda _
+ (delete-file "src/test/resources/clojure/data/xml/cljs_testsuite.clj")
+ (delete-file "src/test/clojure/clojure/data/xml/test_cljs.clj"))))))
(propagated-inputs (list clojure-data-codec))
(synopsis "Clojure library for reading and writing XML data")
(description "@code{data.xml} is a Clojure library for reading and writing
--
2.34.0
Julien Lepiller wrote 3 years ago
Re: [bug#53868] [PATCH] gnu: clojure-data-xml: Fix test suite
20220208115319.16d6fbdc@tachikoma.lepiller.eu
Le Mon, 7 Feb 2022 21:28:13 -0800,
Ryan Sundberg via Guix-patches via <guix-patches@gnu.org> a écrit :

Toggle quote (33 lines)
> Removes clojurescript related tests that interfere with the JDK
> clojure test suite, causing it to fail.
>
> * gnu/packages/clojure.scm (clojure-data-xml)[arguments]: Add
> 'delete-cljs-tests phase
> ---
> gnu/packages/clojure.scm | 10 ++++++++--
> 1 file changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
> index 2a9ad90740..3ee4941ddb 100644
> --- a/gnu/packages/clojure.scm
> +++ b/gnu/packages/clojure.scm
> @@ -441,8 +441,14 @@ (define-public clojure-data-xml
> (build-system clojure-build-system)
> (arguments
> '(#:source-dirs '("src/main/clojure")
> - #:test-dirs '("src/test/clojure")
> - #:doc-dirs '()))
> + #:test-dirs '("src/test/clojure" "src/test/resources")
> + #:doc-dirs '()
> + #:phases
> + (modify-phases %standard-phases
> + (add-before 'build 'delete-cljs-tests
> + (lambda _
> + (delete-file
> "src/test/resources/clojure/data/xml/cljs_testsuite.clj")
> + (delete-file
> "src/test/clojure/clojure/data/xml/test_cljs.clj"))))))
> (propagated-inputs (list clojure-data-codec)) (synopsis "Clojure
> library for reading and writing XML data") (description
> "@code{data.xml} is a Clojure library for reading and writing

Thanks for the patch, pushed to master as
6d357541021578914eba7bb33d2529a6744de36d.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53868@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53868
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help