telegram-desktop: fails to build

  • Done
  • quality assurance status badge
Details
4 participants
  • Christopher Howard
  • Neo Lynn via web
  • Liliana Marie Prikler
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Liliana Marie Prikler wrote 3 years ago
713a002ee4b33eb9b3ebb07edf0034a4d1cdd053.camel@ist.tugraz.at
Hi Christopher,

Am Montag, dem 07.02.2022 um 09:32 -0900 schrieb Christopher Howard:
Toggle quote (14 lines)
> {standard input}:1918775: Warning: end of file not at end of a line;
> newline inserted
> {standard input}: Error: open CFI at the end of file; missing
> .cfi_endproc directive
> c++: fatal error: Killed signal terminated program cc1plus
> compilation terminated.
> make[2]: *** [Telegram/CMakeFiles/td_scheme.dir/build.make:79:
> Telegram/CMakeFiles/td_scheme.dir/gen/scheme.cpp.o] Error 1
> make[2]: Leaving directory '/tmp/guix-build-telegram-desktop-2.9.3.drv-
> 0/build'
> make[1]: *** [CMakeFiles/Makefile2:1618:
> Telegram/CMakeFiles/td_scheme.dir/all] Error 2
> make[1]: *** Waiting for unfinished jobs....
> ```
According to [1], this happens when GCC runs out of memory. You could
try decreasing parallelism to see how that goes, but I'd hazard a guess
that telegram-desktop is too large for measly 12 gigs of RAM+swap.

Toggle quote (9 lines)
> I will attached the build log. Here is my system information:
>
> ```
> christopher@theoden ~$ guix describe
> Generation 31   Feb 04 2022 09:30:14    (current)
>   guix 8391a99
>     repository URL: https://git.savannah.gnu.org/git/guix.git
>     branch: master
>     commit: 8391a99d089322a39cbacb1e6dc2979d8b2ef7c9
Note that the last build of telegram-desktop succeeded in the
evaluation of commit 11590bff50fe0244e66c11d995aa5301c8965959 [2],
which admittedly is newer than February 4th, but the recipe hasn't
changed in between as far as I'm aware. I therefore don't think that
the package itself is broken.

Cheers


Christopher Howard wrote 3 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)(address . 53857@debbugs.gnu.org)
YgQhjyeyfGWoHUWy@theoden
Hi, when I try to build with `guix build -M 1 -c 1 telegram-desktop` I seem to be getting the same error. I can believe what you say about the ram, as I've run into that problem before with other packages, though it seems frustrating I can't use some kind of command line option or something to tell the linker/compiler/assembler to use less ram. Seems strange that any package should need more than a GB or two of ram to build (*end rant*).

One thing though: using the above command-line options, I see that the last message in the build log is:

```
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("-j" "4") exit-status: 2 term-signal: #f stop-signal: #f>
phase `build' failed after 254.0 seconds
command "make" "-j" "4" failed with status 2
```

Isn't using -M 1 in the guix build options supposed to translate to "make -j 1", or do I misunderstand?

Christopher Howard
Liliana Marie Prikler wrote 3 years ago
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 53857@debbugs.gnu.org)
90486e80cb3fb9abafa593839dfd77ef752de6f3.camel@ist.tugraz.at
Am Mittwoch, dem 09.02.2022 um 11:18 -0900 schrieb Christopher Howard:
Toggle quote (21 lines)
> Hi, when I try to build with `guix build -M 1 -c 1 telegram-desktop`
> I seem to be getting the same error. I can believe what you say about
> the ram, as I've run into that problem before with other packages,
> though it seems frustrating I can't use some kind of command line
> option or something to tell the linker/compiler/assembler to use less
> ram. Seems strange that any package should need more than a GB or two
> of ram to build (*end rant*).
>
> One thing though: using the above command-line options, I see that
> the last message in the build log is:
>
> ```
> error: in phase 'build': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("-j" "4")
> exit-status: 2 term-signal: #f stop-signal: #f>
> phase `build' failed after 254.0 seconds
> command "make" "-j" "4" failed with status 2
> ```
>
> Isn't using -M 1 in the guix build options supposed to translate to
> "make -j 1", or do I misunderstand?
-M 1 tells *guix* how many jobs it should use in parallel. What you're
aiming fore is probably -c 1.
Christopher Howard wrote 3 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)(address . 53857@debbugs.gnu.org)
YgS5gl5cR7eyt5il@nightshade
As mentioned, I used -c 1 as well. Is something wrong in the package that Make still tries to use -j 4?
Neo Lynn via web wrote 3 years ago
telegram-desktop: fails to build
(address . 53857@debbugs.gnu.org)
7efd447af760.b8eea50ff1844de@guile.gnu.org
I got the same error, solved by using a swap partition.
Neo Lynn via web wrote 3 years ago
(address . 53857@debbugs.gnu.org)
7efd447db7d0.65ecff080ba2fe5@guile.gnu.org
If you got a 4G ram like mine, try allocating a swap around 10-15GB, though in proper settings of the compiling task, it is unlikely to hit the 10 GB ceiling. (And it may vary depending on different machines)
Liliana Marie Prikler wrote 2 years ago
940a3b78684239c1af0e7dc601d8906e872110ab.camel@gmail.com
Am Montag, dem 07.02.2022 um 09:32 -0900 schrieb Christopher Howard:
Toggle quote (1 lines)
> telegram-desktop-2.9.3 fails to build:
Telegram was "recently" updated and is now getting proper substitutes
as far as I'm aware.

Does the problem persist?
Liliana Marie Prikler wrote 2 years ago
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 53857-done@debbugs.gnu.org)
36d09c8c7f9f2ba932b301f9661adb109672f4a4.camel@gmail.com
Am Montag, dem 24.10.2022 um 09:13 -0800 schrieb Christopher Howard:
Toggle quote (8 lines)
> I am able to install it normally using the most recent Guix commit.
>
> On Sun, Oct 23, 2022 at 01:41:41PM +0200, Liliana Marie Prikler
> wrote:
> > Telegram was "recently" updated and is now getting proper
> > substitutes as far as I'm aware.
> >
> > Does the problem persist?
Good to know. Closing
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53857@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53857
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help