[PATCH] gnu: Add sbase.

  • Done
  • quality assurance status badge
Details
4 participants
  • jgart
  • Maxim Cournoyer
  • Maxime Devos
  • Xinglu Chen
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 6 Feb 2022 18:56
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220206175618.1710-1-jgart@dismail.de
* gnu/packages/suckless.scm (sbase): New variable.
---
gnu/packages/suckless.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 708eb2c338..af7c0a8801 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -988,6 +988,38 @@ (define-public snooze
running a command.")
(license license:cc0)))
+(define-public sbase
+ (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
+ (revision "0"))
+ (package
+ (name "sbase")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/dylanaraps/sbase")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://core.suckless.org/sbase/")
+ (synopsis "Collection of unix tools that are portable across unix-systems")
+ (description
+ "@command{sbase} is a collection of unix tools that are portable across
+ unix-systems.")
+ (license license:expat))))
+
(define-public scron
(package
(name "scron")
--
2.35.0
X
X
Xinglu Chen wrote on 6 Feb 2022 19:24
(name . jgart)(address . jgart@dismail.de)
87mtj326qk.fsf@yoctocell.xyz
jgart via schrieb am Sonntag der 06. Februar 2022 um 12:56 -05:

Toggle quote (17 lines)
> * gnu/packages/suckless.scm (sbase): New variable.
> ---
> gnu/packages/suckless.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
> index 708eb2c338..af7c0a8801 100644
> --- a/gnu/packages/suckless.scm
> +++ b/gnu/packages/suckless.scm
> @@ -988,6 +988,38 @@ (define-public snooze
> running a command.")
> (license license:cc0)))
>
> +(define-public sbase
> + (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
> + (revision "0"))

What’s the reason for using a specific commit instead of a tag? There
should be a comment about this.

Toggle quote (10 lines)
> + (package
> + (name "sbase")
> + (version (git-version "0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/dylanaraps/sbase")

The homepage points to https://git.suckless.org/sbase/. This Github
repo seems to be private or deleted. Guix wasn’t able to clone it.

Toggle snippet (6 lines)
fatal: could not read Username for 'https://github.com': No such device or address
Failed to do a shallow fetch; retrying a full fetch...
fatal: could not read Username for 'https://github.com': No such device or address
git-fetch: '/gnu/store/avdv1l8zyfnjm8z5f9c4y5fgncqb03zc-git-minimal-2.34.0/bin/git fetch origin' failed with exit code 128

Toggle quote (11 lines)
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ; There are no tests.
> + #:make-flags
> + (list (string-append "CC=" ,(cc-for-target))
> + (string-append "PREFIX=" %output))

Use gexps instead (untested)

,#~(list (string-append "CC=" #$(cc-for-target))
(string-append "PREFIX=" #$output))
Toggle quote (6 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure))))
> + (home-page "https://core.suckless.org/sbase/")
> + (synopsis "Collection of unix tools that are portable across unix-systems")

Capitalize “unix”.

Toggle quote (4 lines)
> + (description
> + "@command{sbase} is a collection of unix tools that are portable across
> + unix-systems.")

Likewise

Toggle quote (2 lines)
> + (license license:expat))))

LICENSE says MIT/X Consortium[1], so it should be ‘license:x11’

-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmIAEmMVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5NdcP/Rv2ehKIMM05auAzD8agEDPvJRLn
XXYzMYL0t4nuH2bomp34bdNR+6NX6GBtpIEbLCYeXPt56ReE7jikWPHzMbeYPmt8
jwWxx4wUk7qUjepblmnq726tATKrBS664ko3F80y3Oi9ozOfMWHzUBjhF2CTXFl8
jS1qE3gC0EaYu79Dtm88lPqJ7ZlxMPmvGWtDDBYAW8XJwhoi1S8P1Abl/4yVvbXt
vXRa5ZAt9lEQOt/iTXOeTfyK/NMmWKgvpOj5+2XZxD/hPhnjZoyR9v7nL5B01l8m
rLm4OMJpqOEGiPxcwjPkCrFkedWNG8V4LgygccX49sBhatvIHd8kQZ5oBKN1BhGp
Vr71N02U3WXzRg6LNvpRraDO8DRG7z6kuS7XcO2HN5lAS5JeDV3HjjNNZLe4sLUy
diq6EkktEMvzKtAutqJ631NE0tiRAG/3Ou/uDE0kJ2cOoJWJzeekWpcrnkD5Zh12
WL7XCIpXvuQZcHrk9yqWHLPP1iG+y4SbE6qzd/EMsXW6ZZuqKVdkj+HcPirl66su
0BRgqKnXPfqPl07ETslWvF4fDtTiJ3I+VmLRmCVenU5BPxkKVIgK1ElMCllRRLA2
4TO/RrlvWASykcjhSbKIvdG4umWjuYkwCbJNcjB8b4HPH5k7q5Avjkm0EKKARGRj
/Ej4+CYmOlFbRPHi
=RsM8
-----END PGP SIGNATURE-----

J
J
jgart wrote on 7 Feb 2022 03:17
[PATCH v2] gnu: Add sbase.
(address . 53825@debbugs.gnu.org)
20220207021717.16045-1-jgart@dismail.de
* gnu/packages/suckless.scm (sbase): New variable.
---

Hi Xinglu,

Not sure how dylanaraps got in that url... :)

Something bugged out or I didn't notice.

Anyways here is version 2 with all of your suggestions.

Thanks for the review, Much appreciated!

all best,

jgart

gnu/packages/suckless.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 708eb2c338..6aedb2b3ba 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -988,6 +988,39 @@ (define-public snooze
running a command.")
(license license:cc0)))
+(define-public sbase
+ ;; There are no tagged releases.
+ (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
+ (revision "0"))
+ (package
+ (name "sbase")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.suckless.org/sbase/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ ,#~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://core.suckless.org/sbase/")
+ (synopsis "Collection of unix tools that are portable across unix-systems")
+ (description
+ "@command{sbase} is a collection of Unix tools that are portable across
+ Unix-systems.")
+ (license license:x11))))
+
(define-public scron
(package
(name "scron")
--
2.35.0
X
X
Xinglu Chen wrote on 9 Feb 2022 14:37
(name . jgart)(address . jgart@dismail.de)
87sfssw47r.fsf@yoctocell.xyz
Hi,

jgart schrieb am Sonntag der 06. Februar 2022 um 21:17 -05:

Toggle quote (58 lines)
> * gnu/packages/suckless.scm (sbase): New variable.
> ---
>
> Hi Xinglu,
>
> Not sure how dylanaraps got in that url... :)
>
> Something bugged out or I didn't notice.
>
> Anyways here is version 2 with all of your suggestions.
>
> Thanks for the review, Much appreciated!
>
> all best,
>
> jgart
>
> gnu/packages/suckless.scm | 33 +++++++++++++++++++++++++++++++++
> 1 file changed, 33 insertions(+)
>
> diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
> index 708eb2c338..6aedb2b3ba 100644
> --- a/gnu/packages/suckless.scm
> +++ b/gnu/packages/suckless.scm
> @@ -988,6 +988,39 @@ (define-public snooze
> running a command.")
> (license license:cc0)))
>
> +(define-public sbase
> + ;; There are no tagged releases.
> + (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
> + (revision "0"))
> + (package
> + (name "sbase")
> + (version (git-version "0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://git.suckless.org/sbase/")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ; There are no tests.
> + #:make-flags
> + ,#~(list (string-append "CC=" #$(cc-for-target))
> + (string-append "PREFIX=" #$output))
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure))))
> + (home-page "https://core.suckless.org/sbase/")
> + (synopsis "Collection of unix tools that are portable across
> unix-systems")

“unix” isn’t capitalized. Whoever merges the patch can probably do it
for you though; no need to send a new reroll.

Otherwise, LGTM. I didn’t test if all the binaries worked though.
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmIDw6gVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5YD8P/ia1UTgppxcRSgflAMfzfnn2z1P3
39cFK67SFHSZmTN9SSrz/lSdHsjpxYdAsIjerObdwG7bH95RU9ASW/ykbKiUAtGm
dXlpkXm3sf3vSBDtIEp9uMmKGZQ9TCAQ6EmceyZ9YtHJtWtPfbDRChNw6fVmU3Du
en9WakEV4UrMKWat4qAGluZ225AwN213C+z37PoTX68UrnwwYgVslygDkctvdGjN
dd4t3Iz4AHDfD+pnqP+NbIh6DW8izdBFiJn6j2ybwOuQWbohYwO5/ijuId5qyBFU
4kT2ndERjTtFAQOgNdU9BKONsqczR7MFNw5lt74n9VnWUJuoNyvJWWQgLDR+wFMK
eamSnn42B6KobJl7DroIaty771QPXkgbFqDP4+H3jZVGOHPysCOuOcXllF3wbotW
5oGvacBT0NPoNcbcrdIIq9mNyfswtf4Wl3UM5MsDWBPK28f4iuK8Mg4Vi1WlzR1G
uYde2/lQkxsoeLJea+S3rsuZ0EhjWII1xTYXHXIrPUWL8bbNrbMcn6MMqllFiTHp
BBxkaAeUXeZLLuSBt5uSh4Cdd2JRpiHv1/F7OXuVMzQxgChtyOMKt3Al3FlOZqkB
s1mBlFLq9znUQCbrvD8lJn37auzRcfi5Izlaq1w3bA5cH7IcAoXjJ54Pte0pb3oj
eUMJaat8EdyOcV7C
=63Tt
-----END PGP SIGNATURE-----

J
J
jgart wrote on 9 Feb 2022 18:57
[PATCH v3] gnu: Add sbase.
(address . 53825@debbugs.gnu.org)
20220209175709.5954-1-jgart@dismail.de
* gnu/packages/suckless.scm (sbase): New variable.
---

Hi,

Here is version 3 with the fix Xinglu mentioned.

I haven't tested all the binaries.

all best,

jgart

gemini://whereiseveryone.srht.site/


gnu/packages/suckless.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 708eb2c338..198e17384e 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -988,6 +988,39 @@ (define-public snooze
running a command.")
(license license:cc0)))
+(define-public sbase
+ ;; There are no tagged releases.
+ (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
+ (revision "0"))
+ (package
+ (name "sbase")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.suckless.org/sbase/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ ,#~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://core.suckless.org/sbase/")
+ (synopsis "Collection of Unix tools that are portable across unix-systems")
+ (description
+ "@command{sbase} is a collection of Unix tools that are portable across
+ Unix-systems.")
+ (license license:x11))))
+
(define-public scron
(package
(name "scron")
--
2.35.0
M
M
Maxime Devos wrote on 20 Mar 2022 16:21
Re: [PATCH] gnu: Add sbase.
(address . 53825@debbugs.gnu.org)
455b4fe4df74f14bf54ad9999cb14de612b29fd0.camel@telenet.be
Toggle quote (2 lines)
> + (license license:x11))))

The license does not have the

Except as contained in this notice, the name of the X Consortium
shall not be used in advertising or otherwise to promote the sale,
use or other dealings in this Software without prior written
authorization from the X Consortium.

X Window System is a trademark of X Consortium, Inc.

clause, so this seems to be the license:expat? Looks like the first
line in LICENSE is incorrect.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYjdGbhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7oLPAP4noByoWB6PqReP0m9kTIz2DNB1
IGq4/f/8/0lMmb2AawD+Nn2/XIUoQL88G25IOeSmZmAFLM1gEAFFLx9RdlUIWg4=
=peov
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 7 Jul 2022 21:57
Re: bug#53825: [PATCH] gnu: Add sbase.
(name . jgart)(address . jgart@dismail.de)
87edywy9uv.fsf_-_@gmail.com
Hi,

jgart <jgart@dismail.de> writes:

Toggle quote (16 lines)
> * gnu/packages/suckless.scm (sbase): New variable.
> ---
>
> Hi,
>
> Here is version 3 with the fix Xinglu mentioned.
>
> I haven't tested all the binaries.
>
> all best,
>
> jgart
>
> https://whereiseveryone.srht.site/
> gemini://whereiseveryone.srht.site/

I've adjusted it like so:

Toggle snippet (43 lines)
modified gnu/packages/suckless.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1011,19 +1012,19 @@ (define-public sbase
(base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; There are no tests.
- #:make-flags
- ,#~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list
+ #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://core.suckless.org/sbase/")
- (synopsis "Collection of Unix tools that are portable across unix-systems")
- (description
- "@command{sbase} is a collection of Unix tools that are portable across
- Unix-systems.")
- (license license:x11))))
+ (synopsis "Collection of UNIX tools")
+ (description "@command{sbase} is a collection of UNIX tools similar to those of GNU
+Coreutils, containing utilities commands such as @command{grep}, @command{cp},
+@command{rm}, etc.")
+ (license license:expat))))
(define-public scron
(package

Reverting the license to Expat as pointed by Maxime, fully capitalizing
UNIX, using a gexp for the phases and adding a few commands to the
description to give a better idea. I've also removed the bits "portable
across UNIX systems" as on Guix that's not useful (the tools are as
portable as Guix itself is).

Pushed as 5299628b90.

Thanks!

Maxim
Closed
?