(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
* gnu/packages/suckless.scm (sbase): New variable.
---
gnu/packages/suckless.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (45 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 708eb2c338..af7c0a8801 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -988,6 +988,38 @@ (define-public snooze
running a command.")
(license license:cc0)))
+(define-public sbase
+ (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
+ (revision "0"))
+ (package
+ (name "sbase")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/dylanaraps/sbase")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://core.suckless.org/sbase/")
+ (synopsis "Collection of unix tools that are portable across unix-systems")
+ (description
+ "@command{sbase} is a collection of unix tools that are portable across
+ unix-systems.")
+ (license license:expat))))
+
(define-public scron
(package
(name "scron")
--
2.35.0