[PATCH] Add the python-databases package.

  • Open
  • quality assurance status badge
Details
2 participants
  • Pierre-Henry Fröhring
  • Ludovic Courtès
Owner
unassigned
Submitted by
Pierre-Henry Fröhring
Severity
normal
P
P
Pierre-Henry Fröhring wrote on 6 Feb 2022 17:09
(address . guix-patches@gnu.org)(name . Pierre-Henry Fröhring)(address . contact@phfrohring.com)
20220206160907.1780570-1-contact@phfrohring.com
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c1b5e8ed3..7049ce61fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28931,3 +28931,31 @@ (define-public python-types-dataclasses
"This packages provides a collection of library stubs for Python, with
static types.")
(license license:asl2.0)))
+
+(define-public python-databases
+ (package
+ (name "python-databases")
+ (version "0.5.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "databases" version))
+ (sha256
+ (base32
+ "0dzb998kg35xmd50ih168320vih2w3ich798r8fc4lf9q4bb1ih2"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-aiocontextvars python-sqlalchemy))
+ (native-inputs (list python-aiosqlite python-asyncmy python-aiomysql
+ python-asyncpg python-aiopg))
+ (home-page "https://github.com/encode/databases")
+ (synopsis "Async database support for Python")
+ (description
+ "Databases gives you simple asyncio support for a
+range of databases.
+
+It allows you to make queries using the SQLAlchemy Core expression language,
+and provides support for PostgreSQL, MySQL, and SQLite.
+
+Databases is suitable for integrating against any async Web framework,
+such as Starlette, Sanic, Responder, Quart, aiohttp, Tornado, or
+FastAPI.")
+ (license license:bsd-3)))
--
2.34.0
L
L
Ludovic Courtès wrote on 24 Mar 2022 23:29
(name . Pierre-Henry Fröhring)(address . contact@phfrohring.com)(address . 53824@debbugs.gnu.org)
87pmmb7zn8.fsf@gnu.org
Pierre-Henry Fröhring <contact@phfrohring.com> skribis:

Toggle quote (15 lines)
> +(define-public python-databases
> + (package
> + (name "python-databases")
> + (version "0.5.5")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "databases" version))
> + (sha256
> + (base32
> + "0dzb998kg35xmd50ih168320vih2w3ich798r8fc4lf9q4bb1ih2"))))
> + (build-system python-build-system)
> + (propagated-inputs (list python-aiocontextvars python-sqlalchemy))
> + (native-inputs (list python-aiosqlite python-asyncmy python-aiomysql
> + python-asyncpg python-aiopg))

All these are presumably used at run time; shouldn’t they be propagated?

Thanks in advance,
Ludo’.
?